Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!


Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 10 of 10
  1. #1
    Member Gersh's Avatar
    Join Date
    Apr 2005
    Location
    Kentucky
    Posts
    225
    Corvette(s)
    2006 DSOM Z06, 2007 Black ZZR, 1968 Charger RT 440

    Default Zero oil pressure

    My wife's 2006 coupe came up with no oil pressure today when she first started it. She checked the oil and the dipstick says it's OK.
    Pretty sure it can't be a blocked filter since I do regular oil and filter changes.
    Is there a way to determine if the problem is the oil pump vs. just the gauge? Either way it needs to be fixed, but she can't drive it to a mechanic if the pump is bad and there really is no pressure...
    Thanks!
    Gersh
    I think, therefore I am
    --Rene Descartes
    I am, therefore I think
    --Gersh Lundberg

  2. #2
    Technical Writer for Internet & Print Media
    Join Date
    Jan 2001
    Location
    Southern California
    Posts
    6,477
    Corvette(s)
    71 95 04 12

    Default

    If the car is still under warranty, I'd call your dealer and tell them to come get it.

    if it's not under warranty, you could try replacing the sender, but if she fired the engine and oil pressure didn't come up within less than a second, there's a good chance the oil pump or other component in the oiling system has failed.

    If you're a DIY you're looking at pan removal to inspect the pickup and oil pump removal to change the pump.

    If you're not a DIY, I'd have the car hauled to a repair facility on roll-back.

  3. #3
    geekinavette's Avatar
    Join Date
    Aug 2002
    Location
    Colorado Springs, CO USA
    Posts
    1,800
    Corvette(s)
    84 Z51 auto R.I.P. Current 89 black roadster

    Default

    Hib...does that engine have the oil filter bypass? (like the old Gen1 SBC)

    I'm just thinking that a "new" oil filter doesn't always mean a good one (especially if its a Fram!). I even had a AC Delco filter block up on me after a week once. You just never know.

  4. #4
    Technical Writer for Internet & Print Media
    Join Date
    Jan 2001
    Location
    Southern California
    Posts
    6,477
    Corvette(s)
    71 95 04 12

    Default

    All production engines have an oil filter bypass. If they didn't and the filter plugged, either the filter would rupture or there'd be no oil pressure. Better to send the engine unflitered oil than to have no oil at all.

    Just curious what was the cause of the ACDelco filter "blocking up"?

  5. #5
    geekinavette's Avatar
    Join Date
    Aug 2002
    Location
    Colorado Springs, CO USA
    Posts
    1,800
    Corvette(s)
    84 Z51 auto R.I.P. Current 89 black roadster

    Default

    I really don't know. It got thrown away before I had a chance to cut it open. I have wondered that ever since! I know ACD filters are one of the higher quality out there, along with Mobil1.

  6. #6
    Technical Advisor c4c5specialist's Avatar
    Join Date
    May 2001
    Location
    New Haven, Ct. USA
    Posts
    3,742
    Corvette(s)
    Nope, but someday.

    Default

    HI there,
    Call the dealership, tell them the problem, and they will come and get it.
    A mechanical test will confirm oil pressure or no.
    Then, possibly, the oil pump could be the issue but the only way to know for sure is to perform the mechanical test.
    Allthebest, c4c5
    GM World Class Certified Technician.
    Like us: www.facebook.com/corvettemechanic
    http://twitter.com/GMvettemechanic
    http://thecorvettemechanic.com
    Podcast: Itunes, search 'the corvette mechanic'

  7. #7
    Member
    Join Date
    Aug 2002
    Location
    wilkes-barre,pa.usa
    Posts
    769
    Corvette(s)
    1988 white 4+3 coupe 99 Torch Red 6spd. coupe

    Default

    Wouldn't the engine have an audible clatter with no oil pressure???

  8. #8
    Member Gersh's Avatar
    Join Date
    Apr 2005
    Location
    Kentucky
    Posts
    225
    Corvette(s)
    2006 DSOM Z06, 2007 Black ZZR, 1968 Charger RT 440

    Default

    Thanks for the help, guys--guess I'll have to trailer it in to the shop, and see what they say.

  9. #9
    Member
    Join Date
    Sep 2006
    Location
    Carlsbad,Ca.
    Posts
    872
    Corvette(s)
    2006 C6Z DSOM

    Default

    Be sure to post back here what the cause is. Did your wife get a warning on the DIC? Are you using MOBIL 1? Check the oil level?

  10. #10
    Member Gersh's Avatar
    Join Date
    Apr 2005
    Location
    Kentucky
    Posts
    225
    Corvette(s)
    2006 DSOM Z06, 2007 Black ZZR, 1968 Charger RT 440

    Default Fixed!

    Quote Originally Posted by NORTY View Post
    Be sure to post back here what the cause is. Did your wife get a warning on the DIC? Are you using MOBIL 1? Check the oil level?
    Yes, I always use Mobil 1. Terri did get a DIC message saying "NO OIL PRESSURE". When I started the car to back it onto the trailer it sounded fine, so I looked at the gauge and it was fine! She ended up driving it to the mechanic, and he changed the oil and filter, ordered a new bypass valve, since there was a factory bulletin about that (it took a week to arrive though we are less than 3 hours from Bowling Green). He thought at first that it was fixed , but no--after sitting it would have no pressure at start-up, then get pressure if he revved it gently. Ended up replacing the oil pump--$1500, since he had to drop the front frame and oil pan to get to it.

    The pump was leaking oil back into the pan when it sat, then had to be revved to suck oil back up and start pumping--not good. The oil pump had metal scorring indicating a little piece of something had been there, but he couldn't find any scrap of metal--evidentally gone with a previous filter change.

    Well, this was just one of FIFTEEN things that have broken down this spring--repairs are keeping us busy...

Similar Threads

  1. question on oil pump replacement
    By grumpyvette in forum C4 General Discussion
    Replies: 1
    Last Post: 11-03-06, 11:31 AM
  2. engine oil
    By LOUVETTE in forum C4 Technical and Performance
    Replies: 32
    Last Post: 05-10-06, 03:27 PM
  3. oil pressure question
    By BarryK in forum C1 & C2 General and Technical Discussion
    Replies: 34
    Last Post: 08-23-04, 04:56 AM
  4. aftermarket pan and high voluum oil pump are worth the cost
    By grumpyvette in forum General Automotive Discussion
    Replies: 1
    Last Post: 01-30-03, 05:13 PM
  5. Oil Temp or Oil Pressure
    By Kritter in forum C3 Technical and Performance
    Replies: 6
    Last Post: 01-24-02, 12:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved