Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!

Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Member
    Join Date
    Jan 2009
    Location
    Garden State
    Posts
    20
    Corvette(s)
    1998 coupe

    Default blinkers/turns signals inconsistant

    hi guys, my blinkers have been sporadic lately. at times either right or left blinker will start flashing super fast..almost as if you have a bulb out(but none are out) i do have leds in the back which i installed about a year ago..i'm wondering where the signal-"flasher" is on a c5? maybe its going bad? is there a heavy duty one that out there? could my led taillights be part of the problem?
    thanks!

  2. #2
    Moderator Toms01's Avatar
    Join Date
    Sep 2004
    Location
    Southwest Kansas
    Posts
    5,021
    Corvette(s)
    2001 Magnetic Red Coupe

    Default

    I'm no expert, but I think you found your own problem. LEDs.....They require so little energy to make them work, they "hyper flash" when installed without a resistor (I think that's what it is) in line.

    2001 Magnetic Red
    / Custom Light Oak/Mag Red interior

    2005 CruiseFest Attendee (Bowling Green, KY)
    2007 CruiseFest Attendee (Colorado Springs, CO)
    2008 CruiseFest Attendee (Cleveland, OH)

    2010 Cruisefest Attendee(Effingham, IL)
    2011 CruiseFest Attendee(Effingham, IL)

    Visit the members GuestMap and show us where you live.

    http://www.mapservices.org/myguestmap/map/TomBachman

    link to thread
    http://www.corvetteactioncenter.com/...c-members.html





  3. #3
    Member
    Join Date
    Jan 2009
    Location
    Garden State
    Posts
    20
    Corvette(s)
    1998 coupe

    Default

    ok. do you know where i can purchase a resistor? something an autozone would have or is it gonna be a car specific special order type deal?

  4. #4
    Moderator Toms01's Avatar
    Join Date
    Sep 2004
    Location
    Southwest Kansas
    Posts
    5,021
    Corvette(s)
    2001 Magnetic Red Coupe

    Default

    Here's a place that you can buy the harness you need .

    C5 LED Hyperflash Harness

    2001 Magnetic Red
    / Custom Light Oak/Mag Red interior

    2005 CruiseFest Attendee (Bowling Green, KY)
    2007 CruiseFest Attendee (Colorado Springs, CO)
    2008 CruiseFest Attendee (Cleveland, OH)

    2010 Cruisefest Attendee(Effingham, IL)
    2011 CruiseFest Attendee(Effingham, IL)

    Visit the members GuestMap and show us where you live.

    http://www.mapservices.org/myguestmap/map/TomBachman

    link to thread
    http://www.corvetteactioncenter.com/...c-members.html





  5. #5
    Member Junkman2008's Avatar
    Join Date
    Aug 2007
    Location
    Kentucky
    Posts
    497
    Corvette(s)
    2001 Navy Blue Metallic Coupe

    Default

    Quote Originally Posted by Toms01 View Post
    Here's a place that you can buy the harness you need .

    C5 LED Hyperflash Harness
    Good call Tom. That's exactly what the problem is. That cable will bypass the hazard switch and resolve the issue.
    "Marines - Making the other guy die for his country for over 200 years."

  6. #6
    Member
    Join Date
    Jan 2009
    Location
    Garden State
    Posts
    20
    Corvette(s)
    1998 coupe

    Default

    ok great. thanks!

  7. #7
    Member Curious George's Avatar
    Join Date
    Oct 2008
    Location
    Orlando, Florida
    Posts
    291
    Corvette(s)
    '92 Red Convertible / '99 Red Convertible

    Default

    You can also do it yourself for $13 and about an hour of time. Search my name and you will find the info. You guys are killing me... why spend $60?

    CG

  8. #8
    Member Junkman2008's Avatar
    Join Date
    Aug 2007
    Location
    Kentucky
    Posts
    497
    Corvette(s)
    2001 Navy Blue Metallic Coupe

    Default

    Quote Originally Posted by Curious George View Post
    You can also do it yourself for $13 and about an hour of time. Search my name and you will find the info. You guys are killing me... why spend $60?

    CG
    Some people have better things to do than fool with their cars. I can't blame them. If I could find a reliable mechanic around me, I probably wouldn't fool with mine.
    "Marines - Making the other guy die for his country for over 200 years."

  9. #9
    Member dougelam's Avatar
    Join Date
    Jul 2011
    Location
    Michigan
    Posts
    49
    Corvette(s)
    2002 Roadster

    Default

    I have a similar but different problem; my right turn signal indicator in the instrument cluster only works half of the time. You can hear it click and the lights flash normally though. The left is fine, would this wire kit have anything to do with this?

  10. #10
    Member Junkman2008's Avatar
    Join Date
    Aug 2007
    Location
    Kentucky
    Posts
    497
    Corvette(s)
    2001 Navy Blue Metallic Coupe

    Default

    Try this. The next time that your blinker acts flaky, hit the hazard switch rapidly a bunch of times. If the blinker starts working, then the cable will fix your problem.

    Understand this, the hazard switch is the problem. The way that the circuit is designed, runs the turn signals circuitry THROUGH the hazard switch. The cable bypasses the hazard switch (or isolates the turn signals from the hazard switch), and that what corrects the issue. You can also replace the hazard switch but that's a lot more work. Parts cost is about the same. The hazard switch will still work after installing the cable.
    "Marines - Making the other guy die for his country for over 200 years."

  11. #11
    Member dougelam's Avatar
    Join Date
    Jul 2011
    Location
    Michigan
    Posts
    49
    Corvette(s)
    2002 Roadster

    Default Fixed

    I solved my "right turn signal indicator only works sometimes" Problem. It turns out that the printed circuit was not seated all the way into the socket on the circuit board on the back of the IPC. The right turn signal positive was the 1st one in the line and you could see it was not in all the way. Re seated it and it is back up and working. it took less than an hour to find and repair, Oh what a relief

    2002 W/Borla Exhaust

  12. #12
    Member Junkman2008's Avatar
    Join Date
    Aug 2007
    Location
    Kentucky
    Posts
    497
    Corvette(s)
    2001 Navy Blue Metallic Coupe

    Default

    Can you post some pictures of what you did? It would make it a lot easier to understand and be helpful for others in your situation. What made you look where you found the problem?
    "Marines - Making the other guy die for his country for over 200 years."

  13. #13
    Moderator Toms01's Avatar
    Join Date
    Sep 2004
    Location
    Southwest Kansas
    Posts
    5,021
    Corvette(s)
    2001 Magnetic Red Coupe

    Default

    Yea, what Junkman said. Pictures and more explanation would be really handy for those of us in the future.

    2001 Magnetic Red
    / Custom Light Oak/Mag Red interior

    2005 CruiseFest Attendee (Bowling Green, KY)
    2007 CruiseFest Attendee (Colorado Springs, CO)
    2008 CruiseFest Attendee (Cleveland, OH)

    2010 Cruisefest Attendee(Effingham, IL)
    2011 CruiseFest Attendee(Effingham, IL)

    Visit the members GuestMap and show us where you live.

    http://www.mapservices.org/myguestmap/map/TomBachman

    link to thread
    http://www.corvetteactioncenter.com/...c-members.html





  14. #14
    Member dougelam's Avatar
    Join Date
    Jul 2011
    Location
    Michigan
    Posts
    49
    Corvette(s)
    2002 Roadster

    Default

    I did not take any pictures, SORRY

    As you can see from the date of this post it has been some time, the junkman was adamant about the cause being the hazard switch so I was going to wait until this spring to address it. Looking at the wiring schematic he sent me it looked like the turn signals are after the switch and if the outside lights worked the inside indicator malfunction must be an inside job-pun intended. So I started my diagnoses by going to the hazard switch connector C-215 and monitored pin-G while the hazards were on and also pin-F for the left side for comparison, both had flashing power.

    Next I removed the IPC and as I pulled it away from the dash I had to unplug C-1 to remove it, I back probed pin A-16 again with the hazards on and again I was getting flashing power. Removed the IPC from the car and brought in to the dinner table.
    Amazing how much better of a work bench it is while the wife is away
    Anyway, I could see the bulb holder in its socket so I took my multimeter and measured resistance across the bulb socket at the printed circuit = 2.0ohms. I then measured from pin A-16 to the bulb and got an open reading. I was not sure if it used logic or was a direct connection so I took of the voltage invertor on the back of the IPC and then the circuit board carrier which was also the back cover as well, it has 3 sets of connections from the printed circuit which are about an inch and a half long each and as I lifted the cover back hinging on the 3 sets I looked at them to release them, the first one which just happen to be the one closest to the right turn indicator I saw it was uneven within the socket. Removed it from the socket and reset it back in and rechecked my measurements and now it has continuity.

    2002 W/Borla Exhaust

  15. #15
    Moderator Toms01's Avatar
    Join Date
    Sep 2004
    Location
    Southwest Kansas
    Posts
    5,021
    Corvette(s)
    2001 Magnetic Red Coupe

    Default

    The emergency flasher is probably the most common problem with the signals. I even had the same problem with my wife's Bonneville. It's good to hear that you troubleshot the issue.

    Thanks to you for stepping us through the solution.

    BTW, I understand about not taking pictures......I always get wrapped up in the repair and forget about taking pictures.

    2001 Magnetic Red
    / Custom Light Oak/Mag Red interior

    2005 CruiseFest Attendee (Bowling Green, KY)
    2007 CruiseFest Attendee (Colorado Springs, CO)
    2008 CruiseFest Attendee (Cleveland, OH)

    2010 Cruisefest Attendee(Effingham, IL)
    2011 CruiseFest Attendee(Effingham, IL)

    Visit the members GuestMap and show us where you live.

    http://www.mapservices.org/myguestmap/map/TomBachman

    link to thread
    http://www.corvetteactioncenter.com/...c-members.html





Page 1 of 2 12 LastLast

Similar Threads

  1. blinkers & turn-signals stop working
    By CCAddict in forum C5 Technical and Performance
    Replies: 1
    Last Post: 06-15-11, 12:55 AM
  2. HELP WITH BLINKERS
    By RONALD50 in forum C5 Technical and Performance
    Replies: 2
    Last Post: 08-17-08, 03:57 PM
  3. Blinkers running too fast
    By djxib in forum C4 Technical and Performance
    Replies: 1
    Last Post: 09-03-04, 08:02 AM
  4. No Blinkers
    By 84Vette in forum C3 Technical and Performance
    Replies: 3
    Last Post: 06-11-03, 08:31 PM
  5. my blinkers don't blink!
    By quickjagg in forum C3 Technical and Performance
    Replies: 6
    Last Post: 05-17-02, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved