Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!


Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Jun 2011
    Location
    Georgia
    Posts
    73

    Default Gauges button not working

    My CHANGE OIL light has been on since I bought the car. I changed the oil and follwed the steps to turn the change oil light off, it did not work. I have found that the GAUGES button does not function at all. Where do I start trying to find the issue? Should I do a CCM diagnosis or something else? Maybe a fuse that I am not seeing is blown somewhere? Hope for some info so I can correct another PO issue.

  2. #2
    Member
    Join Date
    Jun 2011
    Location
    Georgia
    Posts
    73

    Default

    I spooke to Junkie yesterday, he recommended taking the switches out and cleaning and checking them. Got it tore open and found the GAUGES button will not depress like the others do. I have played with it a few hours and have made no progress. Looks like I might need a new cover and swithes so I can reset my change oil light and get the gauges button to function correctly.

  3. #3
    Robertwav1's Avatar
    Join Date
    Jan 2003
    Location
    Apollo Beach, Florida
    Posts
    716
    Corvette(s)
    1993 Blue

    Default

    Hey Tim,

    Like many things on this car I've found most of the buttons and switches can be cleaned...i.e. radio, AC and heat controls, window switches etc. I've always taken them out of the car and look at them with a glass to see how they come apart. So far I've been able to correct everything that way. More then wear they ususally need a little cleaning. Again when you look at them with a glass you can understand why they don't work. Good Luck!

  4. #4
    Member
    Join Date
    Jun 2011
    Location
    Georgia
    Posts
    73

    Default

    I took the DIC out two nights ago and found one of the locking tabs on the gauges button was broken. Removed teh broken piece and put it back in yesterday morning and have it working correctly now. Thanks for your help and replies.

Similar Threads

  1. Help! Digital gauges not working
    By Eddie tee in forum C4 Technical and Performance
    Replies: 3
    Last Post: 10-02-09, 07:20 PM
  2. Digital Gauges quit working
    By Eddie tee in forum C4 Technical and Performance
    Replies: 2
    Last Post: 09-22-09, 06:49 PM
  3. Help! gauges in C6
    By sjrenrew in forum C6 Technical and Performance
    Replies: 9
    Last Post: 08-21-09, 10:04 AM
  4. Help! Gauges
    By ds3056 in forum C1 & C2 General and Technical Discussion
    Replies: 3
    Last Post: 09-10-08, 01:10 PM
  5. Gauges!!!!!!
    By 69MyWay in forum C3 Technical and Performance
    Replies: 7
    Last Post: 11-19-01, 06:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved