$projecthp
  • New LT4 owner here.. Cheap car but has issues.
  • New LT4 owner here.. Cheap car but has issues.
  • New LT4 owner here.. Cheap car but has issues.
  • New LT4 owner here.. Cheap car but has issues.

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    New Member
    Join Date
    Sep 2019
    Location
    CrystaL Lake IL
    Posts
    2
    Corvette(s)
    1996 stickshift
    Post Thanks / Like
    Rides
    0

    Default New LT4 owner here.. Cheap car but has issues.

    Car has 105k- looks very neglected in the detail department. Heater core leaked into cabin (as well as hatch weatherstrip and windshield/hatch weatherstrip. He bypassed the heater core to sell the car. Last owner said the fuel pump went out and he replaced it with a chinese one that he had to reverse the polarity. He gave me the take out and I confirmed it was locked up.
    I started my drive home-- clutch grabs at the tippie top of the travel--- and one caliper was dragging (he did tell me he had loosened up the parking brake---also putting the tires on the wrong sides when reinstalling them so I did believe him. Got about 5 miles into my 10 mile ride home and the car turns off. Cranked over fine but no prime sound or start. I assumed he did something incorrect with the fp replacement... Flatbed the car home and PUSH hard into garage before the rain came.

    So here I am...

    His replacement fuel pump in the tank works when hooked directly to 12v.
    I found the 10a dash fuse unblown but contact was intermittent with a ohm meter... very strange.
    I replaced the fuse, plugged the fuel tank harness back in and car starts.

    I ask myself "Was it, could it REALLY be a crapped out fuse or did my direct hook up to 13.5v spin the new fp over a dead spot?"

    Any suggs on the clutch issue?

    The gauges seem to work with exception of the speedo/fuel pod (they may but I can't see them). There is no orange backlight and no visible speedo number or fuel leds... I flipped on the lights and there is absolutely no backlighting to any of the main instrument panel- lights on or off....

    There are a zillion lights lit on the info pod regarding asr and abs I think three for each..... but no service engine soon or airbag!

    Lastly-- how the heck do you get that musty, mildewy smell out of the car???? Doors, hatch and lid have been open 7 days now...still smells like ass. (I do plan on buying carpet and a full weatherstrip kit.)

    This thing is a terd but for what we are using it for the $2750 price was right.

    Ps... Tx for the join.
    Last edited by nickate; 09-15-19 at 11:09 PM.

  2. #2
    Moderator Toms007's Avatar
    Join Date
    Sep 2004
    Location
    Southwest Kansas
    Posts
    6,209
    Corvette(s)
    2007 Atomic Orange Coupe
    Post Thanks / Like
    Rides
    2

    Default

    Welcome to CAC! Sounds like the car has been neglected for some time. The 105K on the clock shouldn't be a big deal (as long as maintenance wasn't neglected as well) as these engines go for a long time. For what they cost, I'd be considering a new (USA made) fuel pump. The new carpeting, I believe, will go a LONG way to ridding yourself of the nasty smell.

    I'm not much help on the clutch issue, hopefully someone else will be by soon to help you with that. Again welcome to CAC.
    2007 Atomic Orange Coupe Cashmere/black interior

    2005 CruiseFest Attendee (Bowling Green, KY) 2007 CruiseFest Attendee (Colorado Springs, CO)
    2008 CruiseFest Attendee (Cleveland, OH)
    2010 Cruisefest Attendee(Effingham, IL)
    2011 CruiseFest Attendee(Effingham
    , IL)

    Formerly owned Corvettes: 1964 coupe, 1994 coupe, 2001 coupe


  3. #3
    Member
    Join Date
    Aug 2006
    Location
    S-NJ
    Posts
    300
    Corvette(s)
    93 Ruby Aniv roadster/6spd
    Post Thanks / Like
    Rides
    0

    Default

    Under the carpet theres a thin rubber coating over a thick jute like insulation. So ya might have to replace that also.I had a Pass side leak I could never find so I removed all the carpet in cockpit & actually drilled a few holes in the floor board to remove the water,If it leaking around the rear hatch its in the corners of the halo.That was in my old 85,no leaks in the old 90 or my current 93.
    Currently 93 Ruby 40th Anniversary Roadster/6 SPD

    Previous 58,68,70,76,78,85,90

  4. #4
    Member vett boy's Avatar
    Join Date
    Feb 2005
    Location
    NH ,ME,FL,MS
    Posts
    3,028
    Corvette(s)
    2008 vert 6M silver
    Post Thanks / Like
    Rides
    0

    Default

    First i'd like to say that that C5's are great cars .My first corvette was a 69 and I loved dumping money into it but at least I could do it at my own pace .When I decided to replace the carpet I bought the package from Knauf (spelling ?).I remembering the amazing amount of pieces .Had a friend helping and he called me one evening ,he was removing the carpet in-under the rear deck .His question was what did I want to do with the wires going to the trailer hitch ??

Similar Threads

  1. Site Update: 1959 Corvette: Service Bulletin: Missing Glove Box Items: Owner`s Manual - Owner`s Protection Policy
    By Rob in forum C1 & C2 General and Technical Discussion
    Replies: 0
    Last Post: 12-26-14, 09:40 AM
  2. Jeep Owner Teaches Corvette Owner a Lesson?
    By Rob in forum News and Announcements Forum
    Replies: 8
    Last Post: 09-25-14, 06:36 PM
  3. Current Owner Seeks First Owner
    By yellow_2002_germany in forum C1 & C2 General and Technical Discussion
    Replies: 0
    Last Post: 05-10-10, 05:16 PM
  4. New LT4 owner with several issues, HELP!!
    By BIG CTY in forum LT4 Forum
    Replies: 4
    Last Post: 12-12-08, 12:49 AM
  5. Original '68 Vette owner seeks current owner
    By billarf in forum C3 Parts For Sale / Wanted
    Replies: 1
    Last Post: 07-15-03, 06:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •