Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    New Member
    Join Date
    Apr 2009
    Location
    Turlock, Ca
    Posts
    11
    Post Thanks / Like
    Rides
    0

    Default Emission questions

    My 81 4 speed will not pass Cal. emission testing, it failed the visual inspection. I bought a hose replacement kit with a diagram of emission hose routing but it does not match the emission sticker. The EGR area and where hoses connect to the carburator is a mystery. Photos of a stock engine with the air cleaner removed would be greatly appreciated. I am interested in purchasing a spare ECM wire harness (mine is missing) and a complete EGR soleniod.

    Also there are 2 ea. 6 wire connectors on the firewall near the wiper motor, male and female, do they go together? There are also a couple of other wires that i have no idea where they go. Any ideas?

  2. #2
    Member
    Join Date
    May 2003
    Location
    Netherlands
    Posts
    2,497
    Post Thanks / Like
    Rides
    0

    Default

    Hello Kosbahr,

    Welcome to the L81 forum
    I have a couple of questions for you to see if you still have the correct parts.
    Do you still have the E4ME Rochester Quadrajet Carb? Easy to see, when you remove the aircleaner you should see on top in front if the right primary airvalve a 2 pin connector and in front of the carb on the right side a 3 pin connector.
    And second do you have a HEI ignition that also has a (I think) 4 or 5 pin connector?

    You need these two items to let the ECM work properly.

    What I see in the picture is (as you say) you're missing the ECM wiringharness on top of the engine. The wiringharness connects to all the solenoids and MC and TPS etc etc, but if you don't have the right carb (as I suspect) then you need more then just the wiringharness (also the ECM controlled HEI ignition).
    The two big connectors don't go together. I believe the previous owner had some problems with the carb and changed everything to work without the ECM (just a guess of course!).
    Here some pictures of my engine..





    Good luck

    Groeten Peter

  3. #3
    Member
    Join Date
    May 2009
    Location
    florida
    Posts
    121
    Post Thanks / Like
    Rides
    0

    Default

    does this help? theres more where that came from...










  4. #4
    New Member
    Join Date
    Apr 2009
    Location
    Turlock, Ca
    Posts
    11
    Post Thanks / Like
    Rides
    0

    Default

    Thanks for the photos. I have installed the correct carburator and distributor, exhaust heat riser valve, EGR?? TVS. I found what I think is half of the ERG soleniod bolted to the backside of the head. It doesn't have the red half. Anyone know where I could find an EGR soleniod and bracket for the top of the manifold? I also need to locate the ECM wire harness. I called lectriclimited and they have discontinued the item.

  5. #5
    Member
    Join Date
    May 2003
    Location
    Netherlands
    Posts
    2,497
    Post Thanks / Like
    Rides
    0

    Default

    I find it amazing that your engine is still running without all the electric stuff. The primary rows go up and down with a solenoid but if the solenoid doesn't get any info I don't know how it is running, my problem of course

    I think you'll have the best change to call some of the bigger corvette graveyards like contamporary corvettes. Maybe they can help you out.
    Good luck!

    Groeten Peter

  6. #6
    New Member
    Join Date
    Apr 2009
    Location
    Turlock, Ca
    Posts
    11
    Post Thanks / Like
    Rides
    0

    Default

    I removed a Holley and HEI dist. and installed the OEM parts. I've also installed a new heat riser valve, EFE TVS and have new hoses. I called several corvette salvage yards today and had no luck locating the EGR solenoid. The search continues.

Similar Threads

  1. General questions from a prospective C3 owner
    By entropy454 in forum C3 General Discussion
    Replies: 28
    Last Post: 10-26-08, 11:14 AM
  2. Texas Smog Laws
    By jnenni in forum C3 General Discussion
    Replies: 10
    Last Post: 04-09-07, 08:09 PM
  3. Questions....more questions....
    By LannyL81 in forum L81 Vette Registry Forum
    Replies: 1
    Last Post: 01-01-04, 07:33 PM
  4. A Couple questions on my 77
    By PHXVETTE in forum C3 Technical and Performance
    Replies: 4
    Last Post: 11-19-02, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •