$projecthp
Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Jul 2016
    Location
    malaga
    Posts
    5
    Corvette(s)
    2005 2005 silver C6
    Post Thanks / Like
    Rides
    0

    Default random shutdown with no codes.

    Hi guys
    2005 C6 M6, no mods.
    I have a strange problem with car randomly shutting down, it will start right up again but i dont trust to take the car out anywhere incase it shuts off at speed in an awkward place.
    I have followed the FSM with my Tech2 and everything checks out perfectly.
    I have new plugs, cables, MAS, CAM sensor i have had the injectors flow tested, balanced with new O rings etc by Bosche.
    I have electrically tested all injector harness and ignition harness with DVOM and scope.
    fuel trims are all around 0 +-2.
    Fuel pressure at the rail is 60PSI with no drop past 51PSI with pump off,
    Drivers side fuel module replaced (complete unit with pump regulator, filter etc)
    There is only one thing that is not making sense to me....the fuel gauge will not move past nearly half no matter how much fuel i put in. The readings on the Tech2 for the left and the right fuel tank fuel level sensors seem outta wack.
    The right fuel level sensor reads 0.71 volts which means empty, and the left fuel level sender reads 4.98 volts, but according to the FSM should read 2.0 Volts for full.
    so i'm guessing that i have a problem with the right fuel level sensor somehow, but would that cause random stalls?
    I would have thought that if right tank reads empty but left is full then it should still run as normal.
    There are no codes at all on the Tech2 so a bit confused.
    I'm wondering if there was a loose connector from the right tank, but then why am i seeing 0.7 volts on Tech2?
    Any advice greatly appreciated.

  2. #2
    Technical Writer for Internet & Print Media
    Join Date
    Jan 2001
    Location
    CenCoast CA
    Posts
    11,949
    Corvette(s)
    71 04 12 19
    Post Thanks / Like
    Rides
    0

    Default

    Apparently, your problem is unrelated to engine controls.

    Is this the engine running out of fuel or the car's electrical system loosing power?

    I would start looking at the battery along with battery cables, large wires that feed the fuse blocks.

    Also, look at chassis grounds.

    Finally, use your T2 to read any codes which are set but that do not turn on warning lights, especially Uxxxx codes.

  3. #3
    New Member
    Join Date
    Jul 2016
    Location
    malaga
    Posts
    5
    Corvette(s)
    2005 2005 silver C6
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Hib Halverson View Post
    Apparently, your problem is unrelated to engine controls.

    Is this the engine running out of fuel or the car's electrical system loosing power?

    I would start looking at the battery along with battery cables, large wires that feed the fuse blocks.

    Also, look at chassis grounds.

    Finally, use your T2 to read any codes which are set but that do not turn on warning lights, especially Uxxxx codes.
    Thanks for the reply.
    Plenty of fuel in tank, around 25 Ltr
    Fuel pressure 60 PSI at the rail under idle.
    Battery is reading good volts, Ground wire to fuse box cleaned and secure
    Chassis ground especially G107 all checked and are clean and tight on the block.
    No codes at all on T2 just the usual radio one because i swapped out the OEM radio for an aftermarket so code not relevant.

Similar Threads

  1. Question: Redline Shutdown
    By Hawksnest in forum C7 General Discussion
    Replies: 1
    Last Post: 04-01-18, 06:36 PM
  2. Help! 05 Shutdown gremlin
    By 84jet4rs in forum C6 General Discussion
    Replies: 13
    Last Post: 01-28-15, 10:38 PM
  3. 84 electrical shutdown random left turn only
    By monte70 in forum C4 Technical and Performance
    Replies: 3
    Last Post: 08-26-03, 04:23 PM
  4. Help - Clunking under car due to ZR-1 shutdown ??
    By Volunteer in forum C4 Corvette ZR-1
    Replies: 4
    Last Post: 08-30-02, 08:17 AM
  5. Random shutdown.....
    By Topless in forum C4 Technical and Performance
    Replies: 4
    Last Post: 06-09-02, 09:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •