Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Sep 2009
    Location
    NJ
    Posts
    69
    Post Thanks / Like
    Rides
    0

    Default no heat in the seat

    hi, my 10,000mi 08 z51 m6 drivers side heated seat switch has no lights and no heat what could be wrong? thanks kraz

  2. #2
    Member o2bnkc's Avatar
    Join Date
    May 2004
    Location
    Carson City, Nv.
    Posts
    447
    Post Thanks / Like
    Rides
    0

    Default

    And I remember the days when we complained about the cupholders in the c5's. Just kidding, kraz. If I had heated seats, I'd sure want the damn things to work. Since I don't, and you probably want real answers instead of wise ass remarks like this, let's see what the experts say. Good luck!
    A Proud U.S. Navy Veteran

  3. #3
    Member
    Join Date
    Sep 2006
    Location
    Carlsbad,Ca.
    Posts
    851
    Post Thanks / Like
    Rides
    0

    Default

    Fuse?

    Did you remove the seat and forget to (un)plug in the recepticle?

    Have a CEL?

    Does the pass seat heat operate?

  4. #4
    Member
    Join Date
    Dec 2009
    Location
    North Texas
    Posts
    354
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by NORTY View Post
    Fuse?

    Did you remove the seat and forget to (un)plug in the recepticle?

    Have a CEL?

    Does the pass seat heat operate?

    Also Norty, if he did not buy his Vette new, then it may have had mild 2 wild controller in it. I believe that the heated seat fuse slot is where one of the leads connects too. Maybe he should check to ensure the fuse is there and working....it IS the same I found for both Z51 AND Z06....(the fuse slots on pass side interior floor.....

  5. #5
    Registered User
    Join Date
    Sep 2009
    Location
    NJ
    Posts
    69
    Post Thanks / Like
    Rides
    0

    Default

    hi norty, 1 no 2 no 3 yes the pass seat works do you think its the fuse i dont have mild to wild on my vette thanks kraz

  6. #6
    no heat in the seat vett boy's Avatar
    Join Date
    Feb 2005
    Location
    NH ,ME,FL,MS
    Posts
    2,948
    Post Thanks / Like
    Rides
    0

    Default

    I can't help ya .I just want to say that I can grill a pretty thick steak on mine .:d

  7. #7
    Registered User
    Join Date
    Sep 2009
    Location
    NJ
    Posts
    69
    Post Thanks / Like
    Rides
    0

    Default

    funny

  8. #8
    Member
    Join Date
    Dec 2009
    Location
    North Texas
    Posts
    354
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by kraz View Post
    funny
    and a real nice guy.....

  9. #9
    Registered User
    Join Date
    Sep 2009
    Location
    NJ
    Posts
    69
    Post Thanks / Like
    Rides
    0

    Default

    i got it fixed loose wire ya got some steaks for me

  10. #10
    no heat in the seat vett boy's Avatar
    Join Date
    Feb 2005
    Location
    NH ,ME,FL,MS
    Posts
    2,948
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by kraz View Post
    i got it fixed loose wire ya got some steaks for me
    I'll tell ya when it works it WORKS .GM didn't skip on BTU's .My wife has a Ford Escape and they are gentle warm with auto shut off .The Corvette cooks your azz to medium well .

    Really glad ya got it fixed.

  11. #11
    Registered User
    Join Date
    Sep 2009
    Location
    NJ
    Posts
    69
    Post Thanks / Like
    Rides
    0

    Default

    thanks kraz

Similar Threads

  1. Question: Seat Problem Adjusting-Driver's seat
    By Bill Coke in forum C5 Technical and Performance
    Replies: 3
    Last Post: 06-08-09, 02:11 PM
  2. Question: Seat adjustment problem after BCM installed
    By Bill Coke in forum C5 General Discussion
    Replies: 0
    Last Post: 06-04-09, 10:27 AM
  3. Sport seat lumbar bladder replacement
    By Inertia 500 in forum C4 Technical and Performance
    Replies: 10
    Last Post: 05-08-07, 01:58 PM
  4. Warning About DR. TIRES
    By toolman44092 in forum C5 General Discussion
    Replies: 23
    Last Post: 05-04-05, 08:28 AM
  5. Exhaust Wrap...
    By Ken in forum General Automotive Discussion
    Replies: 2
    Last Post: 07-29-03, 03:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •