$projecthp
Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 13 of 13
  1. #1
    caps
    Guest

    Default Driver information center inop?

    Some time ago I posted a problem with my DIC operating intermittently and occasionally inop. A technical advisor recommended I replace the switch having diagnosed my problem as a sticking switch. I replaced the switch and the problem still exists? Anyone have any suggestions where to look next?

    Thanks,

  2. #2
    Technical Advisor c4c5specialist's Avatar
    Join Date
    May 2001
    Location
    New Haven, Ct. USA
    Posts
    3,682
    Corvette(s)
    Nope, but someday.
    Post Thanks / Like
    Rides
    0

    Default

    HI there,
    Can you elaborate on what exactly is wrong with your DIC?????
    Please be precise as to what works and doesnt work.
    Allthebest, c4c5
    GM World Class Certified Technician.
    Like us: www.facebook.com/corvettemechanic
    http://twitter.com/GMvettemechanic
    http://thecorvettemechanic.com
    Podcast: Itunes, search 'the corvette mechanic'

  3. #3
    caps
    Guest

    Default

    Thanks for the reply,


    When the malfunction first occurred the DIC would just start going through a cycle "Trip A, Trip B, Elapsed time, etc" this would happen without even touching a button. Then when I would push a button on the switch panel (fuel, guages, trip, reset, etc.) nothing would happen. Sometimes when I first would get in the car it would seem to work just fine, then after driving for 5 or 10 minutes it would start going through this "cycle". I changed the switch hoping this would solve the problem, but no luck? It currently does not respond to any input, I can press any switch and nothing happens, it just reads the odometer. When I open the trunk it indicates so, when a door is open it indicates so, upon start up it goes through its usual cycle "corvette by chevrolet". All my analog gauges work fine, I just can't get the DIC to respond.

    I appreciate your help.

  4. #4
    Redcars
    Guest

    Default Dic problems same as -- caps Z06

    Caps, I have exactly the same problem with my FRC. I've had the IPC several
    times, checked the DIC switch with a multi meter all seems ok. I've even
    checked all the wires going to IPC making sure it was not a broken wire.
    If and when you find your problem i would appreciate your reply to the
    forum or---E/mail me at eimuller@cox.net

    Thanks, Redcars

  5. #5
    caps
    Guest

    Default

    Glad to know I am not the only one out there that has had this problem (misery loves company). I will definately let you know if I find the solution to this problem. Fortunately it is not something that keeps me from driving the car or does it hinder the performance.

  6. #6
    caps
    Guest

    Default

    Quote Originally Posted by c4c5specialist
    HI there,
    Can you elaborate on what exactly is wrong with your DIC?????
    Please be precise as to what works and doesnt work.
    Allthebest, c4c5
    c4c5 specialist,

    I recently replied with how my Driver Information Center was performing. Were you able to identify what might be my next step?

    Appreciate any suggestions.

  7. #7
    Redcars
    Guest

    Default

    Caps, Thanks for your reply,to bring you up to speed take a look at page (5) of
    corvettemechanic.com under DIC problems. I listed some of the code before my
    IPC started listing only KM-STAND 24922 (mileage) which works correctly, along with
    all mechanical gauges working properly. I,m hoping C4C5 will help us out with this problem. I also checked fuses #25,#19 and both are ok. I do have a location question
    on #1,#2 star connectors? Thanks, Redcars

  8. #8
    Technical Advisor c4c5specialist's Avatar
    Join Date
    May 2001
    Location
    New Haven, Ct. USA
    Posts
    3,682
    Corvette(s)
    Nope, but someday.
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by caps
    c4c5 specialist,

    I recently replied with how my Driver Information Center was performing. Were you able to identify what might be my next step?

    Appreciate any suggestions.
    HI there,
    From what you are telling us, there seems to be a switch that is holding and not making contact, or contact all the time.
    Or, the DIC is NOT giving the correct voltage to the switches to begin with.
    What I would do, is ask what exactly happened after the switch was replaced, and were all the pins drag tested to make sure that there is enough contact on the terminals itself????????
    Please keep us posted, c4c5
    GM World Class Certified Technician.
    Like us: www.facebook.com/corvettemechanic
    http://twitter.com/GMvettemechanic
    http://thecorvettemechanic.com
    Podcast: Itunes, search 'the corvette mechanic'

  9. #9
    caps
    Guest

    Default

    After I replaced my DIC switches, reassembled the dash, and hooked up the battery. I put the key in the ignition turned it to the "on" position. DIC scrolled across "Corvette by chev" as it usually does, upon starting the engine the odometer was now reading in the DIC. I pressed each switch, and no response, same problem I had prior to replacing the switch. I did not drag test the pins when I had the assembly out. I really don't want to pull this dash apart again if I don't have to. Where would my next step be in diagnosing this malfunction? Your help is greatly apprecated.

  10. #10
    caps
    Guest

    Default

    Quote Originally Posted by Redcars
    Caps, Thanks for your reply,to bring you up to speed take a look at page (5) of
    corvettemechanic.com under DIC problems. I listed some of the code before my
    IPC started listing only KM-STAND 24922 (mileage) which works correctly, along with
    all mechanical gauges working properly. I,m hoping C4C5 will help us out with this problem. I also checked fuses #25,#19 and both are ok. I do have a location question
    on #1,#2 star connectors? Thanks, Redcars
    Redcar,

    I will check out corvettemechanic.com and check out your reference.

    Caps

  11. #11
    Redcars
    Guest

    Default

    CAPS see new post in corvettemechanic.com page 5 DIC

  12. #12
    Redcars
    Guest

    Default

    Hi all.
    Seems strange there are only Two C5 members that have problems with the
    drivers instrument cluster.Or possibly everyone is taking the car to the dealer?
    Has anyone disassembled the cluster to check connection? I would appreciate
    anyone's help.
    Thanks, Redcars

  13. #13
    New Member
    Join Date
    Aug 2003
    Location
    Boca Raton Fl.
    Posts
    5
    Corvette(s)
    1995 Coup
    Post Thanks / Like
    Rides
    0

    Default Dic reset problems

    Need help also, the DIC is working fine the only thing the reset switch, only resets part of the time, can this switch be replased? or is there a fix.

Similar Threads

  1. Corvette Action Center For PalmPilots
    By Rob in forum News and Announcements Forum
    Replies: 5
    Last Post: 01-23-03, 04:42 PM
  2. New Release: 1996 Corvette Center
    By Rob in forum C4 Technical and Performance
    Replies: 0
    Last Post: 03-27-02, 10:05 AM
  3. Steering returning to center on a '73
    By Steve's73 in forum C3 Technical and Performance
    Replies: 6
    Last Post: 02-22-02, 10:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •