$projecthp
  • Engine Light Back On, Need Advice
  • Engine Light Back On, Need Advice
  • Engine Light Back On, Need Advice
  • Engine Light Back On, Need Advice

Thanks Thanks:  0
Dislikes Dislikes:  0
Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Aug 2019
    Location
    Chicago
    Posts
    4
    Corvette(s)
    2002 Millenium Yellow 6 speed Coupe
    Post Thanks / Like
    Rides
    0

    Default Engine Light Back On, Need Advice

    Okay so about two weeks ago my engine light came on. P0131. Bank 1 sensor 1 O2 sensor, low voltage. So I replaced the sensor. Today, codes P0131 and P0151 (both upstream O2 sensors low voltage), were thrown when my engine light came back on. What could be causing this? Car seems to be running fine. Someone told me it could be a dirty Mass Air Flow sensor, which could be throwing off the readings of the upstream O2 sensors? That's odd that they both went off at the same time, especially after I just replaced the one. Another thing I've heard is a vacuum leak.


    Not sure if this matters, but the engine light came on under the exact same conditions both times. After about an hour of spirited driving with fairly regular wide open throttle pulls.


    What do you guys think?
    Last edited by Evan97; 08-25-19 at 09:49 PM.

  2. #2
    Member LLC5's Avatar
    Join Date
    Sep 2004
    Location
    Wa.
    Posts
    2,282
    Corvette(s)
    98 black 6spd convert.
    Post Thanks / Like
    Rides
    0

    Default

    I would be looking for a vacuum leak, I use propane and a hose. The PCV hose on the throttle body is known to deteriorate, I would try there first. Do a close visual for any wiring chafing or rodent damage even if stored in a garage.
    Master Technician

    25+ year ASE Master Certified Tech

    22+ year Honda Master Tech
    Likes vett boy liked this post

Similar Threads

  1. Question: Need some light bulb advice.
    By killain in forum C4 General Discussion
    Replies: 1
    Last Post: 09-20-14, 03:38 PM
  2. Back Up Light Switch R & R
    By CAJUN C4 in forum C4 Technical and Performance
    Replies: 0
    Last Post: 01-20-09, 06:53 PM
  3. how to make a check engine light, and low fuel light work again
    By topless82vette in forum C3 General Discussion
    Replies: 6
    Last Post: 09-08-08, 11:34 PM
  4. Advice needed to mount shoulder harness clips on the seat back of a 69
    By 69L88clone in forum C3 Technical and Performance
    Replies: 6
    Last Post: 09-02-07, 09:23 AM
  5. Back up light switch on 73
    By jmoldfield in forum C3 Technical and Performance
    Replies: 0
    Last Post: 08-05-07, 03:13 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •