• Parking brake handle went limp- cable disconnected?
  • Parking brake handle went limp- cable disconnected?
  • Parking brake handle went limp- cable disconnected?
  • Parking brake handle went limp- cable disconnected?

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Member Bluemill's Avatar
    Join Date
    Jul 2005
    Location
    Scituate, MA
    Posts
    106
    Corvette(s)
    2000 Navy targa
    Post Thanks / Like
    Rides
    0

    Default Parking brake handle went limp- cable disconnected?

    Hi Supertechs,


    My C5 coupe is now at 122,000 miles, and has been running well for many years. I did a beer run this afternoon and while at the retailer, I set the parking brake as per usual, and it worked fine. When I got home a few minutes and 4 miles later, I pulled on the emergency brake, and it had no resistance, i.e., went all the way up, and I knew I had nothing. To make sure I pulled out on my driveway, which is about 150 ft. long and slightly pitched. I took it to the top of the hill and coasted and tried to stop the car with the handbrake, also to adjust, as I was coasting in reverse. Nothing. It's like the cable just let go, as if the plug at the end of the cable slid off.


    The service brake is fine so I brought it back to the garage and parked it in first.


    What is the first thing to check, second, etc. The service manual is a bit intimidating as far as the possibilities... The good news is that I'm retired and have a lot of time to attack it, the bad is that it's freaking cold in January in the Boston area!


    Thanks for any advice!


    Best always,


    Bluemill

  2. #2
    Member LLC5's Avatar
    Join Date
    Sep 2004
    Location
    Wa.
    Posts
    2,066
    Corvette(s)
    98 black 6spd convert.
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Bluemill View Post
    Hi Supertechs,


    My C5 coupe is now at 122,000 miles, and has been running well for many years. I did a beer run this afternoon and while at the retailer, I set the parking brake as per usual, and it worked fine. When I got home a few minutes and 4 miles later, I pulled on the emergency brake, and it had no resistance, i.e., went all the way up, and I knew I had nothing. To make sure I pulled out on my driveway, which is about 150 ft. long and slightly pitched. I took it to the top of the hill and coasted and tried to stop the car with the handbrake, also to adjust, as I was coasting in reverse. Nothing. It's like the cable just let go, as if the plug at the end of the cable slid off.


    The service brake is fine so I brought it back to the garage and parked it in first.


    What is the first thing to check, second, etc. The service manual is a bit intimidating as far as the possibilities... The good news is that I'm retired and have a lot of time to attack it, the bad is that it's freaking cold in January in the Boston area!


    Thanks for any advice!


    Best always,


    Bluemill


    I would start by pulling the back rotors and checking the parking brake shoes on both sides, you can also check cable movement at the shoes.
    Master Technician

    25+ year ASE Master Certified Tech

    22+ year Honda Master Tech

  3. #3
    Member Bluemill's Avatar
    Join Date
    Jul 2005
    Location
    Scituate, MA
    Posts
    106
    Corvette(s)
    2000 Navy targa
    Post Thanks / Like
    Rides
    0

    Default

    Thanks LL. You are always there for me. It's 15 degrees F in the garage right now so I doubt I'll be chasing this repair today. I hope I don't need new cables, especially the upper one, as they do look buried under a lot of work!
    Still got my Ridgeline, and did the timing belt at 107,000 miles.

Similar Threads

  1. Parking brake handle question
    By FFAST87 in forum C4 General Discussion
    Replies: 10
    Last Post: 04-08-18, 01:48 PM
  2. Help! Parking brake handle fastener
    By TPAW in forum C4 General Discussion
    Replies: 1
    Last Post: 05-19-16, 09:45 PM
  3. Help! Parking Brake Handle Question on my 62
    By dennyrock in forum C1 & C2 General and Technical Discussion
    Replies: 2
    Last Post: 02-13-08, 12:47 PM
  4. Replacement Parking Brake Handle
    By CSM87 in forum C4 Technical and Performance
    Replies: 4
    Last Post: 07-19-02, 04:40 PM
  5. 77 parking brake handle
    By 77-4speed in forum C3 Technical and Performance
    Replies: 3
    Last Post: 05-12-02, 07:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •