Thanks Thanks:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    Member Lakotah's Avatar
    Join Date
    Nov 2014
    Location
    Livermore, California
    Posts
    66
    Corvette(s)
    1999 Pewter coupe
    Post Thanks / Like
    Rides
    0

    Default C-5 Oil Pressure at 130?

    My DIC says my oil pressure is 130lb's. Totally impossible but that's what it says. I'm starting here for information on where to start looking to fix this. Other than that my C-5 has been running pretty well at 90k+ miles, now that my ground issue's seem to be fixed.


    Up-date 11/20/17.................Yup........it was that oil pressure sensor all right. What rascal to get to. I managed to get to the sensor by inserting a piece of sheet metal between the cowl and the wiring and vacuum hose just below it so as not to cut through them. Using a miniature circular saw blade I very carefully cut a rectangular hole through the cowl to access the sensor. After replacing the sensor I pop riveted a piece of sheet metal under the hole then placed the piece I cut out back in place an pop riveted it down to secure it then very carefully filled the slot I cut with black silicone. Turned out pretty good I must say. Time and patience was the key here. Should be easier next time. Oil pressure reading back to normal.
    I'll tell you, I feel better doing it this way verses removing the top half of my engine and stirring up more potential problems.
    Last edited by Lakotah; 11-20-17 at 09:47 PM.

  2. #2
    Member Otter's Avatar
    Join Date
    May 2005
    Location
    Maryland
    Posts
    410
    Corvette(s)
    2001 Z06
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Lakotah View Post
    My DIC says my oil pressure is 130lb's. Totally impossible but that's what it says. I'm starting here for information on where to start looking to fix this. Other than that my C-5 has been running pretty well at 90k+ miles, now that my ground issue's seem to be fixed.
    Sending units in C5s are well known to fail/go bananas. Just replaced mine.

  3. #3
    Member LLC5's Avatar
    Join Date
    Sep 2004
    Location
    Wa.
    Posts
    2,229
    Corvette(s)
    98 black 6spd convert.
    Post Thanks / Like
    Rides
    0

    Default

    Make sure you didnít accidentally switch to metric gauge readings. If good, the sending units are known to go bad as stated previously.
    Master Technician

    25+ year ASE Master Certified Tech

    22+ year Honda Master Tech
    Likes kpic liked this post

  4. #4
    Member Junkman2008's Avatar
    Join Date
    Aug 2007
    Location
    Kentucky
    Posts
    559
    Corvette(s)
    2001 Navy Blue Metallic Coupe
    Post Thanks / Like
    Rides
    0

    Default

    It's a COMMON failure. I did a repair thread on how to fix it here.
    "Marines - Making the other guy die for his country for over 200 years."

Similar Threads

  1. Replies: 5
    Last Post: 06-15-13, 02:20 PM
  2. No Pressure!!!
    By Mike2500 in forum C3 Technical and Performance
    Replies: 1
    Last Post: 11-15-11, 07:43 PM
  3. Oil pressure
    By johnohio in forum C6 Technical and Performance
    Replies: 1
    Last Post: 07-01-11, 10:15 AM
  4. Question: Any difference between the Z06 pressure plate/clutch & stock pressure plate
    By Bill Boyle in forum C5 Technical and Performance
    Replies: 7
    Last Post: 05-27-11, 12:42 PM
  5. oil pressure
    By knightvette in forum C5 Technical and Performance
    Replies: 10
    Last Post: 05-07-11, 02:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •