Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    just me
    Guest

    Default Keep Blowing fuse

    Not sure if this is in the correct forum or not, so here goes. I purchased this ride in Feb 2009 so I do not know what all was done or how it was done, so to get to the issue at hand: I keep blowing the fuse for the power window and the power outside mirror on the passenger side of the vette. little 10 amp I have tried to narrow it down to what I am running but it seems to be random, It can go several days and then all of a sudden I go to drop window and does not work, any one have this issue or has had and can you provide me with insight
    Thanks Larry

  2. #2
    Member njlouc's Avatar
    Join Date
    Jan 2009
    Location
    New Jersey
    Posts
    401
    Post Thanks / Like
    Rides
    0

    Default

    This is probably more than I know but here goes.
    The 10a fuse is probably the
    #33 Door Control Module Left, or #30 Door Control Module Right
    This controls the window/door locks. My guess is that whoever did the Lambo doors may have damaged a wire and it occasionally shorts out.

  3. #3
    Member c5y2k's Avatar
    Join Date
    Oct 2005
    Location
    Gallatin, TN
    Posts
    475
    Post Thanks / Like
    Rides
    0

    Default

    Nice catch NJ! I didnt even notice the lambo doors in the pict. I would guess you are correct on this.

    JM, being that the car is new to you I would check all the grounds. There are grounds right behind both headlights, some by the door hinges (if i remember right they are behind the kick panel) Search this section for "ground" and you will find many posts with more detail on where the grounds are. Even if they are not the issue its preventative maintenance.

  4. #4
    just me
    Guest

    Default

    thanks for the heads up on the lambo door found a wire there wrapped it up and all is good thanks for the help
    L

  5. #5
    Member c5y2k's Avatar
    Join Date
    Oct 2005
    Location
    Gallatin, TN
    Posts
    475
    Post Thanks / Like
    Rides
    0

    Default

    Good deal. Glad you got it fixed.

Similar Threads

  1. LCD 5amp fuse blowing
    By muzy67 in forum C4 Technical and Performance
    Replies: 0
    Last Post: 10-03-07, 06:43 PM
  2. Instrument lights fuse blowing
    By MFPvette80 in forum C3 Technical and Performance
    Replies: 17
    Last Post: 07-21-07, 08:54 AM
  3. Replies: 8
    Last Post: 08-12-03, 09:58 PM
  4. No More Interior Lights and Blowing Fuse
    By 1982Corvette2002 in forum C3 Technical and Performance
    Replies: 2
    Last Post: 03-14-03, 10:43 PM
  5. AC / CCM fuse blowing on 90 vette - need help urgently!!!
    By malc350 in forum C4 Technical and Performance
    Replies: 6
    Last Post: 07-26-02, 04:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •