Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 14 of 14
  1. #1
    New Member
    Join Date
    Apr 2009
    Location
    Ohio
    Posts
    6
    Post Thanks / Like
    Rides
    0

    Default abs traction control

    HELP!!!!! I'm pulling my hair out. Have a 2000 C5 Conv. trying to sell it but the abs traction control lite is on . I ran thru the codes in the dash and got no C codes only H I replaced the blown fuse and that seemed to work for a couple days but it started to come back on and when I restarted it it went off then It came on and now stays on. I haven't ckd the fuse yet. What would make this fuse keep blowin and is it possible that the abs box should be sent to abs fixer??? HELP by the way I only want 17,000 has 64K miles

  2. #2
    Houley
    Guest

    Default ABS,AC and TC

    I am also looking for the same answer, I have an 01 with the same issue, after finally going to a reputable dealer I got the answer I didn't want EBCM error code C1214. The first dealer also told me to replace the BPMV anyone know if thats possible for both at the same time and if so why?

  3. #3
    Technical Writer for Internet & Print Media
    Join Date
    Jan 2001
    Location
    CenCoast CA
    Posts
    11,688
    Post Thanks / Like
    Rides
    0

    Default

    When the fuse keeps blowing that's a big clue you have an electrical system problem. It's pointless to keep putting in new fuses.

    You need to pull the codes from the ABS controller using a scan tester then perform the repairs called-for by the factory service manual.

    if the FSM calls for replacement of the EBTCM or the BPMV, I'd knock $1500 off the price and sell the car as is.

  4. #4
    New Member
    Join Date
    Apr 2009
    Location
    Ohio
    Posts
    6
    Post Thanks / Like
    Rides
    0

    Default

    the fuse didn't blow it keeps goin off then the next time I drive it it goes on then it might be on again and then off again so the fuse is ok

  5. #5
    Technical Writer for Internet & Print Media
    Join Date
    Jan 2001
    Location
    CenCoast CA
    Posts
    11,688
    Post Thanks / Like
    Rides
    0

    Default

    I'm confused I guess. Sorry about that. I read the first post that there was a problem with fuses blowing repeatedly.

    If the ABS Service light is on, you need to take the car to a service facility familiar with C5/C6 Corvette chassis control systems diagnosis and have it repaired.

    It is possible to troubleshoot C5 ABS on a DIY basis but a professional-grade scan tester is often required. That said, you must start by getting the fault codes that are set in the ABS controller. You can do that using the DIC. There are instructions elsewhere on the CAC as to how to use the IP display to read codes.

    Get the codes out of the ABS controller and post them here.

  6. #6
    New Member
    Join Date
    Apr 2009
    Location
    Ohio
    Posts
    6
    Post Thanks / Like
    Rides
    0

    Default abs lite

    Quote Originally Posted by Hib Halverson View Post
    I'm confused I guess. Sorry about that. I read the first post that there was a problem with fuses blowing repeatedly.

    If the ABS Service light is on, you need to take the car to a service facility familiar with C5/C6 Corvette chassis control systems diagnosis and have it repaired.

    It is possible to troubleshoot C5 ABS on a DIY basis but a professional-grade scan tester is often required. That said, you must start by getting the fault codes that are set in the ABS controller. You can do that using the DIC. There are instructions elsewhere on the CAC as to how to use the IP display to read codes.

    Get the codes out of the ABS controller and post them here.
    I pulled the codes on the dash:
    under TCS I get C1217H C1243H
    any clues?????? I've got a buyer but he's leary about the lite

  7. #7
    New Member
    Join Date
    Apr 2009
    Location
    Ohio
    Posts
    6
    Post Thanks / Like
    Rides
    0

    Default

    I pulled the codes again and cleared the C 1217 H but the C1243 H code is still there when I start the car and the fuse is good

  8. #8
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    4,416
    Post Thanks / Like
    Rides
    0

    Default

    C1217 : BPMV Pump Motor Relay Contact CKT Open

    C1243 : BPMV Pump Motor Stalled

    First thing I'd do is CLEAN and Check ALL Grounds!! Ex-specially the ones under the Hood!! There are 2 gang Grounds beside the RT and LT headlamp!! Take them Off and take them apart and clean them!! Grounds make these cars do weird Things!!
    Check the ABS relay for good connections,It should be in the Power Distribution center on the right inner wheel house I believe!!
    I'm not at my desk computer where my SI program is installed!!
    It's got so it seems to me that the Internet has created a lot more Horses A$$'s than we have Horses!
    junk!~!!
    Founding Member: 10 Corvettes Anonymous


  9. #9
    Technical Writer for Internet & Print Media
    Join Date
    Jan 2001
    Location
    CenCoast CA
    Posts
    11,688
    Post Thanks / Like
    Rides
    0

    Default

    I agree with the Junkster. First, check the grounds. If you find them loose or corroded, make appropriate repairs, clear codes and road test.

    If the ABS Service light comes on with the same codes, an ethical person is going to have to either tell the buyer and lower the price a grand or so or not sell the car until it's fixed.

    My guess is, if the C1243 (pump motor stalled) resets, that will be the expensive one because it may require replacement of the brake pressure modulator valve.

  10. #10
    New Member
    Join Date
    Apr 2009
    Location
    Ohio
    Posts
    6
    Post Thanks / Like
    Rides
    0

    Default

    well i caved and took it corvette care in columbus ohio. great guy llyod viet nam vet navy fighter pilot so anybody in columbus ohio this guy is straight up. its not the pump but the module abs fixer is $150 plus labor tks for all your help

  11. #11
    New Member
    Join Date
    May 2009
    Location
    st louis mo
    Posts
    2
    Post Thanks / Like
    Rides
    0

    Default where is the EBCM

    i have read through the forums, ran the codes (c1214hc) on my car, and it seems like i need to send the EBCM to absfixer but i am not sure where it is located. can anyone help?

    thanks

  12. #12
    Member shark454's Avatar
    Join Date
    Mar 2007
    Location
    Illinois
    Posts
    177
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by slick782000 View Post
    i have read through the forums, ran the codes (c1214hc) on my car, and it seems like i need to send the EBCM to absfixer but i am not sure where it is located. can anyone help?

    thanks
    www.absfixer.com

    you need to inform him you are sending him a unit.

  13. #13
    New Member
    Join Date
    May 2009
    Location
    st louis mo
    Posts
    2
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by shark454 View Post
    www.absfixer.com

    you need to inform him you are sending him a unit.
    i'm sorry, i am not sure where the module is located on the vehicle?

  14. #14
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    4,416
    Post Thanks / Like
    Rides
    0

    Default

    The EBCM is attached to the ABS/BPMV it is behind the radiator in front of the engine attached with 6 screws!!

    You can access it by removing the air bridge,unplugging the the harness and 1 small plug and removing the 6 screws from the passenger side with a 1/4 inch drive long extension and socket.





    It's got so it seems to me that the Internet has created a lot more Horses A$$'s than we have Horses!
    junk!~!!
    Founding Member: 10 Corvettes Anonymous


Similar Threads

  1. 2000 vette with a service issue?
    By Tigershark_11 in forum C5 Technical and Performance
    Replies: 11
    Last Post: 10-26-07, 02:50 PM
  2. C4 power not catalysed of origin
    By pat68 in forum C4 Technical and Performance
    Replies: 15
    Last Post: 03-02-06, 12:39 AM
  3. My new 95
    By FX3FX3 in forum C4 General Discussion
    Replies: 16
    Last Post: 10-27-04, 11:02 PM
  4. 1984 - Z-51 suspension???
    By sasquatch in forum C4 Technical and Performance
    Replies: 8
    Last Post: 09-27-04, 01:56 PM
  5. ML9 or MN6 manual trans difference
    By Paul G in forum C4 General Discussion
    Replies: 10
    Last Post: 09-01-04, 04:00 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •