• What can cause the DIC average mpg to reset on its own?
  • What can cause the DIC average mpg to reset on its own?
  • What can cause the DIC average mpg to reset on its own?
  • What can cause the DIC average mpg to reset on its own?

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 7 of 7
  1. #1
    Member
    Join Date
    Mar 2005
    Location
    Pennsylvania
    Posts
    22
    Corvette(s)
    2002 Millenium Yellow - Z06
    Post Thanks / Like
    Rides
    0

    Default What can cause the DIC average mpg to reset on its own?

    2002 - Z06 - 23K - No Mods.

    Have owned for 4 years, once in a while over the past two years I would notice the DIC would be set to the odomoter when I looked down after started my drive to work. Only problem was I never left the DIC on the odometer, it is usually set to show Avg MPG or trip mileage.

    Only Average MPG is getting reset in the DIC, not the trip meters, and certainly not the oil life or anything else important. More annoying than anything else.

    Since last fall and through this spring, the DIC auto resets are becoming more frequent. Never happens during the day, like when I drive it home in afternoon after sitting for the day. Only happens after sitting at least one overnight.

    One other thing I have seen is that it seems like if I put the key in and turn to power on electrics, but wait a few seconds for the DIC to fully power up before starting the engine, the reset doesn't usually occur. But if I get in and immediately start the car with the key, it ususally ALWAYS resets the AVG and sets the display to the odometer.

    Chevy dealer tried to fix this last fall by replacing the entire instrument cluster (under warranty). No dice.

    Any ideas out there? Will weak battery in any way cause these types of symptoms? Battery is at least original to my purchase (4 years).

    Any advice appreciated!

  2. #2
    Member
    Join Date
    Jan 2002
    Location
    Cincinnati, Ohio, USA
    Posts
    293
    Corvette(s)
    1999 White Coupe
    Post Thanks / Like
    Rides
    0

    Default

    A weak battery and/or improper battery terminal connections (dirty, not tight enough, corroded, etc.) can cause this condtion.

  3. #3
    Member jrose7004's Avatar
    Join Date
    Aug 2004
    Location
    Oklahoma City, OK
    Posts
    8,523
    Corvette(s)
    10 Grand Sport Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Just a guess but I'd bet your battery is starting to go.

  4. #4
    Member njlouc's Avatar
    Join Date
    Jan 2009
    Location
    New Jersey
    Posts
    401
    Corvette(s)
    2000 Black Coupe
    Post Thanks / Like
    Rides
    0

    Default

    All of the above. Check your codes I think that if there was a loose connection it would register as a lost communication, and you would get that code. I had a bunch of "lost communications", just note the codes and reset - see if it happens again.

  5. #5
    Member
    Join Date
    Mar 2005
    Location
    Pennsylvania
    Posts
    22
    Corvette(s)
    2002 Millenium Yellow - Z06
    Post Thanks / Like
    Rides
    0

    Default

    Thanks everyone for the quick responses. A new battery is now in the works.

  6. #6
    Member njlouc's Avatar
    Join Date
    Jan 2009
    Location
    New Jersey
    Posts
    401
    Corvette(s)
    2000 Black Coupe
    Post Thanks / Like
    Rides
    0

    Default

    BTW - have the store test the battery and check the date code before you buy it. The last battery I bought they tried to sell me one 3months older than the others and it also tested defective. Also make sure that it has all the necessary plastic spacers and tubes (this was not for a Vette).

  7. #7
    Member killain's Avatar
    Join Date
    Feb 2004
    Location
    Southeast, PA
    Posts
    1,102
    Corvette(s)
    2003 50th Annversary Red coupe, beautiful !
    Post Thanks / Like
    Rides
    0

    Default

    One other thing I'd check, See if a battery at some point leaked. Check the bundle of wires and the PCM which sits directly under the battery pan. If at sometime a battery leaked acid it would have/ could have corroded and are shorting out somewhere in the bundle.

Similar Threads

  1. Strange Idle relating to average mpg display
    By scarylarry in forum C4 Technical and Performance
    Replies: 22
    Last Post: 11-09-08, 10:12 PM
  2. Help! Dash cluster reporting incorrect average and instant MPG
    By TedC in forum C4 Technical and Performance
    Replies: 4
    Last Post: 04-10-08, 10:51 AM
  3. Automatic reset on MPG Readout
    By 98TXRed in forum C5 Technical and Performance
    Replies: 2
    Last Post: 09-02-04, 07:33 AM
  4. Need to reset DIC - LPTWS?
    By froggy47 in forum C4 Technical and Performance
    Replies: 10
    Last Post: 02-12-04, 09:13 PM
  5. average mpg?
    By mikeyc4 in forum C4 Technical and Performance
    Replies: 12
    Last Post: 09-01-03, 08:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •