$projecthp
Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 2 of 2

Thread: 95 HVAC problem

  1. #1
    Member
    Join Date
    Oct 2003
    Location
    Simi Valley, CA.
    Posts
    82
    Corvette(s)
    2004 Red Z06
    Post Thanks / Like
    Rides
    0

    Default 95 HVAC problem

    I continue to have problems with my A/C dash controls on my 95. The display light always blinks when I get in gear and go, for about 1 minute, then it turns solid. By pushing both the up and down fan buttons, it registers a 00. Then, when I push the fan button, it usually sets a 03 (open outside ambient temp).
    Now, I took the controller out of the dash and took it all apart and cleaned. When I put it all together, viola, no blinking. And, after driving for 5 minutes, the outside sensor started sensing the proper temp. That went on for about 1 day. Now, when I start it up, it's the same old thing.

    Can I be reasonably sure that the controller is bad without going into the system any deeper???

    I don't mind replacing a $500 part if I can prove it's faulty. I go ballistic if I replace a $5 part and find out it was good in the first place. Please help.

  2. #2
    Member Rabbit's Avatar
    Join Date
    Dec 2001
    Location
    sonoma ca usa
    Posts
    956
    Corvette(s)
    2004 C5 coupe, MSGM & 2014 Cad SRX Crystal red
    Post Thanks / Like
    Rides
    0

    Default

    I can send you the trouble shooting section for codes "03 & 04". It outlines the various procedures for checking the
    temp sensor.Let me know at roman67844@cs.com.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •