$projecthp
Thanks Thanks:  0
Dislikes Dislikes:  0
Results 1 to 7 of 7

Thread: stever123

  1. #1
    New Member
    Join Date
    Aug 2019
    Location
    SURFSIDE BEACH
    Posts
    6
    Corvette(s)
    1994 c-4
    Post Thanks / Like
    Rides
    0

    Default stever123

    my1994, After driving 20 to 30 miles car not responding to throttle. Slow response when giving gas, then kicks in and goes. very bad idle when stopped. sometimes pings before it kicks in. Has a knew fuel pump. cleaned throttle body. knew air control sensor. any help appreciated

  2. #2
    New Member
    Join Date
    Aug 2019
    Location
    SURFSIDE BEACH
    Posts
    6
    Corvette(s)
    1994 c-4
    Post Thanks / Like
    Rides
    0

    Default

    Just checking, did i post my thread correctly. No responses to question? Thanks

  3. #3
    Member compyelc4's Avatar
    Join Date
    May 2002
    Location
    Dayton, Ohio
    Posts
    526
    Corvette(s)
    '95 LT1 Coupe, Comp Yell; C6 Roadster, Vel Yell
    Post Thanks / Like
    Rides
    0

    Default

    Have you pulled codes yet. Based on your description, it could be the optispark. How many miles on it and is your water pump leaking. You can check by taking an inspection mirror and light and check the weep hole on the bottom of the pump. Report back please.
    Ted
    Likes Toms007 liked this post

  4. #4
    Moderator Toms007's Avatar
    Join Date
    Sep 2004
    Location
    Southwest Kansas
    Posts
    6,209
    Corvette(s)
    2007 Atomic Orange Coupe
    Post Thanks / Like
    Rides
    2

    Default

    It DOES sound like the opti......
    2007 Atomic Orange Coupe Cashmere/black interior

    2005 CruiseFest Attendee (Bowling Green, KY) 2007 CruiseFest Attendee (Colorado Springs, CO)
    2008 CruiseFest Attendee (Cleveland, OH)
    2010 Cruisefest Attendee(Effingham, IL)
    2011 CruiseFest Attendee(Effingham
    , IL)

    Formerly owned Corvettes: 1964 coupe, 1994 coupe, 2001 coupe


  5. #5
    New Member
    Join Date
    Aug 2019
    Location
    SURFSIDE BEACH
    Posts
    6
    Corvette(s)
    1994 c-4
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by compyelc4 View Post
    Have you pulled codes yet. Based on your description, it could be the optispark. How many miles on it and is your water pump leaking. You can check by taking an inspection mirror and light and check the weep hole on the bottom of the pump. Report back please.
    dealer in south Carolina diagnosed problem said was optispark, 1000 dollars later and it wasn't the optispark. thanks for your thoughts.

  6. #6
    New Member
    Join Date
    Aug 2019
    Location
    SURFSIDE BEACH
    Posts
    6
    Corvette(s)
    1994 c-4
    Post Thanks / Like
    Rides
    0

    Default

    I think i posted wrong dealer in south carolina said it was optispark, 1000 dollars later it wasnt the optispark. only codes are knock sensor. thanks for your thoughts

  7. #7
    Member navy2kcoupe's Avatar
    Join Date
    Dec 2006
    Location
    West Central FL and SE Mass.
    Posts
    792
    Corvette(s)
    2000 Navy Blue Coupe A4 Z51
    Post Thanks / Like
    Rides
    0

    Default

    Could be a plugged cat or cats..........
    Andy Anderson - PROUD VIETNAM VETERAN.

    Vietnam Veterans Corvette Club - Founding Member #1

    "Dream as if you'll live forever...........Live as though you'll die today" - James Dean

    "Money isn't everything.........but it SURE DOES keep the kids in touch!"


Similar Threads

  1. stever123
    By stever123 in forum New Member Introductions
    Replies: 5
    Last Post: 08-19-19, 10:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •