$projecthp
  • New owner, wierd charging issue.
  • New owner, wierd charging issue.
  • New owner, wierd charging issue.
  • New owner, wierd charging issue.

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Jun 2019
    Location
    New Florence Pennsylvania
    Posts
    1
    Post Thanks / Like
    Rides
    0

    Default New owner, wierd charging issue.

    Recently purchased this car, fixed a few issues to get it running. Now I'm having a strange issue with battery discharge. I've tried this with two separate batteries and I'm starting to suspect the starter. Put freshly charged battery. Start car. Settles to idle 13.9-14.1 on the gauge, 14.3 at the battery with a voltmeter let run at least 15-20 minutes everything seems fine. Shut it off. Try to restart and the battery is at like 11.8v on the dash acts like it's dead. Any ideas? The starter is sounding kind of beat even when fully charged. I feel like it's killing the battery instantly, when I try to restart it. Or is this a wierd alternator diode problem. I did a continuity check on the alternator and it seemed fine. Also check checked continuity from the alternator to the distribution block and distribution block to battery. Any ideas? 1986 l98.

  2. #2
    Member LLC5's Avatar
    Join Date
    Sep 2004
    Location
    Wa.
    Posts
    2,254
    Corvette(s)
    98 black 6spd convert.
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by 86vettePA View Post
    Recently purchased this car, fixed a few issues to get it running. Now I'm having a strange issue with battery discharge. I've tried this with two separate batteries and I'm starting to suspect the starter. Put freshly charged battery. Start car. Settles to idle 13.9-14.1 on the gauge, 14.3 at the battery with a voltmeter let run at least 15-20 minutes everything seems fine. Shut it off. Try to restart and the battery is at like 11.8v on the dash acts like it's dead. Any ideas? The starter is sounding kind of beat even when fully charged. I feel like it's killing the battery instantly, when I try to restart it. Or is this a wierd alternator diode problem. I did a continuity check on the alternator and it seemed fine. Also check checked continuity from the alternator to the distribution block and distribution block to battery. Any ideas? 1986 l98.


    It sounds like a bad battery. Always the first place to start is to have a fully charged battery load tested with a real carbon pile load tester, even with brand new batteries. You need to prove that the battery is good before any diagnosis.
    Master Technician

    25+ year ASE Master Certified Tech

    22+ year Honda Master Tech

Similar Threads

  1. Question: transmission gone wierd
    By English Guy in forum C4 Technical and Performance
    Replies: 7
    Last Post: 07-09-11, 07:00 AM
  2. charging issue
    By mattyg92 in forum C1 & C2 General and Technical Discussion
    Replies: 5
    Last Post: 04-26-07, 12:38 PM
  3. Wierd Noise... Help!!!
    By Mart in forum C4 Technical and Performance
    Replies: 9
    Last Post: 11-21-03, 05:06 PM
  4. Wierd A/c Gremlins-help!!!!!!!
    By YESZREE in forum C4 Corvette ZR-1
    Replies: 6
    Last Post: 04-03-03, 04:53 PM
  5. 84 still wierd
    By evolution in forum C4 Technical and Performance
    Replies: 12
    Last Post: 04-28-02, 07:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •