$projecthp
Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    May 2016
    Location
    wisconsin
    Posts
    2
    Corvette(s)
    1987 convertible
    Post Thanks / Like
    Rides
    0

    Default electrical problem

    I own an 87 vette convertible. The battery went dead on me while I was driving. I replaced the battery after checking it out and finding it defective. Still I only got 11.3 volt readout at the alternator. Replaced that. Now i get an 11.5 reading. Also when I turn on the lights a warning chime sounds. Any ideas.
    Stumped

  2. #2
    Moderator Toms007's Avatar
    Join Date
    Sep 2004
    Location
    Southwest Kansas
    Posts
    6,202
    Corvette(s)
    2007 Atomic Orange Coupe
    Post Thanks / Like
    Rides
    2

    Default

    Stumped, Welcome to CAC. I believe you will find the help you need to fix your C4. But in order to get the specific help you need I am going to move this post to C4 Tech. That will allow the right audience to see the post and offer their help.
    2007 Atomic Orange Coupe Cashmere/black interior

    2005 CruiseFest Attendee (Bowling Green, KY) 2007 CruiseFest Attendee (Colorado Springs, CO)
    2008 CruiseFest Attendee (Cleveland, OH)
    2010 Cruisefest Attendee(Effingham, IL)
    2011 CruiseFest Attendee(Effingham
    , IL)

    Formerly owned Corvettes: 1964 coupe, 1994 coupe, 2001 coupe

    Thanks Rob thanked for this post
    Likes Rob liked this post

  3. #3
    Member
    Join Date
    Aug 2014
    Location
    new port richey FL
    Posts
    86
    Corvette(s)
    93 polo green
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Toms007 View Post
    Stumped, Welcome to CAC. I believe you will find the help you need to fix your C4. But in order to get the specific help you need I am going to move this post to C4 Tech. That will allow the right audience to see the post and offer their help.

    Here a link from a past forum with a Similar complaint granted it is for a 89 but I think the systems are Marginally close enough for some trouble shooting. Sorry it came from another forum but lets face we all cruise the other ones, and I didnt even realize it until I linked it from Google while searching for a schematic of a charging system .
    Alternator good not charging battery - Corvette Forum
    Last edited by forrest; 05-23-16 at 06:41 AM.

Similar Threads

  1. Do i have an electrical problem?
    By Stogie D in forum C5 Technical and Performance
    Replies: 16
    Last Post: 03-09-11, 10:46 PM
  2. 79 Electrical Problem
    By jnenni in forum C3 Technical and Performance
    Replies: 3
    Last Post: 01-16-05, 11:49 AM
  3. Electrical Problem
    By HughDTX in forum C3 Technical and Performance
    Replies: 2
    Last Post: 07-09-04, 10:27 AM
  4. '97 Electrical Problem
    By Jim Shoemaker in forum C5 Technical and Performance
    Replies: 3
    Last Post: 11-06-03, 08:07 AM
  5. '78 electrical problem?
    By keitheturner in forum C3 Technical and Performance
    Replies: 1
    Last Post: 07-28-01, 11:43 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •