• Climate goes to defrost when set to 90
  • Climate goes to defrost when set to 90
  • Climate goes to defrost when set to 90
  • Climate goes to defrost when set to 90

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 8 of 8
  1. #1
    Member
    Join Date
    Apr 2009
    Location
    N/A
    Posts
    587
    Post Thanks / Like
    Rides
    0

    Default Climate goes to defrost when set to 90

    ....

  2. #2
    Climate goes to defrost when set to 90 TedC's Avatar
    Join Date
    Oct 2007
    Location
    Amherst, NY
    Posts
    719
    Corvette(s)
    1989 Red Coupe
    Post Thanks / Like
    Rides
    0

    Default

    I haven't pulled my controller yet for cleaning. 1 out of 30 times it will show 00. I find using fan down button first, then up, it works right away. Did you check and clean the contacts?

  3. #3
    Climate goes to defrost when set to 90 TedC's Avatar
    Join Date
    Oct 2007
    Location
    Amherst, NY
    Posts
    719
    Corvette(s)
    1989 Red Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Additional info on how the C68 should operate...

  4. #4
    Member
    Join Date
    Feb 2009
    Location
    Broken Arrow, OK
    Posts
    232
    Corvette(s)
    1990 White Coupe
    Post Thanks / Like
    Rides
    0

    Default

    my 90 was going through the air being directed to the wrong place. Most of the cars I have done this is directed by vacuum which seems to be controlled by the programmer.

    Turned out to be the A/C heater programmer. Changed it out now it is fine.

  5. #5
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    4,416
    Corvette(s)
    03 Z-51,78 L82 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by joshwilson3 View Post
    I'm figuring it is the programmer, but I'm hoping it is something else.

    What goes bad on the programmer?
    Usually the vacuum connector starts leaking where the lines plug in,and sometimes the wiring plug pins get light corrosion!!
    It's got so it seems to me that the Internet has created a lot more Horses A$$'s than we have Horses!
    junk!~!!
    Founding Member: 10 Corvettes Anonymous


  6. #6
    Member
    Join Date
    Apr 2009
    Location
    N/A
    Posts
    587
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by gmjunkie View Post
    Usually the vacuum connector starts leaking where the lines plug in,and sometimes the wiring plug pins get light corrosion!!
    I did clean the plug pins on the board. I guess I could spray some electric cleaner on the plug pins itself.

    I did plug the vacuum connector up as tight as I could without the case on. Is there anything that can put on the vacuum connector to get a better seal?

  7. #7
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    4,416
    Corvette(s)
    03 Z-51,78 L82 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by joshwilson3 View Post
    I did clean the plug pins on the board. I guess I could spray some electric cleaner on the plug pins itself.

    I did plug the vacuum connector up as tight as I could without the case on. Is there anything that can put on the vacuum connector to get a better seal?
    Sometimes if you tighten them too tight,it will close the ends of vacuum Tity's!!I've even had to trim the ends a 1/16 of an inch if they've been tightened too tight to keep them from compressing shut!!I use a little transmission assembly lube or even chassis grease on the vacuum connector to help seal it!!Don't use any hardening type sealers though,it can plug the lines after it hardens!!
    It's got so it seems to me that the Internet has created a lot more Horses A$$'s than we have Horses!
    junk!~!!
    Founding Member: 10 Corvettes Anonymous


  8. #8
    Member
    Join Date
    Apr 2009
    Location
    N/A
    Posts
    587
    Post Thanks / Like
    Rides
    0

    Default

    Do yall ever put any vacuum line cleaner in the vacuum lines? I figure there would be a chance of dirt getting in the lines after all these years, and it wouldn't hurt to put a few drops in the lines.

    Though, I'd have to figure out where to get some.

Similar Threads

  1. FS 80-82 only 3.73 gear set several 65-79 gear sets
    By va427c4 in forum C3 Parts For Sale / Wanted
    Replies: 6
    Last Post: 11-15-10, 09:10 PM
  2. Question: Got a set of 15" rally wheels W/O caps?
    By killain in forum C3 Parts For Sale / Wanted
    Replies: 2
    Last Post: 02-17-09, 04:25 AM
  3. Complete Set of Factory Brand New Corvette ZR-1 Emblems!
    By SPEEDEMON in forum C4 Corvette ZR-1
    Replies: 0
    Last Post: 01-05-09, 12:14 AM
  4. If I keep the 90 model, future mods would be....
    By 69MyWay in forum C4 Technical and Performance
    Replies: 18
    Last Post: 12-05-02, 09:33 PM
  5. 24K Gold Corvette Gift Set
    By Gus in forum Die-Casts and Collectibles
    Replies: 1
    Last Post: 11-01-01, 11:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •