Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 2 of 2

Thread: problems

  1. #1
    New Member
    Join Date
    Mar 2009
    Location
    Lexington, Kentucky
    Posts
    2
    Corvette(s)
    1989 Black Convertible
    Post Thanks / Like
    Rides
    0

    Default problems

    about a week ago, i was driving my 89 down the hiway. Suddenly lost power, to the side of the road. car would not start. tried to start but failed. Had the car towed to my house. Off the truck, the car started. Shut it down, it would not start again. I replaced the fuel filter, which looked fine. No trash. Car started right up. Let it warm up, revved it, everything was okay. Started it today, let it run for about 40 minutes. No roughness, missing, nothing, pulled out of the driveway and accelerated, engine died. Any suggestions as to what i can check?????

  2. #2
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    4,416
    Corvette(s)
    03 Z-51,78 L82 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by 89VetteRagtop View Post
    about a week ago, i was driving my 89 down the hiway. Suddenly lost power, to the side of the road. car would not start. tried to start but failed. Had the car towed to my house. Off the truck, the car started. Shut it down, it would not start again. I replaced the fuel filter, which looked fine. No trash. Car started right up. Let it warm up, revved it, everything was okay. Started it today, let it run for about 40 minutes. No roughness, missing, nothing, pulled out of the driveway and accelerated, engine died. Any suggestions as to what i can check?????
    You need to run a fuel pressure test,L98 (34-39) with key on!
    If thats OK,you need to check the ignition module and the coil!!
    It's got so it seems to me that the Internet has created a lot more Horses A$$'s than we have Horses!
    junk!~!!
    Founding Member: 10 Corvettes Anonymous


Similar Threads

  1. Replies: 5
    Last Post: 04-28-05, 01:23 PM
  2. Problems, problems and more problems
    By Huckleberry in forum C4 Technical and Performance
    Replies: 20
    Last Post: 06-21-04, 06:42 PM
  3. Speed Density Drivability problems?
    By Hrtbeat1 in forum C4 Technical and Performance
    Replies: 0
    Last Post: 10-14-03, 02:05 PM
  4. Log-In and Posting Problems
    By Rob in forum New Member Introductions
    Replies: 2
    Last Post: 08-28-03, 06:47 AM
  5. C5 problems.....
    By KANE in forum C5 Technical and Performance
    Replies: 2
    Last Post: 12-18-02, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •