Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    Member milehigreg's Avatar
    Join Date
    Dec 2004
    Location
    Denver Colorado
    Posts
    271
    Post Thanks / Like
    Rides
    0

    Default Loss of Vaccuum Assist

    Lost vacuum assist on my 89 coupe. Brakes are still functional but it takes a lot of leg power. As soon as I depress the brake pedal I can hear a noise (air). Easier to hear inside the car. From the engine bay I can hear it and it sounds like it's coming from inside the vacuum booster.

    Check valve stuck closed?

    Check valve stuck open?

    Hole in diaphragm?

  2. #2
    Member TWISTERUP's Avatar
    Join Date
    Aug 2008
    Location
    Powhatan VA
    Posts
    138
    Post Thanks / Like
    Rides
    0

    Default

    Hole in diaphragm.

  3. #3
    Member milehigreg's Avatar
    Join Date
    Dec 2004
    Location
    Denver Colorado
    Posts
    271
    Post Thanks / Like
    Rides
    0

    Default Closing the loop

    I don't like to leave threads open ended, so here's the resolution to the problem. I ordered a reman power brake booster from thepartsladi on ebay. Just couldn't bring myself to pay the additional $200 for an AC Delco. It is a cadmium plated metal unit made by MMB. It is a bit smaller in diameter than the black plastic one I took off. The one I took off was not original, I know this because the socket was left on one of the nuts up under the dash from the last time the job was done. The guy ( dealer) I bought it from 5 years ago told me he had replaced it.

    So, I did it in less than 2 hours. I was able to do it without removing the seat and without disconnecting the master cylinder. I no longer have to provide the power to my power brakes.

  4. #4
    Member TWISTERUP's Avatar
    Join Date
    Aug 2008
    Location
    Powhatan VA
    Posts
    138
    Post Thanks / Like
    Rides
    0

    Default Glad To Hear It

    Glad to here you got your problem resolved ! Also thanks for "closing" the thread, I'm with you on the "not leavin' them open ended"

Similar Threads

  1. SOS!!! Serious electrical problems on my 2000???
    By fhturner in forum C5 Technical and Performance
    Replies: 12
    Last Post: 10-04-09, 10:58 PM
  2. General Motors Reports Largest Loss Ever for U.S. Automotive Company
    By 6 Shooter in forum General Automotive Discussion
    Replies: 2
    Last Post: 02-14-08, 09:54 PM
  3. Active Handling/ABS Warning Light
    By sandmanmd in forum C5 Technical and Performance
    Replies: 12
    Last Post: 05-11-06, 10:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •