Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 12 of 12
  1. #1
    strange starting problem caninelver's Avatar
    Join Date
    Nov 2003
    Location
    York, Pa
    Posts
    104
    Corvette(s)
    1988 convertible-blue pearl
    Post Thanks / Like
    Rides
    0

    Default strange starting problem

    My 88 money pit is mad at me and won't start if it sits even a few days without first needing the battery charger. It just needs hooked up for a few seconds and I hear clicking noises all over the engine compartment and the interior lights and dash lights come on. The battery is 2 yrs old. I think it has something draining it or there is a loose connection. I haven't driven it in about 2 yrs but now I would like to but I'm afraid it might shut off on me. I usually start it up and let it idle once a month. Does anyone have a suggestion?
    Denny
    denny

  2. #2
    Member TWISTERUP's Avatar
    Join Date
    Aug 2008
    Location
    Powhatan VA
    Posts
    138
    Corvette(s)
    1996 LT1 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    From your description ...check the cable connections at the battery itself for being clean at the contact area and tight.

  3. #3
    strange starting problem caninelver's Avatar
    Join Date
    Nov 2003
    Location
    York, Pa
    Posts
    104
    Corvette(s)
    1988 convertible-blue pearl
    Post Thanks / Like
    Rides
    0

    Default

    Alright, even I can do that. Thanks.

  4. #4
    Member Robertwav1's Avatar
    Join Date
    Jan 2003
    Location
    Apollo Beach, Florida
    Posts
    795
    Corvette(s)
    1993 Blue
    Post Thanks / Like
    Rides
    0

    Default

    I would check the grounds everywhere also. Open the hood, look along the frame rail, both sides. Under the car, bell housing has a few.

  5. #5
    Member
    Join Date
    Aug 2002
    Location
    wilkes-barre,pa.usa
    Posts
    758
    Corvette(s)
    1988 white 4+3 coupe 99 Torch Red 6spd. coupe
    Post Thanks / Like
    Rides
    0

    Default

    Do your power door locks/power seat adjust. work?????

  6. #6
    strange starting problem caninelver's Avatar
    Join Date
    Nov 2003
    Location
    York, Pa
    Posts
    104
    Corvette(s)
    1988 convertible-blue pearl
    Post Thanks / Like
    Rides
    0

    Default

    Do your power door locks/power seat adjust. work?????

    My seat quit working a while back. I left the car sit for a couple days w/o the battery charger on it and tried to start it. When I turn the key on there are the usual clicking and whirling noises. When I turn it to start I get a loud and fast clicking noise and the fan tries to turn but then stops. I think its a problem in the starter. If I leave the battery charger hooked up, the car will start fine. I don't understand this. I think the battery is fine. What is the difference in the voltage going to the starter as long as the battery is good? I am thinking of pulling the starter and that leads to another question. Is it better to rebuild the old one (21 yrs old but I know it fits) or buy a new one which will likely be a rebuilt anyway. I don't think the starter is hard to get to with the car jacked up but I'm not sure if that will fix the problem.

  7. #7
    Member TWISTERUP's Avatar
    Join Date
    Aug 2008
    Location
    Powhatan VA
    Posts
    138
    Corvette(s)
    1996 LT1 Coupe
    Post Thanks / Like
    Rides
    0

    Default May be Battery (even 'tho it's not very old)

    Quote Originally Posted by TWISTERUP View Post
    From your description ...check the cable connections at the battery itself for being clean at the contact area and tight.
    If you've done the above and still have problems....the battery may not be old ,however I'd take it out and have it checked to be sure it's good...if it is in fact a good battery then you likely have a electrical draw which is draining the battery over time,but I'd be certain the battery is good first. It does not sound like a starter problem to me.

  8. #8
    Member
    Join Date
    Feb 2009
    Location
    Broken Arrow, OK
    Posts
    232
    Corvette(s)
    1990 White Coupe
    Post Thanks / Like
    Rides
    0

    Default

    I would say the battery is bad.

    do a load test on it.

    most parts stores have the ability to do one.

  9. #9
    strange starting problem caninelver's Avatar
    Join Date
    Nov 2003
    Location
    York, Pa
    Posts
    104
    Corvette(s)
    1988 convertible-blue pearl
    Post Thanks / Like
    Rides
    0

    Default

    Ok, I'll do the battery test first. I hope its not the battery though. You have to take half the friggin car apart to get it out the side. I'd sooner do the starter. Thanks for all the advice. I appreciate it.

  10. #10
    Member
    Join Date
    Aug 2002
    Location
    wilkes-barre,pa.usa
    Posts
    758
    Corvette(s)
    1988 white 4+3 coupe 99 Torch Red 6spd. coupe
    Post Thanks / Like
    Rides
    0

    Default

    There is a bulletin on the the power seats, check it out on this site. The seat action abraids a power wire, which is hot all the time, the power door locks are on the same circuit breaker. I had the same problem, the circuit breaker burned my finger when I started to investigate......It might be your problem

  11. #11
    strange starting problem caninelver's Avatar
    Join Date
    Nov 2003
    Location
    York, Pa
    Posts
    104
    Corvette(s)
    1988 convertible-blue pearl
    Post Thanks / Like
    Rides
    0

    Default

    Well, you guys are purrtee smart. I took the car to the garage where I bought the battery and had a load test done and they said the battery has less than 50% charge while running and the monitor said replace the sucker. The mechanic said there is a chance that my battery charger is shot or the alternator isn't working. He said he has corvette customers that have to replace their battery every year because of not starting them for long periods of time-like me. I have had problems with the battery charger so I will get a new one tomorrow and charge it up real good and then do another load test done to see if it fixes it. See how hard I'm trying to avoid changing that battery again. Maybe I'll just hire a tow truck to follow me around. Thanks for the help. I'll post the results here when I'm done.

  12. #12
    Member Wayne robson's Avatar
    Join Date
    Feb 2007
    Location
    australia
    Posts
    169
    Corvette(s)
    sold my last corvette.
    Post Thanks / Like
    Rides
    0

    Default starting and idling once a month,a no no,

    Hi caninelver,you mentioned that you start and idle your vette once a month, thats actually not a good thing to do ,ill tell you why,when doing this the thermostate takes twice as long to open,thus why idling puts extra wear on your engine, and also it may give your battery a minor charge boost but it will only help a small amount.The best way to do this for your vette, is if you can not drive it because of weather,snow etc,dont use it or start it unless you can at least drive it for 15 to 20 minutes,this is far better for your vette and the battery,other wise just leave it until spring ,but keep your batttery charged over that period. regards.

Similar Threads

  1. Starting Problem
    By fille9 in forum C4 Technical and Performance
    Replies: 8
    Last Post: 10-16-06, 08:06 AM
  2. starting problem
    By mike025 in forum C3 Technical and Performance
    Replies: 7
    Last Post: 10-08-04, 11:33 PM
  3. starting and radio problem
    By aoriii in forum C4 Technical and Performance
    Replies: 2
    Last Post: 06-04-03, 12:42 PM
  4. Starting problem
    By 6Speed in forum C5 Technical and Performance
    Replies: 3
    Last Post: 04-22-02, 09:06 PM
  5. Really need advice on strange overheat problem
    By 80convertible in forum C3 Technical and Performance
    Replies: 16
    Last Post: 05-02-01, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •