$projecthp
  • 92- C4 350 v8 LT1 with and automatic - I have no blinkers, no reverse lights, I have brake lights, running lights and er
  • 92- C4 350 v8 LT1 with and automatic - I have no blinkers, no reverse lights, I have brake lights, running lights and er
  • 92- C4 350 v8 LT1 with and automatic - I have no blinkers, no reverse lights, I have brake lights, running lights and er
  • 92- C4 350 v8 LT1 with and automatic - I have no blinkers, no reverse lights, I have brake lights, running lights and er

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    New Member
    Join Date
    Oct 2018
    Location
    New York
    Posts
    3
    Corvette(s)
    92 white C4 Ragtop
    Post Thanks / Like
    Rides
    0

    Default 92- C4 350 v8 LT1 with and automatic - I have no blinkers, no reverse lights, I have brake lights, running lights and er

    Hi Folks,

    I have a 92- C4 350 v8 LT1 with and automatic - I have no blinkers, no reverse lights, I have brake lights, running lights and er flashers.
    If I replace the blown blue blinker fuse blinkers work till I put the car in reverse and then the fuse pops AGAIN.
    Any thoughts?

    Thx
    John

  2. #2
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    4,507
    Corvette(s)
    03 Z-51,78 L82 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Yep,I have some thoughts,It takes a big,Big,BIG Dog to weigh a Ton, And a Hell of allot Bigger Cat to whip him!

    As far as your problem,Check the reverse lamp switch and reverse lamp sockets and wiring for a direct short.
    It's got so it seems to me that the Internet has created a lot more Horses A$$'s than we have Horses!
    junk!~!!
    Founding Member: 10 Corvettes Anonymous


  3. #3
    New Member
    Join Date
    Oct 2018
    Location
    New York
    Posts
    3
    Corvette(s)
    92 white C4 Ragtop
    Post Thanks / Like
    Rides
    0

    Default

    Thank you! I will check them.

  4. #4
    New Member
    Join Date
    Oct 2018
    Location
    New York
    Posts
    3
    Corvette(s)
    92 white C4 Ragtop
    Post Thanks / Like
    Rides
    0

    Default

    Hi Folks,

    Fixed it, one of the reverse lights was blown. After replacing the reverse lights and fuse for reverse and blinkers everything works great so far. Thx for the tips

    John

Similar Threads

  1. Brake lights/rear hazard & back-up lights don't work
    By Buckskin7T7V in forum C3 Technical and Performance
    Replies: 13
    Last Post: 12-09-14, 07:57 PM
  2. Help! 2007 Interior Lights Not shutting off (rearview map lights and floor lights)
    By Maddad195 in forum C6 Technical and Performance
    Replies: 2
    Last Post: 08-06-14, 01:53 PM
  3. Replies: 15
    Last Post: 07-24-08, 08:09 PM
  4. No Flashers, No Blinkers and Backup lights stuck on!
    By Derrick in forum C3 Technical and Performance
    Replies: 8
    Last Post: 04-14-08, 08:09 PM
  5. reverse lights
    By joe1975 in forum C3 Technical and Performance
    Replies: 3
    Last Post: 02-20-04, 06:13 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •