$projecthp
  • Exhaust Questions from a first time Corvette owner
  • Exhaust Questions from a first time Corvette owner
  • Exhaust Questions from a first time Corvette owner
  • Exhaust Questions from a first time Corvette owner

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 9 of 9
  1. #1
    New Member 89C4KB's Avatar
    Join Date
    May 2019
    Location
    Cameron Park, CA
    Posts
    12
    Corvette(s)
    1989 Bright Red Coupe
    Post Thanks / Like
    Rides
    0

    Default Exhaust Questions from a first time Corvette owner

    First time Corvette owner and just joined the site last night. I joined because I have a few questions and want to learn. I know next to nothing about Corvettes, other than the fact that I dig them and I’m happy to own one.

    I purchased a 1989 Coupe, Bright Red, 42,000 miles, bone stock except for the wheels and exhaust. The car is in great shape, paint is almost perfect, interior super clean, everything works, and the American Racing polished aluminum 5 spoke wheels, so much nicer than the stock wheels. I paid $7k for it (let me know how I did there). I knew the Y-pipe was corroded when I bought it because the previous owner gave me a new Y-pipe, and there were visible holes in the Y-pipe on the car. The car also had Flowmaster mufflers (series 40 I believe).

    The car sounded great with these mufflers. It had a grunt that was very pleasing, outside the car. I drove the car home, which was a 1 ½ hour trip. By the time I got home I could not wait to get out of the car and away from the obnoxious droning sound inside.

    I figured I would change the Y-pipe out and put the Flowmasters back on to see if the horrible droning was coming from the mufflers or the holes in the Y-pipe. I wasn’t able to do that as the tail pipe to Y-pipe connection was welded (although there were also clamps at the connection deceiving me into believing they were merely clamped on).

    I did this the day after I bought the car, and did not want to spend the money on Flowmasters in case that was the source of the droning. I went to O’Reilly’s and bought two Thrush turbo mufflers and some pre-bent exhaust tubing. Went home and welded up the tail pipe and mufflers and installed them, making sure to clamp them to the Y-pipe in case I wanted to change them in the future.

    I did not expect much from the two $35 mufflers, however the sound was pretty nice. Not nearly as throaty and mean as the Flowmasters, but still respectable sounding. The sound inside the car was unbelievable, in that there was no sound inside the car. This passed the wife test, which is the most important one.

    Amidst my pleasure with the sound, I noticed the throttle response had suffered. There was a noticeable lag when I stabbed the throttle which was not there prior. I deduced this was likely due to the fact there was more restriction in the exhaust having new pipes with no holes in them. I figured I would accept this for the time being as I was only into the new exhaust for less than $100 and a couple hours time, and I need to get a smog inspection before I start messing around with it.

    Here is where the confusion comes in. I got in the car the next day and the throttle response had improved substantially. Not back to where it was originally, but noticeably better than the day before. So I start reading forums and I see someone having an issue with something and wanting to reset something else. Someone else posts to run the car at 35 mph for 5 minutes and the whatever will reset itself due to the oxygen sensors correcting the fuel/air mixture.

    SO MY QUESTION…Did the throttle response improve because this Tuned Port Injection L98 is a genius of a motor and corrected the mixture, or something else, on its own because there is now more pressure in the exhaust system? Or am I just extremely lucky and should go buy a lottery ticket?

    Also on the mufflers, was the droning coming from the holes in the Y-pipe or the Flowmasters?

    Any thoughts and/or knowledge would be greatly appreciated by this brand spanking new Corvette guy.

    Thanks

  2. #2
    Member LLC5's Avatar
    Join Date
    Sep 2004
    Location
    Wa.
    Posts
    2,266
    Corvette(s)
    98 black 6spd convert.
    Post Thanks / Like
    Rides
    0

    Default

    The drone was the mufflers, not the Y pipe.

    Hesitation is not the exhaust, since it works good now. If no CEL is on, keep driving it and note when it does it, rpm's and gear, does the tach jump around etc.? Then you can carry on diagnosis.
    Master Technician

    25+ year ASE Master Certified Tech

    22+ year Honda Master Tech

  3. #3
    Member Hot Rod Roy's Avatar
    Join Date
    Jul 2005
    Location
    Mission Viejo CA
    Posts
    313
    Corvette(s)
    Yellow '84 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    You did good! Flowmasters are known for their drone. Some put up with it, because the performance is slightly better, but I would agree with the trade-off you have chosen. The ECM in these cars is pretty good, so it's likely there was some self-tuning after you had driven the car for a while, to get rid of that slight throttle lag! It's good to see that you were able to do that exhaust work yourself! Enjoy that nice car!


  4. #4
    New Member 89C4KB's Avatar
    Join Date
    May 2019
    Location
    Cameron Park, CA
    Posts
    12
    Corvette(s)
    1989 Bright Red Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Good news...I passed the "enhanced" California Smog Check inspection today!

    Thank you for the responses. After driving the car around all day today, I can't help but feel like I would like a little more oomph out of the exhaust sound. I am tempted to try a set of Magnaflow mufflers for the 200 bucks it would cost to do it. I certainly don't want to go back to the Flowmasters and the droning that comes with those. From what I have read online it seems the Magnaflows do not drone the way the Flowmasters do. Does anyone have them on their cars? And can anyone provide a comparison of the interior noise between the Flowmasters and Magnflows?

    Thanks again

  5. #5
    Member
    Join Date
    Aug 2006
    Location
    S-NJ
    Posts
    288
    Corvette(s)
    93 Ruby Aniv roadster/6spd
    Post Thanks / Like
    Rides
    0

    Default

    I trashed the mufflers on my old 85 & ran twin tipped Resonators.
    Currently 93 Ruby 40th Anniversary Roadster/6 SPD

    Previous 58,68,70,76,78,85,90

  6. #6
    New Member 89C4KB's Avatar
    Join Date
    May 2019
    Location
    Cameron Park, CA
    Posts
    12
    Corvette(s)
    1989 Bright Red Coupe
    Post Thanks / Like
    Rides
    0

    Default Damn!!!

    I was driving the Corvette yesterday when I started to feel that it had lost some pep. I initially chalked it up to the new exhaust. Then after the third start of the day, the Service Engine Soon light came on. I was originally optimistic this was merely an automatic light that came on with mileage. Then I started reading the forums and decoded the message...yep, it threw a 36

    I cleared the code and drove it again today. I was out running local errands and after the 3rd start the light was not on. After the 6th start, there it was again. I have not decoded it again because I am sure I will get another 36.

    Of note, and odd to me, it started right up when cold. As it warmed up, it started taking a few more cranks to start. Also, once it started it seemed to hiccup a little, almost like a misfire right as the engine got going. However, once driving, it ran pretty good.

    I have no history on the vehicle and do not know what the prior maintenance entailed. I'm guessing by the air filter that the service track record was less than stellar. There is also an oil change sticker on the windshield which states it is due for an oil change on 2/28/2011 or 40,185 (it now has 42,100, I guess it wasn't driven much). I was planning on changing the oil next weekend as I do that with every used car I buy. I started inspecting the spark plug wires and found the wire separators were brittle and some were broken. The number 1 and 3 wires are crossing over one another. I'm guessing these are factory plugs and wires with 42,000 miles, and the wires being 30 years old could be dried and arcing.

    My plan now is a full tune up of the Corvette to include the following;

    Oil and filter
    Air filter
    plugs
    wires
    rotor cap
    distributor cap
    fuel filter

    NEXT QUESTION: Can the car throw a Code 36 for anything other than a MAF issue? If a car is in desperate need of a tune-up, could that cause a Code 36? That is what I'm hoping for as I really don't want to be one of the next OP's on the forums about his Code 36 woes.

    Thanks for any help and thoughts

  7. #7
    Member
    Join Date
    Aug 2006
    Location
    S-NJ
    Posts
    288
    Corvette(s)
    93 Ruby Aniv roadster/6spd
    Post Thanks / Like
    Rides
    0

    Default

    Fixing Code 36 for Your Mass Air Flow Sensor
    On my old 85 I would always listen for the MAF burn off relay to click off after I shut it off,the click could be heard on the Pass side dash.

  8. #8
    New Member 89C4KB's Avatar
    Join Date
    May 2019
    Location
    Cameron Park, CA
    Posts
    12
    Corvette(s)
    1989 Bright Red Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Thanks for the response. I had already found that article in my Code 36 panic search of the internet, but still appreciate it.

    I took out the MAF sensor the other night and cleaned it with MAF spray cleaner. Reinstalled it, and a new air cleaner which the car was in desperate need of, and ran it around for about 20 minutes (to include varying levels of aggressiveness). Stopped and started the car once in the middle of the drive. By the time I returned home there was no SES light. I was happy about that, however not convinced I had accomplished anything significant as the light came on after 3 to 6 starts the previous times.

    The car is definitely not running smooth. There seems to be a minor vibration during low to mid rpm, however when I get into the throttle it smooths out and runs hard.

    We will see after the full tune-up

    Thanks for the help

  9. #9
    Member
    Join Date
    Aug 2006
    Location
    S-NJ
    Posts
    288
    Corvette(s)
    93 Ruby Aniv roadster/6spd
    Post Thanks / Like
    Rides
    0

    Default

    Your welcome,the tune up will help.
    Currently 93 Ruby 40th Anniversary Roadster/6 SPD

    Previous 58,68,70,76,78,85,90

Similar Threads

  1. First time corvette owner
    By pnykllr in forum New Member Introductions
    Replies: 9
    Last Post: 04-18-14, 04:56 PM
  2. First time Corvette owner at 65 y/o
    By C3/C4 KID in forum New Member Introductions
    Replies: 19
    Last Post: 11-14-12, 10:54 AM
  3. First Time Corvette Owner Questions
    By chuckndonna67 in forum C4 General Discussion
    Replies: 14
    Last Post: 10-24-05, 08:15 PM
  4. 1st Time owner with questions
    By redeasysport in forum C4 Technical and Performance
    Replies: 24
    Last Post: 01-23-05, 12:54 PM
  5. First time Corvette owner
    By Eyerock in forum C4 Technical and Performance
    Replies: 10
    Last Post: 01-21-02, 08:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •