$projecthp
Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    New Member
    Join Date
    Feb 2006
    Location
    MA
    Posts
    13
    Post Thanks / Like
    Rides
    0

    Default Only one horn working.

    Just wondering if horns on a 96 each have a seperate fuse or both controlled by the same one. Only 33000 on the clock but only one works.
    Thanks in advance for any info.

    Jim

  2. #2
    Member jmhorn52's Avatar
    Join Date
    Feb 2008
    Location
    Hampton VA
    Posts
    145
    Corvette(s)
    2008 Yellow ZHZ
    Post Thanks / Like
    Rides
    0

    Default

    I had the same problem, only one horn working. I found a replacement horn cheap one, my mistake it worked for 1 beep then both horns quit. I took it to the dealers and both horns were bad, the dealer replaced with GM horns not cheap $75 a piece but at least I can be heard now

  3. #3
    New Member
    Join Date
    Feb 2006
    Location
    MA
    Posts
    13
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by jmhorn52 View Post
    I had the same problem, only one horn working. I found a replacement horn cheap one, my mistake it worked for 1 beep then both horns quit. I took it to the dealers and both horns were bad, the dealer replaced with GM horns not cheap $75 a piece but at least I can be heard now

    Thanks for the info. Was kind of hoping for a fuse issue but figured it would end up the horn. Just never heard of one going at such low mi. But such is my luck.

    Thanks again,

    jim

  4. #4
    Member jmhorn52's Avatar
    Join Date
    Feb 2008
    Location
    Hampton VA
    Posts
    145
    Corvette(s)
    2008 Yellow ZHZ
    Post Thanks / Like
    Rides
    0

    Default

    One more thing any replacement horn is not a direct plug in, even the GM horn will need to have wires cut and spliced in

  5. #5
    New Member
    Join Date
    Feb 2006
    Location
    MA
    Posts
    13
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by jmhorn52 View Post
    One more thing any replacement horn is not a direct plug in, even the GM horn will need to have wires cut and spliced in
    Thanks again. Will go that way then. Hate the way it sounds now. lol

  6. #6
    Member Hot Rod Roy's Avatar
    Join Date
    Jul 2005
    Location
    Mission Viejo CA
    Posts
    315
    Corvette(s)
    Yellow '84 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    I like my Wolo horns from Pep Boys. They sound like genuine GM, and cost a lot less than that! They were even made in USA!


Similar Threads

  1. Right horn stopped working
    By Jeb in forum C4 General Discussion
    Replies: 1
    Last Post: 01-19-12, 11:22 PM
  2. Horn on 08 not working
    By ducvw2004 in forum C6 Technical and Performance
    Replies: 2
    Last Post: 10-21-09, 03:17 PM
  3. 93 - horn isn't working
    By TKellarB in forum C4 Technical and Performance
    Replies: 11
    Last Post: 04-13-06, 08:49 AM
  4. Not working..Horn and Wipers
    By Andy in forum C3 General Discussion
    Replies: 9
    Last Post: 12-14-05, 01:07 AM
  5. Horn
    By cmegga in forum C3 Technical and Performance
    Replies: 5
    Last Post: 04-01-03, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •