$projecthp
  • Part number for secondary injector relays?
  • Part number for secondary injector relays?
  • Part number for secondary injector relays?
  • Part number for secondary injector relays?

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    Fulton 1
    Guest

    Default Part number for secondary injector relays?

    Hi guys,
    I'm new to this forum, but it looks like an awesome resource.

    I'm currently trying to troubleshoot some problems I'm having with the secondaries on my 92 ZR-1. To this end I'm attempting to track down the part numbers for the secondary injector relays. There are two of these relays mounted on the rear of the driver's side wheelhouse just forward of the battery. They are labeled with the number 1257 and a schematic symbol of a relay on the top. I've been unable to confirm the part number for these relays so I can replace them.

    Anybody happen to know where I can find the correct part number or otherwise purchase a pair of these relays?

    Thanks!

  2. #2
    Chick
    Guest

    Default

    Are you losing full power mode after you've been in full power for about 30 minutes to an hour? Is that your problem?

  3. #3
    Fulton 1
    Guest

    Default

    Originally posted by Chick:
    Are you losing full power mode after you've been in full power for about 30 minutes to an hour? Is that your problem?
    No. My problem is that I'm getting a surging at part throttle. It tends to happen between 1800-2500RPM at constant light throttle. There is no power loss at WOT. I've checked the vacuum pump and it appears to be fine. According to the Helms Manual the next step is the secondary injector relays.

  4. #4
    Chick
    Guest

    Default

    OK you just didn't state what the problem was. Now you have.
    ===============

    I just want to eliminate a few things before you proceed, k?

    Are sure there are no vacuum leaks under the intake plenum and in the rear engine area. They are prone to this type of vac leak.

    Have you had the intake plenum off and looked under it and checked the vacuum lines?

    Has is been monitored with a scan tool while this condition is happening?

  5. #5
    Member
    Join Date
    Sep 2001
    Location
    Babylon NY
    Posts
    113
    Corvette(s)
    1991 White ZR1-93 Green ZR1/LSV 385 98 Convert.
    Post Thanks / Like
    Rides
    0

  6. #6
    Chick
    Guest

    Default

    You can check both of the solenoids electrically with a test meter and a power source.

    The part number can be obtained from a Chevy dealer.

    BUT in my experience what I have seen on ZR1's is the secondary port vacuum solenoid fail intermittently due to temperature, Consider my professional opinion please before you spend allot of money.

    The condition SHOULD be monitored with a scan tool to see the data of what's happening.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •