• 1990-1995 ZR-1 Secondary Port Vacuum Diagnosis
  • 1990-1995 ZR-1 Secondary Port Vacuum Diagnosis
  • 1990-1995 ZR-1 Secondary Port Vacuum Diagnosis
  • 1990-1995 ZR-1 Secondary Port Vacuum Diagnosis

Likes Likes:  0
Dislikes Dislikes:  0
Page 2 of 2 FirstFirst 12
Results 16 to 28 of 28
  1. #16
    Site Administrator Rob's Avatar
    Join Date
    Sep 2000
    Location
    "Manchestah" NH
    Posts
    13,020
    Post Thanks / Like
    Rides
    1

    Default

    Quote Originally Posted by ROUTE66
    Hi Rob. Thanks for your write up. I have a problem. My ZR1 has a vacuum leak! I called the local Chev dealer to get a new vacuum hose assemble. part #10145221, They told me they are no longer avallable from GM. Do you or anyone else know where I can find a new one? Thank You. Eli.
    Eli,

    What does that part number go to?
    1990 Chevrolet Corvette ZR-1 , 350 Stock ZF 6-speed. Stock Bright Red

  2. #17
    Member
    Join Date
    Nov 2003
    Location
    Oklahoma
    Posts
    28
    Post Thanks / Like
    Rides
    0

    Default ZR1 Vacuum Lines

    Quote Originally Posted by Rob
    Eli,

    What does that part number go to?
    Hi Rob. Thanks for responding. It's called a Secondary port vacuum hose assembly. I got that part # from your post on[Secondary port throttle vacuum leak diagnosis] In one of your pictures it shows a set of vacuum lines & down below the picture is that part#. Im the original owner of a low milage 93. The other day when I went to start it it backfired & blew off a vacuum line at the MAP sensor. I put it back on IT runs ok except sometimes it has a slite hickup when giveing it gas after up shifting. I also found a small amount of oil in the vacuum connection at the MAP sensor. So I thought I would replace the vacuum lines. Any help would be very much appreciated. Thanks.

  3. #18
    New Member
    Join Date
    Dec 2009
    Location
    MI, USA
    Posts
    3
    Post Thanks / Like
    Rides
    0

    Default

    Thank you for the great info Rob! Like the picture of the Visitors!

  4. #19
    Member abbezr1's Avatar
    Join Date
    Jun 2010
    Location
    michigan
    Posts
    42
    Post Thanks / Like
    Rides
    0

    Default

    Rob, great write up!! I'm a new member to the CAC and also a new member to the Corvette world. Being new I have been going through old post and really any info I can absorb to better understand the zr1. My z runs great and the previuos owner had the plenum off when he repaced the starter and checked for any vaccum leaks when he put everything back together. He said eveything underneath looked new, he said the dealer he bought the car from had just did a full tune up. I doubt they did. The wires and the plugs look original to me. My question is after reading this post I went out and turned the ing to the on position heard the pump come on and go off, but it came back on in about 15 seconds went off and then came back on in 15 seconds and just kept doing the same cycle. Is this normal or is this what you ment by cycling on and off? I will buy a vaccum tester this week and run a test that you outlined in this post. I want to thankyou again for so many of yours and everyone else on the forum that has the experiance with these awesome cars and shares that info with us newbeies.

  5. #20
    New Member
    Join Date
    Jan 2011
    Location
    california
    Posts
    8
    Post Thanks / Like
    Rides
    0

    Default 1990 zr1

    My vacume pump cycles on and off but has no affect on the performance of the car. As long as the pump maintains vacume why go to the trouble of replacing lines if the leak is not that bad?

  6. #21
    New Member
    Join Date
    Jan 2011
    Location
    california
    Posts
    8
    Post Thanks / Like
    Rides
    0

    Default 1990 zr1

    Are there any qualified mechanics in California that will work on the LT5 engine?

  7. #22
    New Member
    Join Date
    Jan 2011
    Location
    california
    Posts
    8
    Post Thanks / Like
    Rides
    0

    Default ZR1 Vacuum problem

    The Secondary Port Throttle Control Solenoid is not working on my 1990 ZR1 and is no longer available. The dealer can only get one that looks similar part # 1997201. The connections are slightly different.
    Anyone know if this part will work.
    Thanks

  8. #23
    New Member HAWAIIZR1's Avatar
    Join Date
    Mar 2004
    Location
    Pleasant Hill, CA
    Posts
    11
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Willard View Post
    The Secondary Port Throttle Control Solenoid is not working on my 1990 ZR1 and is no longer available. The dealer can only get one that looks similar part # 1997201. The connections are slightly different.
    Anyone know if this part will work.
    Thanks
    Good question! BUMP!

  9. #24
    Member xfirez51's Avatar
    Join Date
    Jun 2007
    Location
    Chicagoland
    Posts
    280
    Post Thanks / Like
    Rides
    0

    Default

    If this is the vacuum solenoid from a Suburban or Escalade. the answer is yes. This topic was
    recently addressed at the ZR-1 registry. the bracket is different but can be modified to work.

  10. #25
    Technical Writer for Internet & Print Media
    Join Date
    Jan 2001
    Location
    CenCoast CA
    Posts
    11,749
    Post Thanks / Like
    Rides
    0

    Default

    Use the truck part because all you need do is adapt the different bracket to the LT5. With the other choice, it sounds like you have to change the wiring and connections which may decrease reliability/durability.

    Anyone have the PN for the truck solenoid?

  11. #26
    New Member HAWAIIZR1's Avatar
    Join Date
    Mar 2004
    Location
    Pleasant Hill, CA
    Posts
    11
    Post Thanks / Like
    Rides
    0

    Default

    Thanks Dom and Hib,

    Hammer (John) sent me this link and now I remember seeing it last year: Secondary port vacuum solenoid - ZR-1 Net Registry Forums Not sure if this is from a truck or not.

    Craig

  12. #27
    Member xfirez51's Avatar
    Join Date
    Jun 2007
    Location
    Chicagoland
    Posts
    280
    Post Thanks / Like
    Rides
    0

    Default

    Craig,

    Here's the post from the Registry that explains it pretty well.

    Holding the box in my hand, ACD# 214-358 with GM# 1997212

    ZR-1 Net Registry Forums - View Single Post - Secondary port vacuum solenoid

  13. #28
    New Member HAWAIIZR1's Avatar
    Join Date
    Mar 2004
    Location
    Pleasant Hill, CA
    Posts
    11
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by xfirez51 View Post
    Craig,

    Here's the post from the Registry that explains it pretty well.

    Holding the box in my hand, ACD# 214-358 with GM# 1997212

    ZR-1 Net Registry Forums - View Single Post - Secondary port vacuum solenoid
    Thanks Dom. Man, this one is only $18 in Amazon.com; great deal on a substitute item.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •