Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    Ticking sound from engine... johnd's Avatar
    Join Date
    May 2003
    Location
    Green Bay, Wisconsin
    Posts
    240
    Corvette(s)
    1981 Corvette Spectramaster Blue
    Post Thanks / Like
    Rides
    0

    Default Ticking sound from engine...

    Ok, I had heard a ticking sound from the engine. So I took the valve covers off and sure enough a lifer was loose, so I tightened up like I have before and that always got rid of the problem...until now...

    The ticking is not subiding, is there something else I may have to look at? I am not too familiar with building engines and all but I do know the basics of keeping it running. Any ideas of what else may be making that noise?

    Thanks much,
    John D.
    1981 Corvette Construction Done!!! FOR NOW...

    http://www.cardomain.com/memberpage/536899

  2. #2
    Member 6880 Mike's Avatar
    Join Date
    Jun 2006
    Location
    The Bluegrass State
    Posts
    2,723
    Corvette(s)
    1968 convertible; 1980 L-82
    Post Thanks / Like
    Rides
    0

    Default

    Does the tick show up right away? or only after the engine is at operating temp? You could have a cracked exhaust manifold.


  3. #3
    Member Dunzvett81's Avatar
    Join Date
    Jul 2008
    Location
    Port Dover, Ont. Canada
    Posts
    69
    Corvette(s)
    1981 Dark Metallic Blue
    Post Thanks / Like
    Rides
    0

    Default

    I had this same problem last year. I replaced the cam, lifters and rods etc. The cam lobes were very worn. Now the engines purrs!! no ticking, I am pretty sure that it was contributed to the cam. Good luck with yours

  4. #4
    Member jims427400's Avatar
    Join Date
    Jun 2005
    Location
    Temperance Michigan
    Posts
    763
    Corvette(s)
    67 427 tripower,68 427 tripower,04 Z16, 62 340hp
    Post Thanks / Like
    Rides
    0

    Default

    john,
    check out my last thread on tick problem.
    I also popped off the covers and loosened the rockers untill ticking,tightened 1/4 turn,wait 10 seconds tighted another 1/4. It still ticked from right bank. I assume vave has major deposites or as mentioned earlier, cam may have an issue. I'm seriously thinking of fulling original motor and dropping in a 502 or better yet 572/620 crate..
    Good luck,
    Jim

  5. #5
    Ticking sound from engine... johnd's Avatar
    Join Date
    May 2003
    Location
    Green Bay, Wisconsin
    Posts
    240
    Corvette(s)
    1981 Corvette Spectramaster Blue
    Post Thanks / Like
    Rides
    0

    Default

    Thanks guys, I pulled the valve cover again about 4-5 hours ago and retightened the one valve giving me issues and it seems to have stopped for now. But I am with you I plan on pulling this engine and dropping in a ls2/3 after I save up a little.

    John

  6. #6
    Ticking sound from engine... johnd's Avatar
    Join Date
    May 2003
    Location
    Green Bay, Wisconsin
    Posts
    240
    Corvette(s)
    1981 Corvette Spectramaster Blue
    Post Thanks / Like
    Rides
    0

    Default

    I also dumped some sea foam in there not sure if that helped but ya never know...

Similar Threads

  1. Engine still ticking
    By sbushwhacker in forum C5 Technical and Performance
    Replies: 5
    Last Post: 01-19-08, 12:41 PM
  2. WHY KEEP ENGINE RPMS under 7000rpm
    By grumpyvette in forum General Automotive Discussion
    Replies: 13
    Last Post: 07-04-07, 08:10 AM
  3. Great forum for Oil & Lubricant information...
    By Ken in forum General Automotive Discussion
    Replies: 5
    Last Post: 06-18-05, 04:09 PM
  4. Has anyone?
    By BigBrakeFuelie in forum C3 Technical and Performance
    Replies: 2
    Last Post: 10-11-02, 01:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •