Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Member Tntruckguy's Avatar
    Join Date
    Apr 2008
    Location
    Tennessee
    Posts
    40
    Corvette(s)
    1980 L-48 Red Coupe
    Post Thanks / Like
    Rides
    0

    Default Dead Battery, again!!!!

    OK guys, I have been having a dead battery after about two days. I thought it was just a fluke but I re-charge my battery, had it checked out, and reinstalled it only to die again. Here is what I have done to the car recently. I have disconnected the oringinal antenna and replaced with aftermarket manual one. I have also remove and replaced a piece that the sunroof hinges into. It is the little odd shaped metal piece in the door frame towards the back of the car. When I remove it, some wires were attached to it. Did I do something in reinstalling this and connecting the wires back up? I am not sure if they were connected. Is the the original stock car alarm and could that be shorting out somewhere and causing my dead battery? How do you officially disconnect this item??


    Thanks to all and really enjoy reading all the post. This is great for first time Vette owners!!!

  2. #2
    Member
    Join Date
    Jan 2005
    Location
    Southern California
    Posts
    230
    Corvette(s)
    1981 Two tone silver / dr grey
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Tntruckguy View Post
    OK guys, I have been having a dead battery after about two days. I thought it was just a fluke but I re-charge my battery, had it checked out, and reinstalled it only to die again. Here is what I have done to the car recently. I have disconnected the oringinal antenna and replaced with aftermarket manual one. I have also remove and replaced a piece that the sunroof hinges into. It is the little odd shaped metal piece in the door frame towards the back of the car. When I remove it, some wires were attached to it. Did I do something in reinstalling this and connecting the wires back up? I am not sure if they were connected. Is the the original stock car alarm and could that be shorting out somewhere and causing my dead battery? How do you officially disconnect this item??


    Thanks to all and really enjoy reading all the post. This is great for first time Vette owners!!!
    If the battery problem started after you recent work, I would insure that the power wire at the antenna isn't shorting to ground / frame, the use of some electrical tape over the exposed end of the wire and a tie wrap to secure the loose end.
    Based on my shop manual the wires at the "roof" latch point are those going to the roof alarm switch, that triggers the alarm if someone removes the top after the alarm is set. I would also check the following lights aren't staying on after the car is closed up for the night; 1. Spare tire lamp (should go out automatically). 2. Glove compartment light. 3. interior dome & courtesy light (also on a timer), 4. Check hood work lamp goes out as hood is lowered (you can install after market switch to manually control hood lamp). If these check out; you may have do the fuse removal routine to isolate the current drain. Here you need a shop manual, to ID circuits that are hot all the time (no fuse) and a meter to measure current flow changes from the battery as each fuse is pulled one at a time. The above info is based on my shop manual purchased for my 81 when it was new. Hope this make sense and helps!!!

  3. #3
    Member Tntruckguy's Avatar
    Join Date
    Apr 2008
    Location
    Tennessee
    Posts
    40
    Corvette(s)
    1980 L-48 Red Coupe
    Post Thanks / Like
    Rides
    0

    Default solved the problem

    For the record, I have solved the problem. It seems that I was leaving the tops of it for the week and on he weekend the battery would be dead. All I did was pull the fuse for the alarm and my problem was solved. I know this is a little late but it might help someone else out there. Good luck to all who continue to work on your Vettes.

Similar Threads

  1. Help! Dead Battery
    By 059172Vette in forum C6 Technical and Performance
    Replies: 1
    Last Post: 05-22-09, 06:13 AM
  2. dead battery (still)
    By 1980corvettegibson in forum C3 Technical and Performance
    Replies: 19
    Last Post: 04-07-05, 11:28 AM
  3. Dead battery, please help.
    By 1980corvettegibson in forum C3 Technical and Performance
    Replies: 22
    Last Post: 03-10-05, 07:04 PM
  4. 2004 Z06 Battery completely dead after 30 days sitting, why?
    By rsimoes in forum C5 Technical and Performance
    Replies: 19
    Last Post: 02-01-05, 07:11 PM
  5. Winter Project....tending to your battery
    By C3RVETTE in forum General Automotive Discussion
    Replies: 8
    Last Post: 10-13-04, 06:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •