Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 9 of 9

Thread: M/C solenoid

  1. #1
    vietvet
    Guest

    Default M/C solenoid

    on an E4ME carb, if i have 11.6 volts at the wire to the m/c solenoid, can i assume the solenoid is bad if it is not cycleing????????? vietvet

  2. #2
    Member Stingray6974's Avatar
    Join Date
    Oct 2000
    Location
    Garland,Texas
    Posts
    494
    Post Thanks / Like
    Rides
    0

    Default

    No, the M/C solenoid is ground actuated. The ground wire from the ECM cycles the solenoid. Battery voltage remains constant.
    Mike

  3. #3
    vietvet
    Guest

    Default

    thanks stingray for the reply. all i am trying to do is see if the m/c selonoid is bad. carb quit cycleing when key is turned on and it has a rough idle. can i purposely ground it to see if it is working???????? vietvet

  4. #4
    Member Stingray6974's Avatar
    Join Date
    Oct 2000
    Location
    Garland,Texas
    Posts
    494
    Post Thanks / Like
    Rides
    0

    Default

    Jump terminals A & B on the aldl connector under the ashtray. That will put it in field service mode and should constantly cycle the solenoid.Mike

  5. #5
    vietvet
    Guest

    Default

    i did what you suggested and it will click one time and then nothing. it will click each time i touch the terminals but not a continueoes cycle. is the ecm bad????????? vietvet

  6. #6
    Member Stingray6974's Avatar
    Join Date
    Oct 2000
    Location
    Garland,Texas
    Posts
    494
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by vietvet View Post
    i did what you suggested and it will click one time and then nothing. it will click each time i touch the terminals but not a continueoes cycle. is the ecm bad????????? vietvet
    From past experience I will say it's the solenoid but the only way to be sure it to check it with a noid light. If it is the ECM it will be a quad driver failure and the check engine light will be flashing an ECM failure code.Mike

  7. #7
    Member Yallervette's Avatar
    Join Date
    Mar 2010
    Location
    Georgia
    Posts
    38
    Corvette(s)
    Yellow L81
    Post Thanks / Like
    Rides
    0

    Default m/c solenoid

    Quote Originally Posted by vietvet View Post
    i did what you suggested and it will click one time and then nothing. it will click each time i touch the terminals but not a continueoes cycle. is the ecm bad????????? vietvet
    What was the outcome? I'm now having the same problem.

  8. #8
    Member
    Join Date
    May 2003
    Location
    Netherlands
    Posts
    2,497
    Corvette(s)
    '81 Black
    Post Thanks / Like
    Rides
    0

    Default

    You can also check the M/C solenoid signal from inside the car when driving. My solenoid quites within 5 minutes. Installed the ecm in other 81 same problem. Changed ecm, still same problem. Now have a new prom on order.

    Greetings Peter

    Verstuurd vanaf mijn GT-I9195 met Tapatalk

  9. #9
    Member
    Join Date
    Dec 2013
    Location
    Auckland, New Zealand
    Posts
    924
    Corvette(s)
    1981 4 speed
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Yallervette View Post
    What was the outcome? I'm now having the same problem.
    from what I've read it seems the connector is backwards on some vettes.
    If you bridge the terminals at the wrong end of the connector it will click once. The correct terminals can be identified by a slot in the connector that would make them easier to bridge. This will also start the check engine light flashing any codes.

Similar Threads

  1. M/C Solenoid
    By Richard Cooper in forum L81 Vette Registry Forum
    Replies: 6
    Last Post: 10-17-03, 05:40 AM
  2. M/C solenoid
    By Richard Cooper in forum C3 Technical and Performance
    Replies: 0
    Last Post: 03-31-03, 06:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •