• Brake booster inline filter keeps brakeing....
  • Brake booster inline filter keeps brakeing....
  • Brake booster inline filter keeps brakeing....
  • Brake booster inline filter keeps brakeing....

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Mar 2009
    Location
    Delaware
    Posts
    45
    Post Thanks / Like
    Rides
    0

    Default Brake booster inline filter keeps brakeing....

    The inline vacum filter keeps brakeing.... Have any of you guys had this problem? I have no idea on why it doing this. I broke 2 of them today. I think each time it was under high rpm but not sure why they brake. Bad engine mount??? or possible just bad parts or to much vacum??
    im lost on this one.

  2. #2
    Registered User
    Join Date
    Sep 2007
    Location
    Gladstone Missouri
    Posts
    708
    Post Thanks / Like
    Rides
    0

    Default

    I'd bet the hose is too short or it's seeing some flex from somewhere. Wouldn't hurt to check your engine mounts- if the left one is bad and the engine is lifting that could break it, but you'd also get the fan into the shroud. Easy fix, unless you're wanting to stay correct- get a longer hose and throw that inline filter in the trash. All it does is filter any fuel vapors out before they get to the diaphragm in the booster. But the booster on my 69 is 40 years old, never had that filter, and is the one that GM installed when they built the car.

  3. #3
    Member
    Join Date
    Mar 2009
    Location
    Delaware
    Posts
    45
    Post Thanks / Like
    Rides
    0

    Default

    well just check the engine mounts. they seem ok but now I have another problem. The bushings in the shifter (hurst) are screwed. I cant get car to into 1st but 2 and 3rd and 4th are fine. also will go into backward fine too. So Now I need to change the bushings out for the hurst shifter. ..... I still dont know what the problem is the brake filter thing...

Similar Threads

  1. Power Brake Booster May Have Gone Out?
    By gearshift in forum C4 Technical and Performance
    Replies: 10
    Last Post: 08-11-11, 11:00 AM
  2. 84 brake booster / vac line
    By hotshotzny in forum C4 Technical and Performance
    Replies: 8
    Last Post: 10-23-08, 06:26 PM
  3. Installl booster / power brake in a 69, 427
    By TOR in forum C3 Technical and Performance
    Replies: 2
    Last Post: 03-31-08, 06:42 AM
  4. Brake booster rod / clevis problem
    By pbcanney in forum C3 Technical and Performance
    Replies: 5
    Last Post: 09-05-07, 06:23 PM
  5. Brake Booster and MC
    By Kritter in forum C3 Technical and Performance
    Replies: 2
    Last Post: 11-20-02, 10:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •