$projecthp
Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 10 of 10
  1. #1
    Member
    Join Date
    Jul 2008
    Location
    ligonier, PA
    Posts
    21
    Corvette(s)
    1974 coupe L82 4-speed
    Post Thanks / Like
    Rides
    0

    Default windshield washer pump

    Hello,
    On my 74 vette the windshield washer pump does not work. I replaced the outside plastic pieces with the repair kit, however that failed to work. Is there anything else that i can do, or do i just need to buy a new one??

    Thank You,
    Doug

  2. #2
    hhatton
    Guest

    Default

    buy a new one

  3. #3
    Member Vette79's Avatar
    Join Date
    Jan 2007
    Location
    Millersville, MD
    Posts
    1,392
    Corvette(s)
    1979 L-48 Black Coupe
    Post Thanks / Like
    Rides
    0

    Default

    What else have you done to resolve the issue? Do you have a shop manual?

    JEFF

  4. #4
    Member
    Join Date
    Jul 2008
    Location
    ligonier, PA
    Posts
    21
    Corvette(s)
    1974 coupe L82 4-speed
    Post Thanks / Like
    Rides
    0

    Default

    I looked in both my manuals and neither had anything about it. I have already got a repair kit and put it on but no difference. Also i replaced all of the hoses in the system along with a new cap on the reservoir. So i guess just get anew one i was just wondering if anyone knew of anything else i can do.

  5. #5
    Member Vette79's Avatar
    Join Date
    Jan 2007
    Location
    Millersville, MD
    Posts
    1,392
    Corvette(s)
    1979 L-48 Black Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Do you have power? Are you referring to the washer fluid pump under the washer fluid bottle or the wiper motor?

    JEFF

  6. #6
    Member
    Join Date
    Jul 2008
    Location
    ligonier, PA
    Posts
    21
    Corvette(s)
    1974 coupe L82 4-speed
    Post Thanks / Like
    Rides
    0

    Default

    Its the washer fluid pump right by the wiper motor but i emailed corvette world and they said to try and prime it first.

  7. #7
    Member Vette79's Avatar
    Join Date
    Jan 2007
    Location
    Millersville, MD
    Posts
    1,392
    Corvette(s)
    1979 L-48 Black Coupe
    Post Thanks / Like
    Rides
    0

    Default

    The washer fluid pump is right under the washer fluid bottle. The fuel vapor canister is right below that. I replaced both last year.

    JEFF

  8. #8
    Member
    Join Date
    Jul 2008
    Location
    ligonier, PA
    Posts
    21
    Corvette(s)
    1974 coupe L82 4-speed
    Post Thanks / Like
    Rides
    0

    Default

    On my 74 the pump is not below the bottle it is connected to the wiper motor. It pumps it threw a tube that goes threw the cap and into the reservoir. I think that the pump is just messes up.

  9. #9
    Member Vette79's Avatar
    Join Date
    Jan 2007
    Location
    Millersville, MD
    Posts
    1,392
    Corvette(s)
    1979 L-48 Black Coupe
    Post Thanks / Like
    Rides
    0

    Default

    OK. If you have power to the pump and it's not doing anything then it definitely would be time to replace it. They are somewhat inexpensive anyway.

    JEFF

  10. #10
    Member 73shark's Avatar
    Join Date
    Jun 2007
    Location
    KC, MO area
    Posts
    603
    Corvette(s)
    1973 Orange Metallic L-82 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    With a mouth full of water, take the hose from the bottle and put in your mouth and activate the pump. While active, try to force water thru it. If this doesn't get it going, then replace it.
    Save the wave

Similar Threads

  1. Hugh Oil Problem - I Really Need Help.
    By CAJUN C4 in forum C4 Technical and Performance
    Replies: 41
    Last Post: 07-11-09, 09:46 PM
  2. Another oil temp question
    By John '85 in forum C4 Technical and Performance
    Replies: 14
    Last Post: 09-27-07, 06:41 PM
  3. Oil temp before nailing it?
    By froggy47 in forum General Automotive Discussion
    Replies: 54
    Last Post: 09-17-07, 11:32 PM
  4. Great forum for Oil & Lubricant information...
    By Ken in forum General Automotive Discussion
    Replies: 5
    Last Post: 06-18-05, 05:09 PM
  5. aftermarket pan and high voluum oil pump are worth the cost
    By grumpyvette in forum General Automotive Discussion
    Replies: 1
    Last Post: 01-30-03, 07:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •