$projecthp
  • Turn signal indicator lights do not work, in my 79
  • Turn signal indicator lights do not work, in my 79
  • Turn signal indicator lights do not work, in my 79
  • Turn signal indicator lights do not work, in my 79

Results 1 to 8 of 8
  1. #1
    Member stevolwevol's Avatar
    Join Date
    May 2015
    Location
    Michigan
    Posts
    201
    Corvette(s)
    1977 light blue
    Post Thanks / Like
    Rides
    0

    Default Turn signal indicator lights do not work, in my 79

    I just picked up a 79 L48/350hr/370:1 gears. Paint is original, and great, interior is very good, all original. 67,000 miles. It has the original exhaust as well, I'm getting duels on Thursday. I have a few little issues, one is the turn signal/hazard lights don't work. Can anybody tell me the best way to correct this?
    Attached Thumbnails Attached Thumbnails e5bde4b4d35249baff9e421bcbf0f290-jpg  

  2. #2
    Member douglasamariani's Avatar
    Join Date
    May 2008
    Location
    Anaheim Hills CA.
    Posts
    146
    Corvette(s)
    2008 6.2 Coupe,1980 L48 Coupe,1968 427/4spd Coupe
    Post Thanks / Like
    Rides
    0

    Default

    First check the fuses and the connections ( diagrams can be found online). If all is good you will have to change the Turn signal switch.

  3. #3
    Member stevolwevol's Avatar
    Join Date
    May 2015
    Location
    Michigan
    Posts
    201
    Corvette(s)
    1977 light blue
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by douglasamariani View Post
    First check the fuses and the connections ( diagrams can be found online). If all is good you will have to change the Turn signal switch.
    Ok, so there is a fuse for just those indicator lights?

  4. #4
    Member douglasamariani's Avatar
    Join Date
    May 2008
    Location
    Anaheim Hills CA.
    Posts
    146
    Corvette(s)
    2008 6.2 Coupe,1980 L48 Coupe,1968 427/4spd Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Yes for the Turn and Back up

  5. #5
    Member stevolwevol's Avatar
    Join Date
    May 2015
    Location
    Michigan
    Posts
    201
    Corvette(s)
    1977 light blue
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by douglasamariani View Post
    Yes for the Turn and Back up
    Well, my backup lights work, the turn signals work also but the green dash lights that indicate do not. I am concerned that the dash will have to be removed if the bulbs are burned out.
    Likes bill81vette liked this post

  6. #6
    Member douglasamariani's Avatar
    Join Date
    May 2008
    Location
    Anaheim Hills CA.
    Posts
    146
    Corvette(s)
    2008 6.2 Coupe,1980 L48 Coupe,1968 427/4spd Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by stevolwevol View Post
    Well, my backup lights work, the turn signals work also but the green dash lights that indicate do not. I am concerned that the dash will have to be removed if the bulbs are burned out.
    Sounds like the
    bulbs are burned out...

  7. #7
    Member stevolwevol's Avatar
    Join Date
    May 2015
    Location
    Michigan
    Posts
    201
    Corvette(s)
    1977 light blue
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by douglasamariani View Post
    Sounds like the
    bulbs are burned out...
    Yes, both bulbs were burned out, had a Roberts Corvette replace them.
    Likes bill81vette liked this post

  8. #8
    Member douglasamariani's Avatar
    Join Date
    May 2008
    Location
    Anaheim Hills CA.
    Posts
    146
    Corvette(s)
    2008 6.2 Coupe,1980 L48 Coupe,1968 427/4spd Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by stevolwevol View Post
    Yes, both bulbs were burned out, had a Roberts Corvette replace them.
    Nice to see it was a simple fix
    Likes bill81vette liked this post

Similar Threads

  1. Help! Flashers work, but turn indicator also works as flashers
    By jonesyda in forum C3 Technical and Performance
    Replies: 4
    Last Post: 09-28-08, 03:28 PM
  2. Help! C1 - turn signal & brake lights....
    By Stemmer in forum C1 & C2 General and Technical Discussion
    Replies: 16
    Last Post: 08-18-08, 08:27 PM
  3. Passenger front parking lights/turn signal reading 7.0 volts? HELP
    By zackm58941 in forum C3 Technical and Performance
    Replies: 6
    Last Post: 06-13-04, 11:09 PM
  4. Turn signal won't work
    By aharris in forum C3 Technical and Performance
    Replies: 3
    Last Post: 11-06-03, 10:29 PM
  5. Turn Signal won't work
    By rhatala in forum C3 Technical and Performance
    Replies: 8
    Last Post: 03-24-02, 08:04 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •