Thanks Thanks:  0
Dislikes Dislikes:  0
Results 1 to 11 of 11

Thread: Dash Lights

  1. #1
    Member
    Join Date
    Mar 2017
    Location
    Davenport, Florida USA
    Posts
    31
    Corvette(s)
    1980 C3 Corvette Red Coupe
    Post Thanks / Like
    Rides
    0

    Default Dash Lights

    1980 C3 Corvette

    I replace the 194 lights bulbs in the dash and center console with LED bulbs. Now when I turn my lights off the buzzer on the lights stays on.

    If I pull & push the headlight switch off and on a few times the beeper will go off.

    I think it may have something to due with the reduced resistance on the circuit due to the LED bulbs drawing less current.

    Any thoughts or ideas would be appreciated.

  2. #2
    Moderator bill81vette's Avatar
    Join Date
    Jan 2004
    Location
    Troy,NY
    Posts
    4,111
    Corvette(s)
    1981 dark blue metallic
    Post Thanks / Like
    Rides
    1

    Default

    Is your key still in the ignition???

    Sent from my moto z3 using Tapatalk
    Bill and Gail...save the wave
    NCRS member 42415
    1981 St.Louis car #2735
    all matching numbers

    born Sept 18,1980
    Cruisefest 2008
    Cruisefestous 2009
    Cruisefest 2010
    Cruisefest 2011
    Cruisefest2012



    Without Trucks......
    You would be Hungry,Homeless and Naked!!!!!!



  3. #3
    Member
    Join Date
    Mar 2017
    Location
    Davenport, Florida USA
    Posts
    31
    Corvette(s)
    1980 C3 Corvette Red Coupe
    Post Thanks / Like
    Rides
    0

    Default

    My key is not in the ignition.

  4. #4
    Member LLC5's Avatar
    Join Date
    Sep 2004
    Location
    Wa.
    Posts
    2,081
    Corvette(s)
    98 black 6spd convert.
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Drwhitesr View Post
    1980 C3 Corvette

    I replace the 194 lights bulbs in the dash and center console with LED bulbs. Now when I turn my lights off the buzzer on the lights stays on.

    If I pull & push the headlight switch off and on a few times the beeper will go off.

    I think it may have something to due with the reduced resistance on the circuit due to the LED bulbs drawing less current.

    Any thoughts or ideas would be appreciated.

    Your description of cycling the headlight switch to turn off the buzzer sounds like a bad headlight switch. Do the dash, tail, park lights all go off when the buzzer is on?
    Master Technician

    25+ year ASE Master Certified Tech

    22+ year Honda Master Tech

  5. #5
    Member
    Join Date
    Mar 2017
    Location
    Davenport, Florida USA
    Posts
    31
    Corvette(s)
    1980 C3 Corvette Red Coupe
    Post Thanks / Like
    Rides
    0

    Default

    The lights do go out. It worked great until I installed the LED bulbs

  6. #6
    Member Otter's Avatar
    Join Date
    May 2005
    Location
    Maryland
    Posts
    397
    Corvette(s)
    1999 Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Drwhitesr View Post
    I think it may have something to due with the reduced resistance on the circuit due to the LED bulbs drawing less current.
    On a lot of the threads I have seen about LEDs, most state ballast resistors need to be installed. *But* most of the threads I read apply to C5s, a C3 may be a different electrical animal.

  7. #7
    Member douglasamariani's Avatar
    Join Date
    May 2008
    Location
    Anaheim Hills CA.
    Posts
    105
    Corvette(s)
    2008 6.2 Coupe,1980 L48 Coupe,1968 427/4spd Coupe
    Post Thanks / Like
    Rides
    0

    Default

    Its the LED's.... The electrical system does not have enough of a load on it.

  8. #8
    Moderator bill81vette's Avatar
    Join Date
    Jan 2004
    Location
    Troy,NY
    Posts
    4,111
    Corvette(s)
    1981 dark blue metallic
    Post Thanks / Like
    Rides
    1

    Default

    Quote Originally Posted by douglasamariani View Post
    Its the LED's.... The electrical system does not have enough of a load on it.
    Interesting....

    Sent from my moto z3 using Tapatalk
    Bill and Gail...save the wave
    NCRS member 42415
    1981 St.Louis car #2735
    all matching numbers

    born Sept 18,1980
    Cruisefest 2008
    Cruisefestous 2009
    Cruisefest 2010
    Cruisefest 2011
    Cruisefest2012



    Without Trucks......
    You would be Hungry,Homeless and Naked!!!!!!



  9. #9
    Member
    Join Date
    Dec 2013
    Location
    Auckland, New Zealand
    Posts
    931
    Corvette(s)
    1981 4 speed
    Post Thanks / Like
    Rides
    0

    Default

    I would agree if he was talking about turn signals. But as for the dash lights the load should make no difference.
    I suspect a faulty headlight switch or buzzer module. I need to check mine as I also have the same problem. Mine has also only just started, and I also Have LED dash lights (and have done for about a year now)
    Wast just looking at my diagrams, and I cannot find the circuit for the headlight warning buzzer, I have the FSM and a separate diagram and i didn't see it on either.
    Likes bill81vette liked this post

  10. #10
    Member
    Join Date
    Dec 2013
    Location
    Auckland, New Zealand
    Posts
    931
    Corvette(s)
    1981 4 speed
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by Antz81 View Post
    Was just looking at my diagrams, and I cannot find the circuit for the headlight warning buzzer, I have the FSM and a separate diagram and i didn't see it on either.
    Went to start My Vette and the battery was flat, connected the charger and the buzzer was going traced it to the same unit as the seatbelt warning buzzer. Interesting to note that giving it a little shake also stopped the buzzer. Have removed it for now and noted the connections onto the circuit board are not very tight. I'm going to try soldering them so they have a good connection and see what happens. Hopefully that solves the problem as that part doesn't seem to be available as a replacement.

  11. #11
    Member
    Join Date
    Dec 2013
    Location
    Auckland, New Zealand
    Posts
    931
    Corvette(s)
    1981 4 speed
    Post Thanks / Like
    Rides
    0

    Default

    Seems the connections onto the circuit board are to blame for my problem. Soldered them up so they don't move and after that I could not get it to buzz without turning the lights on. I'll have to keep an eye on it but it seems like a good start.

Similar Threads

  1. DASH LIGHTS
    By shulamite in forum C5 Technical and Performance
    Replies: 5
    Last Post: 01-07-17, 10:17 PM
  2. Dash lights on '81
    By Pastor David in forum C3 Technical and Performance
    Replies: 3
    Last Post: 09-30-08, 06:06 PM
  3. Tail lights and dash lights not working
    By dennisb in forum C1 & C2 General and Technical Discussion
    Replies: 4
    Last Post: 07-21-05, 10:57 AM
  4. No dash lights on my '65
    By Jack44 in forum C1 & C2 General and Technical Discussion
    Replies: 4
    Last Post: 03-16-04, 01:42 AM
  5. dash lights
    By 89blkvet in forum C4 Technical and Performance
    Replies: 10
    Last Post: 03-09-04, 09:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •