$projecthp
  • 66 lose of power when warmed up, everytime.
  • 66 lose of power when warmed up, everytime.
  • 66 lose of power when warmed up, everytime.
  • 66 lose of power when warmed up, everytime.

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    Member GULFTANGO's Avatar
    Join Date
    Apr 2003
    Location
    LIHUE HAWAII
    Posts
    32
    Corvette(s)
    1997 FAIRWAY GREEN
    Post Thanks / Like
    Rides
    0

    Default 66 lose of power when warmed up, everytime.

    My 1966 ​small block has recently given me some difficulty, after the installation of a new Edelbrock carburetor and intake manifold. A sudden loss of engine power after 15 to 30 minutes of driving. Does not stall. I turn the engine off and let it cool down. Then restart and drive until engine heats up (does not overheat) to normal operationg temperature.
    I have gone through most of the attached systems of the engine to try to troubleshoot a sudden loss of engine power, after 15 to 30 minutes of driving. I have replaced ignition coil, fuel and vacuum lines. Thinking a vapor lock possibility that I never had with previous Holly or Quadrajet carburetors, that I've driven with, in this car last 20 years. Any ideas what could be causing this?
    Last edited by GULFTANGO; 09-24-14 at 12:23 PM.

  2. #2
    Administrator Tom Bryant's Avatar
    Join Date
    Nov 2000
    Location
    Edgerton, Ohio, United States
    Posts
    7,006
    Corvette(s)
    1959 black 270hp (9/2/69) 1981 Beige L81(10/20/80)
    Post Thanks / Like
    Rides
    2

    Default

    Is the choke staying open when you accelerate after warm up? I'm not familiar with how the Edelbrock holds the choke open once warmed up but that is where I'd start.

    Tom
    NCRS 1360.............SACC 2082.............C1 Registry..............L81 Registry
    1959 Chevrolet Corvette 1981 Chevrolet Corvette , 350 L81 automatic Frost Beige

  3. #3
    New Member
    Join Date
    Sep 2014
    Location
    Just West of Cape Cod
    Posts
    4
    Corvette(s)
    1980 Maroon 350
    Post Thanks / Like
    Rides
    0

    Default

    Quote Originally Posted by GULFTANGO View Post
    My 1966 ​small block has recently given me some difficulty, after the installation of a new Edelbrock carburetor and intake manifold. A sudden loss of engine power after 15 to 30 minutes of driving. Does not stall. I turn the engine off and let it cool down. Then restart and drive until engine heats up (does not overheat) to normal operationg temperature.
    I have gone through most of the attached systems of the engine to try to troubleshoot a sudden loss of engine power, after 15 to 30 minutes of driving. I have replaced ignition coil, fuel and vacuum lines. Thinking a vapor lock possibility that I never had with previous Holly or Quadrajet carburetors, that I've driven with, in this car last 20 years. Any ideas what could be causing this?
    How bad is the power loss?

  4. #4
    66 lose of power when warmed up, everytime.
    Join Date
    Jan 2002
    Location
    Washington, Michigan
    Posts
    7,246
    Corvette(s)
    '67 Marina Blue Convertible
    Post Thanks / Like
    Rides
    0

    Default

    Sounds like fuel percolation, a common problem these days. Does the Edelbrock manifold have an exhaust crossover passage? Is it blocked? Is your heat riser valve wired open? Is the electric choke connected and adjusted properly?
    John
    '67 Convertible

Similar Threads

  1. Miss and surge once warmed up
    By Parrothead in forum C4 Technical and Performance
    Replies: 3
    Last Post: 10-10-11, 11:58 AM
  2. Need help from the pro's. 84 won't start when it's warmed up
    By packen in forum CrossFire Injection Mine
    Replies: 11
    Last Post: 09-29-10, 07:53 PM
  3. Lose the badge?
    By Aurora40 in forum C4 General Discussion
    Replies: 25
    Last Post: 04-24-06, 08:52 PM
  4. 1961 283 2x4 won't run when warmed up!!
    By Sean M in forum C1 & C2 General and Technical Discussion
    Replies: 6
    Last Post: 05-21-04, 09:48 PM
  5. When is the engine warmed up?
    By qbolyf in forum C5 Technical and Performance
    Replies: 5
    Last Post: 04-22-02, 08:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •