PDA

View Full Version : Sick C4



lomcd
04-22-04, 05:07 PM
Help, just purchased a 90 convert. really love the car but am having a problem with a miss at idle. When the car is cold, runs great but as soon as it warms up it starts to miss. So far I've changed plugs, rotor, cap, and wires. also changed o2 sensor. Also noticed a slight surging when driving. If this was happening in my Shark I'd go with carburation. I have a scanner but no codes are present and nothing really stand out. Any suggestions or help is appreciated. Thanks

malc350
04-22-04, 05:23 PM
Could be loads of things on a C4 but, after checking there are no vacuum lines disconnected or bad (corroded?) wiring connections I'd have alook at the inside of the throttle body as they are known for being affected by carbon deposits and this can affect idle and low speed running greatly.

Take a look at the "TB Revival" thread.

psychomatica
04-22-04, 05:24 PM
Hey check your rotors,wires,and other electrical,...when its getting warm they may be shorting....

Ken
04-22-04, 05:48 PM
I've changed plugs, rotor, cap, and wires. also changed o2 sensor.
;)

Describe the "miss" when it's warm. Need more information. :CAC

redvett
04-22-04, 06:03 PM
Help, just purchased a 90 convert. really love the car but am having a problem with a miss at idle. When the car is cold, runs great but as soon as it warms up it starts to miss. So far I've changed plugs, rotor, cap, and wires. also changed o2 sensor. Also noticed a slight surging when driving. If this was happening in my Shark I'd go with carburation. I have a scanner but no codes are present and nothing really stand out. Any suggestions or help is appreciated. Thanks
Take a screwdriver and with engine at temp. rap the Mass "Air Flow Sensor" with the handle several times. If the engine changes speed or misfires its the MAF senser. Only buy the Bosch not the cheap one.

drags1998
04-22-04, 06:51 PM
A 1990 vette does not have a M.A.F. its a speed dens. system.Let me know what you find, MINE does the same thing!!!!!!! I changed EVERYTHING and its better but not 100% Good Luck!!!!:D

Daryllawman
04-22-04, 07:46 PM
:w Hello and Welcome to the Corvette Action Center....as for the miss, my neighbors was the Mass Air Flow ...he put that on and the miss was gone....Enjoy !!!!!

lomcd
04-26-04, 03:54 PM
The miss is random, something like having a bad carb. I've heard this type miss discribed as a carb dropping eggs.

GiDvEtTe84
04-28-04, 01:19 PM
Sometimes a failing ignition module or coil will start to malfuntion when it gets hot. Also check your fuel pressure. Sounds like a closed loop issue.