PDA

View Full Version : need help please part 2



Customcar
04-18-04, 12:44 PM
Computer checked 86 corvette ,.
shows knock sensor fault
Where is this located ???
This car has a computer chip in it ---would this cause this problem.
I have disconnected battery for ten minute and will test drive to see if service light comes on again if so I will computer check again and go from there
Thanks Ken

Moonunit 451
04-18-04, 02:48 PM
Knock sensor is on the block, pass side about mid engine above the pan, single lead connector.

jmccloud
04-18-04, 04:16 PM
About $36 at GM dealer or Advance Auto. Same part. Your antifreeze is goint to run out when you remove the sensor. Have a big pan ready. Might as well drain the radiator and the other side of the block while you're at it. Don't use chemical flush, water only.
Pinch the knock sensor connector to remove it (like a child-proof medicine bottle). You have to look very closely or try different rotations to pinch. It comes of easily when pinched correctly.
Remote chance that it's the knock module (located in the under side of the ECM PCM or whatever it's called for your year).

MBDiagMan
04-18-04, 06:09 PM
You can check the sensor before replacing it by banging with a hammer near the sensor. I think I posted the procedure in a post for someone else about two weeks ago. If you can't search and find it, let me know and I will key it in again.

Also don't overlook the possibility of a disconnected wire or some such. Visual inspection is always worthwhile. It is also worthwhile to diagnose rather than just running out and buying parts to throw at the problem.

Good luck,

Customcar
04-18-04, 06:40 PM
I took it out today after a battery disconect and things were fine for about an hr. I shut the car down for ten min.and when I restarted it the service light came on again and stayed on for 30 min . I once again shut off the car for an hr and restarted light did not come on????

My neighbor rechecked with the computer and it read knock sensor once again.
This car has a performance chip in it and I am going to pull it tomorrow and replace with the original to see if that makes a differance. My freeind thinks it might have advanced the spark thus causing the problem
Performance chip has to be out befor tunup acording to instruction.
Ken

MBDiagMan
04-18-04, 08:01 PM
Okay, the knock sensor code is CONTINUING to come up. Why do you not want to check the knock sensor circuit. It is your next step in troubleshooting. Why do you not want to take it?

Good luck,

1Bad86
04-18-04, 08:09 PM
What he said!!:_rock

Customcar
04-18-04, 08:13 PM
Your right it will be the next step
reguards
Ken