PDA

View Full Version : 1987 Coupe won't start



Alfonso Gomez
04-05-04, 06:59 AM
The car started fine and I went to a friend's house about 3 miles from my house. When I was going to leave about an hour later I tried to start the engine, it "half started", began missing and immediately died. Tried to restart it and it was no go. The engine turned but would not start. I disconnected the electrical connection from one injector, connected a test light and had my friend start the car. The test light did not blink. Then I connected the + battery terminal to connector "G" in the ALDL and the fuel pump did not work, we could not hear it prime. We removed the fuel pump relay and put in a new one but it was no go. A nearby mechanic was called and he connected a fuel pressure gauge to the schraeder valve and fed 12 volts to the pump but the pump would not prime. The gauge read "O" pressure. He said the fuel pump went kaput. Is this test reliable? I am planning to remove the pump and test it outside the tank to verify that it is not working before I go and buy a new one. Any other suggestion? Why is it that I am not getting pulse in the injector? A broken pump can cause this? The mechanic said that the fuel pump malfunction does not cause the problem with the injector but he is not an expert in Corvettes. Right now I cannot read the codes because the battery is dead and I have to take it out to recharge it. Any help from you is really appreciated. This is my daily driver!!

MBDiagMan
04-05-04, 08:34 AM
No fuel pressure? 12Volts to pump and it still makes no fuel pressure? I don't know what other proof you need.

I would replace the fuel filter at the same time as the pump.

Good luck,

taegdh
04-05-04, 09:12 AM
Ditto the above!

For less than a c-note and an hour's time, you can swap out the fuel pump, which is the exact cause of your malady.

Just be sensible and keep atleast 1/4 tank of gas inthe car in the future, and don't smoke while you're doing the job.

Alfonso Gomez
04-05-04, 09:21 AM
Thank you guys. I already took out the pump. Then I connected it to a battery booster and it did not work, until I whacked it a couple of times. Then it started working for a while. I disconnected the booster and reconnected it and it did not work. So, it's off to the auto parts store.

spyysee
04-05-04, 09:53 AM
Isn't there also a fuse for the pump??

MBDiagMan
04-05-04, 11:38 AM
Yes there is a fuse, but he has confirmed that the pump is the culprit.

Good luck,

Alfonso Gomez
04-05-04, 05:44 PM
Good news. I took out the pump, connected it to my battery booster and it ran, but only after I gave it a whack. It ran for a while but stopped. I whacked it again, and it started to run again, so.......... I dropped it in the trash can and bought qa replacement (Federal Mogul/Carter) for $85.00 including the sock. Installed it, charged my battery, and it started right away.
Thanks for all your help, guys.

taegdh
04-05-04, 06:16 PM
You presented all the facts, and did the work, it's just a matter of time and you'll be answering questions too!