PDA

View Full Version : Blown out freeze plug



Surfer44
07-29-01, 10:04 PM
I blew out the driver's side head rear freeze plug. At the same time the plastic top on the radiator blew a gasket.( found this out after pulling the radiator.) Has ANYONE any experience at replacing the freeze plug without pulling the engine or the head? Chevy wants $150.00 for this, it's a $1.95 part. Maybe cheap considering the labor involved. I put one of the screw in type, but I'm afraid to drive it.:confused :confused

Hib Halverson
08-03-01, 04:42 PM
If you blew out a freeze plug AND you blew the seal out of the radiator, there's a chance you have a cooling system problem.

Did you overheat the engine?

Did you disable the high rpm coolant bypass?

Surfer44
08-03-01, 05:22 PM
No, to overheating. I ran through the gears up to about 120MPH coming to work (We have a private road for about 5 miles) with out a problem. I pulled in my parking spot and saw steam under the hood. I looked at my temp guage and it was mid point. I shut off the engine immediately. When it cooled down I put my hand down behind the head and found the hole for the freeze plug. CLEAN AS A WHISTLE.(NO PLUG)

I dont know anything about a high rpm BYPASS. I am wondering if the former owner put in the wrong thermostat. I have been told the original is meant to bypass at 5LBS.
Thanks for the reply.

Surfer44
08-03-01, 05:24 PM
P.S. Could I have OVERFILLED the radiator. I added water the day before because of 120+ F at my location.

Hib Halverson
08-04-01, 07:53 PM
You can't overfill the radiator because there is no filler on it. You can't overfill the high-fill bottle (the black one at the base of the windshield on the right) either, because it's intended to be full to the top. If you overfill the overflow bottle (the white one in front of the right front wheel) it'll just overflow onto the ground.

I run my ZR1 over to Henderson once in a while in the summer and I've never overheated it or blown out expansion plugs.

I'd think you must have just had a weak freeze plug. With 120 deg. ambient the system was probably making some good pressure. That said, since the car was not overheating before the plug failed, then even with the 120 ambient, the cooling system was functioning ok.

As for the thermostat, there's chance that could be the problem if the bypass spring has been locked or damaged such that it will not open. Better check it when you replace the expansion plug.

Surfer44
08-23-01, 10:42 PM
Hib, I had the radiator repaired and checked the thermostat. It is the correct one for the LT5 and the bypass spring is working freely. There is no sign of corrosion at all in the system.(very clean) Chevy did a "block test" checking for hydrocarbons emitting from the radiator and there is no blown head gasket. They are putting in the expansion plug tomorrow, the cost is $150.00, of which I am thankful I dont have to pull the engine. After I run it for awhile I'm going to pull the plenum and install all new vacuum lines and actuators (got them from Mom).
Love the cars and love being a part of the "corvette community".
P.S. We're also trying to order a 2003 Anniversary Edition Convertible 6 Spd. (with ALL options for speed and handling) in case you know of a good dealer and can reccomend how we can find out what options are available. Thanks for the reply.

Hib Halverson
08-24-01, 07:37 PM
Well, the only dealer I know of that actually deals on Corvettes is Stanford in Detroit. Wether or not, they'd deal on an 03, I don't know.

For the Anniversary car don't expect any killer new engine over what we have for 02. My guess is the 50th car is going to be an option including a special exterior and interior package.