PDA

View Full Version : "new" 81 vette



geneius4
03-26-03, 03:36 PM
Hey everybody,

I just purchased my first vette. It's an 81, dark maroon with tan leather interior, 4 speed manual. Driving it back to my home in Maryland from Missouri I noticed a few quirks, I wondered if anyone might have some advice on any or all of them. The problems:

1) after a long hill, the engine cuts out intermittently. I suspect it might be the fuel pump, having trouble moving the fuel uphill. Could it need replacing?

2) intermittent wipers dont work, although other settings do

3) power antenna wont come up

4) there is a leak in the vacuum system that operates the pop up lights, which causes the engine to misfire. I have been clamping off the vacuum line when the lights arent in use, which seems to stop the misfires, but it needs fixing.

5) previous owner had some tinting sheets in the widows, they are coming loose and i want them off, whats the best way to remove them (especially without damaging the rear window defroster)


Thanks a lot,
Gene

Daryllawman
03-26-03, 03:47 PM
Welcome to the Corvette Action Center.....Park your Vette over there by that Blue Honda Wing Hauler and come on in. Read some posts and maybe even post a few yourself....:D

Nut
03-26-03, 08:48 PM
Gene.... I'm in California for one more day on business. When I get back I'll get your address from you and come up and take a look. I live in Bowie. I'm sending you a private message. Hang in there, we'll get it fixed.

Regards........... Nut (Bob)

Rob
03-26-03, 09:22 PM
Gene,

Welcome to the Corvette Action Center. :)