Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!

Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    9
    Corvette(s)
    2009 LS3 Veocity Yellow Convertible

    Default 2009 single CD disk mp3 problem

    I just purchased a 2009 with the GPS/NAV and single disk player. When I used one of my previously recorded mp3 disks the player doesn't recognize some of the files and often will play the same file over and over. The disk has worked fine in my Lincoln and the Mustang GT I traded in on the Vette but doesn't seem to work in the new Corvette. I even tried re-burning the disks using ITunes as recommended by the dealer, but to no avail. The service department at the dealership has not experienced this problem before. Has anyone else experienced this? If so was it the radio/CD player or the way the files are burned to the disk? Any help would be greatly appreciated.

  2. #2
    New Member Björn L's Avatar
    Join Date
    May 2008
    Location
    Visby, Sweden
    Posts
    5
    Corvette(s)
    2007 Machine Silver Coupe Z51

    Default

    Watch your file names - length is critical. The nav manual for my '07 indicated maximum permissible file names of 32 characters. If you are one character longer, the structure is totally messed up and selecting from the index will play a different song, etc.

    I've made a scriptfil that changes the file names to numbers - you keep the ID3 tags (you can still see the name of the artist etc). The script also create a logfil named log.txt.
    Run the script and then burn the CD at low speed.

    Start notepad, copy this and save/name it as corvette.vbs (Good luck):

    Dim FSO, Files, FolderChooser, LogFile
    Dim Counter : Counter = 0

    Set FolderChooser = CreateObject("Shell.Application")


    Set Folder = FolderChooser.BrowseForFolder(0,"Välj Mapp",0)
    If Not Folder Is Nothing Then
    EnumerateFiles(Folder.Items.Item.Path)
    Set WshShell = CreateObject("WScript.Shell")
    LF = Folder.Items.Item.Path & "\Log.txt"
    WshShell.Run "notepad.exe """ & LF & """ "
    End If


    Sub EnumerateFiles(Folder)
    Set FSO = CreateObject("Scripting.FileSystemObject")
    Set LogFile = FSO.CreateTextFile( Folder & "\Log.txt", True)
    Set Files = CreateObject("ADOR.RecordSet")
    Files.Fields.Append "FileName", 200, 255
    Files.Open
    Set FSOFolder = FSO.GetFolder(Folder)
    For Each File In FSOFolder.Files
    If LCase(FSO.GetExtensionName(File.Name)) = "mp3" Then
    Files.AddNew
    Files("FileName") = File.Name
    Files.Update
    End If
    Next
    RenameFiles(Folder)
    LogFile.Close
    End Sub


    Sub RenameFiles(Folder)
    If Files.RecordCount > 0 Then
    Files.MoveFirst
    Randomize
    CurrentRecord = Int(Files.RecordCount*Rnd())
    Files.Move CurrentRecord
    Name = Files.Fields.Item("FileName")
    Counter = Counter + 1
    FSO.MoveFile Folder & "\" & Name, Folder & "\" & Counter & ".mp3"
    LogFile.Write Folder & "\" & Name & " Moved to: " & Folder & "\" & Counter & ".mp3" & vbCrLf & "_____________" & vbCrLf
    Files.Delete 1
    RenameFiles(Folder)
    End If
    End Sub

  3. #3
    New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    9
    Corvette(s)
    2009 LS3 Veocity Yellow Convertible

    Default

    Thanks I will give it a try. Can you tell me the step by step process once I have saved the file on the word pad. How do I run the file? Do I have to have the ITunes burn list ready to go. I tried running the file and got an error message, I must not have done it properly.

    I appreciate it

    LGRAHAME

  4. #4
    New Member Björn L's Avatar
    Join Date
    May 2008
    Location
    Visby, Sweden
    Posts
    5
    Corvette(s)
    2007 Machine Silver Coupe Z51

    Default

    Quote Originally Posted by lgrahame View Post
    Thanks I will give it a try. Can you tell me the step by step process once I have saved the file on the word pad. How do I run the file? Do I have to have the ITunes burn list ready to go. I tried running the file and got an error message, I must not have done it properly.

    I appreciate it

    LGRAHAME
    Hi,
    what kind of message did you get? - the antivirus program may stop you running the script.
    Save the file using notepad
    run (double-click) the script - chose the map with the mp3-files and confirm with <OK>
    voilá - the log file, showing this
    "C:\Media\Music\(04) The River - Bruce Springsteen.mp3 Moved to:
    C:\Media\Music\1.mp3
    _____________
    C:\Media\Music\(01) Born To Run - Bruce Springsteen.mp3 Moved to:
    C:\Media\Music\2.mp3" etc......

    Good luck!

  5. #5
    New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    9
    Corvette(s)
    2009 LS3 Veocity Yellow Convertible

    Default

    here is the Windows Script Host error message I get when I double click on the "corvette.vbs" file
    _________________________________________________________________
    Script: C:\Documents and Settings\LG\My Documents\My Music\corvette.vbs
    Line: 7
    Char: 61
    Error: Expected end of statement
    Code: 800A0401
    Source: Microsoft VBScript compilation error

    OK
    _________________________________________________________________
    I must be missing something in the process. Do I have to change any of the text within the "corvette.vbs" file?

    Does it matter what subdirectory I save the file in?

    I am not all that computer literate with regards to using VBScripting.

    Thanks for your patience.

    LGrahame

  6. #6
    New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    9
    Corvette(s)
    2009 LS3 Veocity Yellow Convertible

    Default Got your program working, but problem not solved

    I got the scripting program to work and followed your instructions to re-burn the mp3 files to a disk. When I tried the disk in the car I had the same problem as before.

    I appreciate your help and patience.

    I took the car and all the disks to the dealer this morning and they are going to have a radio specialist take a look and perhaps replace the entire radio and GPS NAV. When I got the dealer the service tech took my latest MP3 disk and tried it in a 2007 Corvette on the used car lot and the disk played all the files with no problem.

    Will keep you posted on the outcome so that if others have the same problem, they will have as much information as possible to solve it.

    Once again thanks for your help.

    LGrahame

  7. #7
    New Member Björn L's Avatar
    Join Date
    May 2008
    Location
    Visby, Sweden
    Posts
    5
    Corvette(s)
    2007 Machine Silver Coupe Z51

    Default

    Hi,

    maybe we should name the script file corvette2007.vbs?

  8. #8
    New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    9
    Corvette(s)
    2009 LS3 Veocity Yellow Convertible

    Default

    Well back to the drawing board. I took the car into the dealer, they had a "specialist" look at the problem. His disks apparently played in the system, my still wouldn't. The "specialist" was an independant contractor that does all the electronic work for the dealer, and they do not work directly with customers to try and resolve issue. So I don't know their process for burning disks. They replaced the radio and the problem was still there. The dealer suggested I use Windows Media Player or ITunes to burn my MP3 disks. Did that...wouldn't even recognize the Windows Media Player disk was in the player and the ITunes disk showed only about 12 files when in fact there were 150 burned to the disk.

    Called GM Customer Service...they have no other reports of this issue and refered me back to the dealer.

    So far I am getting some idea why GM is in trouble with their share of the market.

    Going to dig deeper online to try and find a fix.

    I would welcome any suggestions or advise that others might have for this issue.

    Thanks

  9. #9
    New Member Björn L's Avatar
    Join Date
    May 2008
    Location
    Visby, Sweden
    Posts
    5
    Corvette(s)
    2007 Machine Silver Coupe Z51

  10. #10
    Member Chrisr's Avatar
    Join Date
    Aug 2004
    Location
    Cinnaminson & Ocean City NJ
    Posts
    811
    Corvette(s)
    '07 Monterey Red/Cashmere Vert

    Default

    I had a similar problem with another vehicle I owned. The solution was fairly simple. The original CD I brunt the music to had a blue tint to it. Thus it would only play in certain players. However, when I re-burnt the disc to a silvery/chrome type CD, the disc plays in everything.

  11. #11
    New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    9
    Corvette(s)
    2009 LS3 Veocity Yellow Convertible

    Default

    Bjorn

    thanks for the link. I found the problem after many hours of experimentation and trial and error. The file names were too long. I shortened them all to under 32 characters (including the .mp3 extension) and then I burned an mp3 disc using AVS MP3 Disc Creator (the free trial edition). I couldn't get the Windows Media Player to burn a workable disc. I am going to go through and rename all of my music files and then try to burn a disc using ITunes to see if that will work for me.
    I really appreciate all of the help you sent along and also thank the others who contributed to me keeping my sanity over this issue.

    Keep the wave going:

  12. #12
    kunphuzn
    Guest

    Default Similar issue but slightly different

    First off, I want to say great forum, have learned a great deal about my 3 week old C6 here. Thanks!

    Secondly, I too am having problems with my Single Disc/Nav Stereo playing MP3's. I have burned multiple discs and when I insert into the stereo, it says it is loading the disc and then after a few moments I get a message that says no valid disc is inserted. Ugh! What in the world am I doing wrong? I am burning the files to a CD-R and they play fine on both of my computers. I'm sure it is a technical (read "user") problem but I can't figure it out for the life of me.

    Any help would be greatly appreciated!

  13. #13
    New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    9
    Corvette(s)
    2009 LS3 Veocity Yellow Convertible

    Default

    What program are you using to burn your discs? I used the Windows Media Player to burn one of my experimental discs and got the same error message in the car. It did not recognize the disc. I ended up using AVS MP3 Disc Creator (the free trial edition). and it seemed to be the easiest to use and gave me a disc that did play in the car. Just be sure you have short filenames for each song or the player won't recognize them.

    I am also going to try and make an ITunes disc once I get all my filenames shortened. It may take a week or two but at least I know it's not a problem with the player in the car.

    You might also want to take a look at the following link, it gives very detailed info about the same problem.

    Good Luck

    LGrahame

  14. #14
    New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    9
    Corvette(s)
    2009 LS3 Veocity Yellow Convertible

    Default oops forgot the link


  15. #15
    kunphuzn
    Guest

    Default

    Quote Originally Posted by lgrahame View Post
    What program are you using to burn your discs?
    Good Luck

    LGrahame
    Thanks for the reply! I had been using MSFT to no availo but I ended up being successful using Roxio to burn the disc. I selected the jukebox data option and it ended up putting some strange data files along with the music data files on the disc....but it ended up working so I was happy!

Page 1 of 2 12 LastLast

Similar Threads

  1. Bose CD problem
    By ron in forum C4 Technical and Performance
    Replies: 8
    Last Post: 08-25-03, 03:00 PM
  2. Problem with CD player
    By VTHokieVette in forum C5 Technical and Performance
    Replies: 2
    Last Post: 07-18-03, 01:41 PM
  3. Help with Bose CD Player Problem
    By Doutdoor in forum C4 Technical and Performance
    Replies: 0
    Last Post: 04-14-03, 02:14 AM
  4. factory cd player problem
    By Geof180 in forum C4 Technical and Performance
    Replies: 4
    Last Post: 02-10-03, 01:09 PM
  5. CD Changer Problem
    By rwlc5 in forum C5 Technical and Performance
    Replies: 2
    Last Post: 12-22-01, 10:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved