Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!


Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 15 of 15
  1. #1
    Member Norseman's Avatar
    Join Date
    Mar 2006
    Location
    Illinois
    Posts
    363
    Corvette(s)
    2006 Blue Z51 Coupe/2004 STi for the snow.

    Default Crap; it won't start.

    Well I tried to start my car 2 weeks ago and no joy, just a lot of clicks; then nothing. So off I go to Costco and I buy a portable jumper, compressor, light, etc. and I hook it up to my car and, no joy, just a bunch of clicks. So I get my brother to try and jump me with a pair of starter cables and his car, no joy. The lights work and all the gages light up and my radar detector turns on etc. but no motor turning over! So now I'm P.O.ed. I call the dealer and he tells me "It's probably your battery, those big V-8's are hard to start." I tell him "Right, I'm not stupid it's not the battery. I've got about 12 days left on my warranty so I'm bringing it in."
    Well I just had it picked up with a flat bed tow truck, and watched it roll off down the street between great piles of plowed snow. I think a tear rolled down my frozen right cheek.
    What I want to know is; has anyone had trouble with a starter or any solenoid issues; I've only got a little over 7,000 miles on my baby, and it's falling apart; ( OK it's not really falling apart, but it's too soon for a starter to fail.)
    My 2004 Subaru STi, has given me no problems except for a dead battery after 6 years. Ok, I guess I shouldn't have said that, but crap, I'm pissed off!
    For those who have fought for it, freedom has a taste the protected will never know. HM1 1st MAR DIV.

  2. #2
    Technical Advisor c4c5specialist's Avatar
    Join Date
    May 2001
    Location
    New Haven, Ct. USA
    Posts
    3,742
    Corvette(s)
    Nope, but someday.

    Default

    HI there,
    Fact is, when a battery goes dead, it is possible that jump starting will NOT get it started.
    C6 is especially susceptible to this.
    Duramax diesel trucks are also this way.
    That being said, make sure they install all programming updates and provide you with copies of the confirmation calibrations, which they can do.
    RCDLR and PCM for starters and possibly the BCM.
    The battery was probably toast.
    Allthebest, c4c5
    GM World Class Certified Technician.
    Like us: www.facebook.com/corvettemechanic
    http://twitter.com/GMvettemechanic
    http://thecorvettemechanic.com
    Podcast: Itunes, search 'the corvette mechanic'

  3. #3
    Member
    Join Date
    Sep 2006
    Location
    Carlsbad,Ca.
    Posts
    872
    Corvette(s)
    2006 C6Z DSOM

    Default

    Here's the thing about batteries~ You have to use them often and they'll serve you longer. If you have only driven your car 7000 miles in 3 years, then you aren't driving your car enough, according to your battery. The people that drive a hell out of their cars, are the ones that get 6-7 years of service out of their batteries. The polar opposite is true also~ if the car is rarely driven, then the battery will last 1 year (maybe less.)

    Remember, a "healthy" battery will lose 1% of charge for every idle day. That's for a healthy battery. One that has been dead and totally recharged isn't healthy anymore. They sulfate when discharged, regardless of the formula used in the electrolyte. (However, some formulas help a little, but there is no cure.)

    Get a new battery, and drive your car!

  4. #4
    Member Chrisr's Avatar
    Join Date
    Aug 2004
    Location
    Cinnaminson & Ocean City NJ
    Posts
    811
    Corvette(s)
    '07 Monterey Red/Cashmere Vert

    Default

    Norseman,
    I just went thru this exact same thing around the Holidays. As C4C5Specialist said, the battery is toast. The dealer explained there is always a draw on these cars. So if the car sits for 2 weeks or more, without being started or run, chances are the battery will be dead when you go to start it. Such was the case with mine.

    Now I have a battery tender on it to keep it peaked.

    Chris

  5. #5
    New Member
    Join Date
    Jan 2009
    Location
    Hansville. Wa
    Posts
    2
    Corvette(s)
    2007 C6

    Default Dead Battery continuing problem on C6

    Quote Originally Posted by Norseman View Post
    Well I tried to start my car 2 weeks ago and no joy, just a lot of clicks; then nothing. So off I go to Costco and I buy a portable jumper, compressor, light, etc. and I hook it up to my car and, no joy, just a bunch of clicks. So I get my brother to try and jump me with a pair of starter cables and his car, no joy. The lights work and all the gages light up and my radar detector turns on etc. but no motor turning over! So now I'm P.O.ed. I call the dealer and he tells me "It's probably your battery, those big V-8's are hard to start." I tell him "Right, I'm not stupid it's not the battery. I've got about 12 days left on my warranty so I'm bringing it in."
    Well I just had it picked up with a flat bed tow truck, and watched it roll off down the street between great piles of plowed snow. I think a tear rolled down my frozen right cheek.
    What I want to know is; has anyone had trouble with a starter or any solenoid issues; I've only got a little over 7,000 miles on my baby, and it's falling apart; ( OK it's not really falling apart, but it's too soon for a starter to fail.)
    My 2004 Subaru STi, has given me no problems except for a dead battery after 6 years. Ok, I guess I shouldn't have said that, but crap, I'm pissed off!
    I have the same problem. My 07 C6 has had dead battery at least 10 times in the last 18 mo. I keep taking to dealer and they can't find anything wrong. I just picked up car at dealer after leaving it there for 9 days and it always started at the dealership.. I have been to dealer 3 times with this problem. They have reported batt ok and so is every thing else. When I got home l left hatch and doors open to clean car. In 20 min. batt was dead. I also have never been able to jump start. I have tried this 5 or 6 times with no luck. Charged batt. and left doors and hatch open and this time the sensor shut off elec. as it should. I did it again with doors and hatch open and 20 min. later dead batt. I drive car 1500 miles/mo. Dealer is now going to put in new batt. I have to pay for cuz I have 37K on car and am out of warranty, even though car has been seen with this problem since 20k miles.
    I am willing to try anything and hate the keyless entry.
    Has anyone else had this problem? Is it a computor problem?
    Hope to hear from someone on this. steve.grether@gmail.com

  6. #6
    Patrick's Avatar
    Join Date
    Jan 2003
    Location
    5,800 feet above sea level
    Posts
    6,043
    Corvette(s)
    2006 'Evil Stealth Black' Roadster

    Default

    Hello, Steve,
    And welcome to the

    I experienced a problem similar to what you describe (although not quite as severe). I documented my experience in THIS THREAD. Have a read through, and in particular, pay attention to the posts by C4C5Specialists, and my own wrap-up to the story in post #12. There may be clues to your problem in there.



    -Patrick

  7. #7
    Member Norseman's Avatar
    Join Date
    Mar 2006
    Location
    Illinois
    Posts
    363
    Corvette(s)
    2006 Blue Z51 Coupe/2004 STi for the snow.

    Default Well, I guess I am stupid!

    I just picked my car up today and had to drive it home on icy roads! Those Goodyear's are sure slippery! Anyway, the service guy, Kinna like the Pizza Guy, said that the person who serviced my car, replaced the dead battery, (dead cell in battery), and flashed (reprogrammed the Power train Control Module Engine, reprogramming with SPS
    27 Rollinger, Glen LIC #: 6274 (I think this is the technition)
    FC: 110FF
    I also got a new 90-6yr Battery
    There was no charge!!!! They paid for the tow too!!! about 14 miles-nice. Especially since my warranty was just about to expire!
    Well I just wanted to say thanks to C5-C6 and you other guys for the input, I just finished reading the other posts here on battery drain problems with Corvettes. Holy Crap, I didn't realize it was such a problem.
    When I got my car in Feb. 2006, I had my right hip replaced, and it sat for 4 months before I was mobil enough to drive it; and it fired right up- no problem. last winter I left it sit for almost 3 months and it needed a jump start from a tow truck. Now, I'm supprised it lasted as long as it did.
    I promise to be a good Corvette owner from now on and to put more miles on my baby. Thanks again for all the great advice.
    For those who have fought for it, freedom has a taste the protected will never know. HM1 1st MAR DIV.

  8. #8
    Member
    Join Date
    Jun 2001
    Location
    Defiance, MO
    Posts
    374
    Corvette(s)
    1969 dark red convert

    Default

    Along this subject, has anyone tried the Battery Tender as insurance so your car will start and also keeping a charge thought out the winter time?

  9. #9
    vett boy's Avatar
    Join Date
    Feb 2005
    Location
    NH ,ME,FL,MS
    Posts
    3,209
    Corvette(s)
    2008 vert 6M silver

    Default

    My 08 had a battery problem with less than 200 miles .Junkie got GM to come good for it.

    C4/C5 has it pegged.

    Tenders are great when ya have power.In my case when I park mine in Florida for 4-6 weeks I disconnect the battery because I have no power.Biggest issue is to re-program a couple things .Takes less than two minutes.

  10. #10
    Member Chrisr's Avatar
    Join Date
    Aug 2004
    Location
    Cinnaminson & Ocean City NJ
    Posts
    811
    Corvette(s)
    '07 Monterey Red/Cashmere Vert

    Default

    Quote Originally Posted by Red73BB View Post
    Along this subject, has anyone tried the Battery Tender as insurance so your car will start and also keeping a charge thought out the winter time?
    See my post above. I have mine on a Battery Tender and it's doing fine.

  11. #11
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    5,313
    Corvette(s)
    03 Z-51,78 L82 Coupe

    Default

    Quote Originally Posted by vett boy View Post
    My 08 had a battery problem with less than 200 miles .Junkie got GM to come good for it.

    C4/C5 has it pegged.

    Tenders are great when ya have power.In my case when I park mine in Florida for 4-6 weeks I disconnect the battery because I have no power.Biggest issue is to re-program a couple things .Takes less than two minutes.
    High Tech gadgets from GMJunkie.com
    Introducing the "Vett Boy" C6 Battery Quick Disconnect!!


    C6 Battery Quick Disconnect!!
    Tired of Dead Battery's after just 1-2 weeks storage??
    Don't have power outlet in storage facility to power a Battery Tender???

    Well,We at GMJunkie.com have came up with a Superior Product for solution of this problem!!

    We Call it the "Vett Boy" C6 Battery Quick Disconnect!!
    Kit comes with Complete C6 Boot Up and Window Indexing Instructions meticulously plagiarized directly from your owners manual!!

    At the super low price of just $49.95 Retail!!

    CAC Members 25% off and FREE Shipping the through February!!~!!



    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *


    junk!!
    "WARNING"
    The views and opinions of this forum user might not be suitable for others, this user may appear to be heavily over-medicated, under medicated, intoxicated, listening to the voices in his head or just plain being an ass, so some viewers may be offended!~!!!
    www.gmjunkie.com
    Founding Member: 10 Corvettes Anonymous


  12. #12
    jhecox's Avatar
    Join Date
    May 2006
    Location
    Auburn Hills-MI
    Posts
    848
    Corvette(s)
    Hers: 2007 Atomic Orange, His: 2007 Machine Silver

    Default

    Hey Junkie, is that a Craftman battery disconnect? LOL

    Hecox
    Hecox

  13. #13
    jhecox's Avatar
    Join Date
    May 2006
    Location
    Auburn Hills-MI
    Posts
    848
    Corvette(s)
    Hers: 2007 Atomic Orange, His: 2007 Machine Silver

    Default

    I try to start both my C6's once a month and let them run for about 30 minutes.

    I let the wife's car go about 6 weeks and it wouldn't start, just clicked. I put jumper cables on it and it just clicked. I left the jumper cables on (with my truck running on fast idle) for about 10 minutes, just clicked. I wouldn't start. I disconnected the jumper cables, scratched my head (even the bald spot), but nothing, just clicked. I was just about to give up, when I pushed the engine OFF button to get out of the car (habit), but i noticed it clicked again. So I pushed the start button and it started right up. The battery had charged enough when the jumper cables had been attached, it started no problem.

    This happened another time, went out to start her car, it groaned and then clicked. I had waited just a little too long between starts. I put a battery charger on it for about 30 minutes. Jumped in and hit the start button, just clicked. So I pushed the engine off button then pushed the start button and it started up no problem.

    Hecox
    Hecox

  14. #14
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    5,313
    Corvette(s)
    03 Z-51,78 L82 Coupe

    Default

    Quote Originally Posted by jhecox View Post
    Hey Junkie, is that a Craftman battery disconnect? LOL

    Hecox
    No,Wrights "True Craft" !!
    Manufactured right here in Western NC!!
    Just try'n to stimulate the Local Economy!!
    junk!!
    "WARNING"
    The views and opinions of this forum user might not be suitable for others, this user may appear to be heavily over-medicated, under medicated, intoxicated, listening to the voices in his head or just plain being an ass, so some viewers may be offended!~!!!
    www.gmjunkie.com
    Founding Member: 10 Corvettes Anonymous


  15. #15
    vett boy's Avatar
    Join Date
    Feb 2005
    Location
    NH ,ME,FL,MS
    Posts
    3,209
    Corvette(s)
    2008 vert 6M silver

    Default

    Works good so far and the price was right.

Similar Threads

  1. VIN # Question
    By Vette66AirCoupe in forum C1 & C2 General and Technical Discussion
    Replies: 4
    Last Post: 10-15-04, 01:14 PM
  2. I tried to start my 454 tonight.
    By Paranoid in forum C1 & C2 General and Technical Discussion
    Replies: 44
    Last Post: 10-08-04, 02:12 PM
  3. 82 no start
    By tcolyer in forum C3 Technical and Performance
    Replies: 2
    Last Post: 09-17-04, 08:08 AM
  4. Will not start
    By Customcar in forum C4 Technical and Performance
    Replies: 5
    Last Post: 09-13-04, 02:46 AM
  5. Click..no Start...click..no Start...start...
    By racersedge52 in forum C4 Technical and Performance
    Replies: 8
    Last Post: 08-10-03, 04:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved