Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!


Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 14 of 14
  1. #1
    Member Jistari's Avatar
    Join Date
    Aug 2006
    Location
    New York
    Posts
    256
    Corvette(s)
    2001 Black on Black A4 Coupe

    Default Anyone know which ground points service ABS / TCS ?

    As many of you are aware some C5's experience intermittent DIC error codes due to inherently poorly designed grounding connections around the vehicle.
    I am getting the dreaded "TCS C1214" (Sol Valve Relay Contact or Coil CKT Open) DIC code intermittently with the associated ABS, TCS disabled indicaters on the dash.
    Although not a mechanic, I have done a fair amount of research on TCS related DIC codes and the conditions that cause them (bad grounds, water in pass footwell due to clogged AC drain, inferior parts in OEM EBCM) and have been down this road before (had my EBCM replaced last year), so this post isn't really about why I'm getting the current code (although I'm appreciative to anyone who can provide a definitive answer :-) ), it's just a question I have not seen answered anywhere:
    Thirteen ground points in C5 : G101, 102, 103, 104, 105, 106, 107, 201, 202, 301, 302, 401, 402





    So . . My question:

    Which of the thirteen grounding points on the C5 provide the ground for the components of the ABS and or TCS?


    I'm assuming they might include 101, 102, 201 and 202 (that would be both the connectors (R+L) on the frame rails under the hood and both the connectors (R+L)by the rocker panels under the dash.
    The reason I'm asking is to try and narrow down the spots to take apart and clean when this problem resurfaces during the life of the car.
    Thank to Bill C for the diagrams from a previous post and much excellent info btw ) and Thanks in advance to any respondents for your help.


    Please excuse my posting this here, should have probably been in C5 Tech. Sorry about that, don't know how to delete it. Can a Mod move it foir me?

    I liked this so much I had to put it in here :
    Quote : 67heaven "The only active handling I've got is in my butt muscles. " 502 cubic inches / 567 ft. lb. 67 Coupe :-)

  2. #2
    Member Jistari's Avatar
    Join Date
    Aug 2006
    Location
    New York
    Posts
    256
    Corvette(s)
    2001 Black on Black A4 Coupe

    Default

    I have since found that the Grounds involved are G103 and G108 (Thanks Bill C )

    The locations are as follows

    The pictures in the manual do not help much. This is from the Master Electrical Component list in the manual.

    G101 Forward lamp harness, on LH frame rail, near brake pressure modulator valve (BPMV) (CKT 150)
    G102 Forward lamp harness, on the top of the RH frame rail, behind the RH headlamp assembly, ground for SP100 (CKT 250)
    G103 Forward lamp harness, on LH frame rail, near brake pressure modulator valve (BPMV) (CKT 1250)
    G104 Instrument panel harness, below the battery tray, on the RH frame rail, ground for SP208 (CKT 851)
    G105 Engine harness, LH side bottom of engine, ground for SP122 (CKT 150)
    G106 Engine harness, RH side of the engine, above the starter (CKT 451)
    G107 Engine harness, LH side top, rear of engine (CKT 151)
    G108 Forward lamp harness, below the battery tray on the frame rail (CKT 1251

    I liked this so much I had to put it in here :
    Quote : 67heaven "The only active handling I've got is in my butt muscles. " 502 cubic inches / 567 ft. lb. 67 Coupe :-)

  3. #3
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    5,323
    Corvette(s)
    03 Z-51,78 L82 Coupe

    Default

    Did you replace your EBCM with a Genuine GM Mogul?????
    junk!!
    "WARNING"
    The views and opinions of this forum user might not be suitable for others, this user may appear to be heavily over-medicated, under medicated, intoxicated, listening to the voices in his head or just plain being an ass, so some viewers may be offended!~!!!
    www.gmjunkie.com
    Founding Member: 10 Corvettes Anonymous


  4. #4
    Member Jistari's Avatar
    Join Date
    Aug 2006
    Location
    New York
    Posts
    256
    Corvette(s)
    2001 Black on Black A4 Coupe

    Default

    Ya know, I dont know.
    It was just one of those things. The day I picked up the car from the place I bought it, the TCS error came up. The guy said they all throw codes if you let them sit in the showroom, and it would go away, or he would take care of it.
    It did go away in a few miles so I let it go.

    I started getting the code a few months later and had the car back to him a few times, each time it cleared up, but eventually came back and stayed.
    It was almost a year when the problem just stayed (none of his fixes worked). So I brought it to a real vette guru who diagmosed exactly what was wrong. Turned out to be a bad ground on circut (556 I think) that killed the sensor on the EBCM.
    Brought it back to where I bought it, showed the guy the diagnosis, and to his credit, he said I told ya Id take care of it, leave it (he fixed it no charge).
    We discussed it briefly, but I felt funny about him fixing it after a year, so I didnt dwell on it, he said he replaced the ebcm, I thanked him and left.

    It seems to be pretty much cleared up, I rarely get the error now (and this time, the one that I wrote this post about, has cleared itself up) seems to be related to low voltage. My oem delco went, so I replace it with a red top. I think the red tops die when they sit on the shelf. I brought the car back and had them test the battery and alternator, battery = good, but low charge, alternator fine.

    I'm betting the error was voltage related, its been fine when I use the car for a while now.

    When I get some time, I'll clean all the grounds.

  5. #5
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    5,323
    Corvette(s)
    03 Z-51,78 L82 Coupe

    Default

    Quote Originally Posted by Jistari View Post
    Ya know, I dont know.
    It was just one of those things. The day I picked up the car from the place I bought it, the TCS error came up. The guy said they all throw codes if you let them sit in the showroom, and it would go away, or he would take care of it.
    It did go away in a few miles so I let it go.

    I started getting the code a few months later and had the car back to him a few times, each time it cleared up, but eventually came back and stayed.
    It was almost a year when the problem just stayed (none of his fixes worked). So I brought it to a real vette guru who diagmosed exactly what was wrong. Turned out to be a bad ground on circut (556 I think) that killed the sensor on the EBCM.
    Brought it back to where I bought it, showed the guy the diagnosis, and to his credit, he said I told ya Id take care of it, leave it (he fixed it no charge).
    We discussed it briefly, but I felt funny about him fixing it after a year, so I didnt dwell on it, he said he replaced the ebcm, I thanked him and left.

    It seems to be pretty much cleared up, I rarely get the error now (and this time, the one that I wrote this post about, has cleared itself up) seems to be related to low voltage. My oem delco went, so I replace it with a red top. I think the red tops die when they sit on the shelf. I brought the car back and had them test the battery and alternator, battery = good, but low charge, alternator fine.

    I'm betting the error was voltage related, its been fine when I use the car for a while now.

    When I get some time, I'll clean all the grounds.
    I just sent mine off 2 weeks ago!!!Mine just started acting up for a couple weeks and then the Lights came on for good!!!I went with the rebuild rout because there having some trouble!!!I sent it off to a guy in Missouri and he put a up grade in it and Guarantees it for as long as I own the car!!! I could actually see cold solder joints in the board with my naked eye!!! Fed Ex picked it up on a Wed. at 4:35 PM and UPS delivered it back on Fri at 10:35 AM!!! My Active Handling,ABS and Traction control work better than they ever did even when new!!!
    junk!!
    "WARNING"
    The views and opinions of this forum user might not be suitable for others, this user may appear to be heavily over-medicated, under medicated, intoxicated, listening to the voices in his head or just plain being an ass, so some viewers may be offended!~!!!
    www.gmjunkie.com
    Founding Member: 10 Corvettes Anonymous


  6. #6
    Member
    Join Date
    Jul 2001
    Location
    Middleboro, MA
    Posts
    1,448
    Corvette(s)
    99' MR Coupe, 04' Silverado 03' ZO6 Sold

    Default

    When I was getting my service traction control soon I cleaned G101 and G102. They were both corroded with the green type oxidation. In the Bill Curlee thread he shows a few pics. of the corrosion. Sure as hell, the DIC messages went away.

  7. #7
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    5,323
    Corvette(s)
    03 Z-51,78 L82 Coupe

    Default

    Quote Originally Posted by TODD L GRIFFITH View Post
    When I was getting my service traction control soon I cleaned G101 and G102. They were both corroded with the green type oxidation. In the Bill Curlee thread he shows a few pics. of the corrosion. Sure as hell, the DIC messages went away.
    Yeah well,after cleaning every ground in the car at least twice mine didn't!!! So I sent it off!!!
    junk!!
    "WARNING"
    The views and opinions of this forum user might not be suitable for others, this user may appear to be heavily over-medicated, under medicated, intoxicated, listening to the voices in his head or just plain being an ass, so some viewers may be offended!~!!!
    www.gmjunkie.com
    Founding Member: 10 Corvettes Anonymous


  8. #8
    Member
    Join Date
    Jul 2001
    Location
    Middleboro, MA
    Posts
    1,448
    Corvette(s)
    99' MR Coupe, 04' Silverado 03' ZO6 Sold

    Default

    Quote Originally Posted by gmjunkie View Post
    Yeah well,after cleaning every ground in the car at least twice mine didn't!!! So I sent it off!!!
    Yeah, I guess you have no choice then. Good luck with it, hopefully it won't take them too long.

  9. #9
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    5,323
    Corvette(s)
    03 Z-51,78 L82 Coupe

    Default

    Quote Originally Posted by TODD L GRIFFITH View Post
    Yeah, I guess you have no choice then. Good luck with it, hopefully it won't take them too long.
    They had it back to me in less than 39 hours,with a Long as I own the car Guarantee!!After driving it now I know it always did have a problem,it was not bad enough to trip the lights!!!
    junk!!
    "WARNING"
    The views and opinions of this forum user might not be suitable for others, this user may appear to be heavily over-medicated, under medicated, intoxicated, listening to the voices in his head or just plain being an ass, so some viewers may be offended!~!!!
    www.gmjunkie.com
    Founding Member: 10 Corvettes Anonymous


  10. #10
    Member c5y2k's Avatar
    Join Date
    Oct 2005
    Location
    Gallatin, TN
    Posts
    483
    Corvette(s)
    2000 Nassau Blue Vert

    Default

    There is no substitute for high quality parts no matter where they are.

  11. #11
    Member
    Join Date
    Jul 2001
    Location
    Middleboro, MA
    Posts
    1,448
    Corvette(s)
    99' MR Coupe, 04' Silverado 03' ZO6 Sold

    Default

    Quote Originally Posted by gmjunkie View Post
    They had it back to me in less than 39 hours,with a Long as I own the car Guarantee!!After driving it now I know it always did have a problem,it was not bad enough to trip the lights!!!
    That's awesome. Can't beat that guarantee too.

  12. #12
    Member Jistari's Avatar
    Join Date
    Aug 2006
    Location
    New York
    Posts
    256
    Corvette(s)
    2001 Black on Black A4 Coupe

    Default

    Yup, with the amount of reading I've done (and help from you guys) I'll keep it in line till it goes and stays gone, then I'll do the ABSFixer upgrade. Thats definitly the way to go (even better then replacing with oem parts).

  13. #13
    Member gmjunkie's Avatar
    Join Date
    Nov 2004
    Location
    Old Fort NC/Vero Beach FL
    Posts
    5,323
    Corvette(s)
    03 Z-51,78 L82 Coupe

    Default

    Quote Originally Posted by Jistari View Post
    Yup, with the amount of reading I've done (and help from you guys) I'll keep it in line till it goes and stays gone, then I'll do the ABSFixer upgrade. Thats definitly the way to go (even better then replacing with oem parts).
    Brandon, AKA : www.ABSFixer.com is who did mine!!!Great guy,Willing to help you trouble shooting too!!!Fast Service!!!!
    junk!!
    "WARNING"
    The views and opinions of this forum user might not be suitable for others, this user may appear to be heavily over-medicated, under medicated, intoxicated, listening to the voices in his head or just plain being an ass, so some viewers may be offended!~!!!
    www.gmjunkie.com
    Founding Member: 10 Corvettes Anonymous


  14. #14
    DRTH VTR's Avatar
    Join Date
    May 2002
    Location
    Boise, Idaho
    Posts
    4,416
    Corvette(s)
    2002 electron blue Z06

    Default

    Quote Originally Posted by Jistari View Post
    Please excuse my posting this here, should have probably been in C5 Tech. Sorry about that, don't know how to delete it. Can a Mod move it foir me?
    I just saw this request. Sorry to be so slow.
    Jim
    Save the Wave!

Similar Threads

  1. Service ABS light on 1991
    By cyclist7531 in forum C4 Technical and Performance
    Replies: 2
    Last Post: 01-02-07, 06:29 PM
  2. Agressive braking causes Service ABS and Service ASR lights to come on??
    By Steve92LT1 in forum C4 Technical and Performance
    Replies: 9
    Last Post: 04-11-03, 01:49 AM
  3. ABS / Traction control service message
    By LA VETT in forum C5 Technical and Performance
    Replies: 5
    Last Post: 12-10-02, 06:16 PM
  4. Digital Dash Problem - This one's unique!
    By Mr Dark in forum C4 Technical and Performance
    Replies: 21
    Last Post: 09-05-02, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved