Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!


Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 5 of 5
  1. #1
    New Member
    Join Date
    Aug 2011
    Location
    S.E. Michigan
    Posts
    3
    Corvette(s)
    1999 Black Convertible

    Default electrical issue? Car shuts down difficult starts - dash light flicker

    Decided to join the C5 club so I traded my mint C4 vert in for a 99 vert last month (Automatic). Went out last week and car was dead not even a click. I did not even notice if the lights were on the dash. Tried to jump and would still not even turn or click. Charged battery re-installed and fired right up, drove for 1 day no problem. Came out of a store and car cranked fine just hard time firing up - had to pump pedal and hold to floor finally started and drove normal. Next day drove to work no issues, came out of work and same starting issue, had to crank car 5 - 6 time before start. was driving along at 50mpgh and car just shut down, gauges just dumped to the left and no engine. threw it in neutral and it started right up and drove home no issues. Pulled codes - lot of 1016 loss of PCM communication on all modules, these could have been old codes. Cleared all codes and was afraid to drive to work Thursday. Got in Thursday night and test started right up 2x. Friday morning, hard start and cut out on way down the driveway - checked codes only 2 this time IPC 0516 - Speedo circuit malfunction and IPC 1016 along with a RFA 1016?
    I checked the battery terminals, they are tight and I cannot see any loose wires or connectors. I am thinking now that the original issue was probably not a dead batteyr but this same issue.

    I notice that when I put the key in, the instrument panel lights will flicker rapidly and I will get the no start, hard start condition. If I remove the key and try a couple times I will finally get a clean key insert and normal instrument lighting and the car fires right up. I just ordered the FSM for 1999 C5 but wondering if any experts out there have any ideas for me? I am thinking I may have a short somewhere - but where! I also noticed that a couple times when I turned the key, I got a hard 'clunk' from what I assume was the starter. This only happened 2x and may just be because of an intermittent electrical surge?

    thanks for any idea or advice

  2. #2
    Technical Writer for Internet & Print Media
    Join Date
    Jan 2001
    Location
    Southern California
    Posts
    6,492
    Corvette(s)
    71 95 04 12

    Default

    I'm going to guess this is a wiring and connections issue.

    Since you have the FSM coming, when you get it, read the section on electrical, find all the chassis grounds and check their tightness.

    Check the connections at the PCM which under the battery.

    You might find a problem with the PCM or harness due to a leaking battery.

  3. #3
    New Member
    Join Date
    Aug 2011
    Location
    S.E. Michigan
    Posts
    3
    Corvette(s)
    1999 Black Convertible

    Default

    Quote Originally Posted by Hib Halverson View Post
    I'm going to guess this is a wiring and connections issue.

    Since you have the FSM coming, when you get it, read the section on electrical, find all the chassis grounds and check their tightness.

    Check the connections at the PCM which under the battery.

    You might find a problem with the PCM or harness due to a leaking battery.
    Yeah, I sort of figured that also. There is no sign of any battery leaking, the entire engine compartment is very clean. I started to look at the fuse connector block under the hhod and was going to pull it, it looks like besides the top cover, the entire body will 'unplug' from the lower section, but, until I get the FSM I don' t want to start pulling stuff aprt that is not meant to come apart. I think it is a short or ground issue also, when it happens, there is nothing, or just enough to clik the starter, but when the problem does not present itself, the bettry cranks like new and the car fires right up with just a touch of the key. My thought also is to check all ground bolts to start - I think this is going to be one of those PITA problems that is going to take part following instructions and part luck to resolve - thanks

  4. #4
    - Online
    Member LLC5's Avatar
    Join Date
    Sep 2004
    Location
    Wa.
    Posts
    1,129
    Corvette(s)
    98 black 6spd convert.

    Default

    Quote Originally Posted by reeferdale View Post
    Yeah, I sort of figured that also. There is no sign of any battery leaking, the entire engine compartment is very clean. I started to look at the fuse connector block under the hhod and was going to pull it, it looks like besides the top cover, the entire body will 'unplug' from the lower section, but, until I get the FSM I don' t want to start pulling stuff aprt that is not meant to come apart. I think it is a short or ground issue also, when it happens, there is nothing, or just enough to clik the starter, but when the problem does not present itself, the bettry cranks like new and the car fires right up with just a touch of the key. My thought also is to check all ground bolts to start - I think this is going to be one of those PITA problems that is going to take part following instructions and part luck to resolve - thanks


    Make sure that it's not the electrical part of the ignition switch by slowly turning the key left to right, and checking if to see you lose dash indicator lights and accessories with any small movement of the key. Good luck with it.
    Master Technician

    25+ year ASE Master Certified Tech

    22+ year Honda Master Tech

  5. #5
    New Member
    Join Date
    Aug 2011
    Location
    S.E. Michigan
    Posts
    3
    Corvette(s)
    1999 Black Convertible

    Default new info on electrical problem

    Hi all, I have torqued the battery leads and checked the body grounds. I have
    been driving the car for the past week or so and I have a definite repeatable
    set of circumstances that I can now share. I notice that when I insert the key
    and turn it to 'ON', there are times that the securtiy light flases rapidly, the
    IP lights flicker, the message line that says 'Corvette' will have garbled
    letters, and I have a light clicking under the passenger foot panel. I have
    narrowed down the issue to this exact series of events every time. If I remove
    the key and try again, I can get the issue to go away, but some times it takes
    several attempts. A few times I have wiped the key before trying again but I
    have also been sucessfull without wiping the key so wiping the key off is not
    actually required. I have verified that this issue occurs with both keys.
    If I attempt to start the car with this occuring, I just get a click from the
    starter like you would get if you had a dead battery, but the car will not
    start. I have also had 2 more incidents of the car dying on me while driving and
    I have had to remove the key and go through this procedure. Fortunatley each
    time the car has re-started and run fine. I now have my FSM, but, before I go
    tearing into random electrical diagnostics, I am just wondering what any of the
    more experienced members might suggest as a starting point.

    Also, I have
    no new codes to report. Since this occurs before engine start, I am not sure
    that any codes would be captured?
    I am thinking I should start with
    eliminating the ignition switch as a problem?

    Any one have any other
    suggestions for a good starting point(s)?

    thanks

Similar Threads

  1. Help! C4 electrical issue
    By strokin383-c4 in forum C4 Technical and Performance
    Replies: 10
    Last Post: 04-07-11, 08:04 AM
  2. starts fine but shuts down when warmed up
    By jchiniski in forum C3 Technical and Performance
    Replies: 5
    Last Post: 01-26-07, 02:52 AM
  3. Electrical Issue
    By Striker 85 in forum C4 Technical and Performance
    Replies: 7
    Last Post: 06-21-06, 09:51 AM
  4. Dash Light Issue & I’ve Checked Previous Threads….
    By yungnbord in forum C4 Technical and Performance
    Replies: 12
    Last Post: 04-06-06, 04:56 PM
  5. Electrical Issue
    By Schmucker in forum C3 Technical and Performance
    Replies: 7
    Last Post: 07-20-02, 08:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved