Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!


Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 6 of 6
  1. #1
    New Member
    Join Date
    Aug 2009
    Location
    Pasadena, Maryland
    Posts
    4
    Corvette(s)
    1999 Coupe

    Default Wipers not parking correctly

    Just recently my windshield wipers park in the middle of the stroke. They work fine when in use, but when I turn them off, the go to teh bottom adn then return to the middle of the glass. At times, when wet, they park at the proper spot. I have cleaned the utters and checked for a bent or broke parking tab but I cannot find it. Has anyone had this problem before and what fixed it? I am tempted to replace the wiper motor being that when wet, they seem to pull down like they are supposed to. HELP.

  2. #2
    6 Shooter's Avatar
    Join Date
    May 2002
    Location
    Missoura Ozarks
    Posts
    10,049
    Corvette(s)
    Millennium Yellow LS6 enhanced Roadster

    Default


  3. #3
    Member Junkman2008's Avatar
    Join Date
    Aug 2007
    Location
    Kentucky
    Posts
    503
    Corvette(s)
    2001 Navy Blue Metallic Coupe

    Default

    If your parking pawl is bent and is not stopping up against the park stop, your problem is exactly what you will experience. Check out this thread, as I explain your problem in detail. There is probably nothing wrong with your wiper motor.
    "Marines - Making the other guy die for his country for over 200 years."

  4. #4
    New Member
    Join Date
    Aug 2009
    Location
    Pasadena, Maryland
    Posts
    4
    Corvette(s)
    1999 Coupe

    Default

    GREAT. Thank you. I will pull it back apart and check the stop. Still baffles me why when raining/wet, it parks fine.

  5. #5
    Member Junkman2008's Avatar
    Join Date
    Aug 2007
    Location
    Kentucky
    Posts
    503
    Corvette(s)
    2001 Navy Blue Metallic Coupe

    Default

    Quote Originally Posted by bstasch View Post
    GREAT. Thank you. I will pull it back apart and check the stop. Still baffles me why when raining/wet, it parks fine.
    The only thing that I can think of is that the water is oiling the parking pawl and when it hits the stop, it doesn't continue to force its way around the stop. You will only need to bend the parking pawl ever so slightly to fix this problem. Don't go all Hercules and break it off. That will cause a free repair to turn into a money repair.
    "Marines - Making the other guy die for his country for over 200 years."

  6. #6
    New Member
    Join Date
    Aug 2009
    Location
    Pasadena, Maryland
    Posts
    4
    Corvette(s)
    1999 Coupe

    Default

    LMFAO...Thanks again.

Similar Threads

  1. Replies: 4
    Last Post: 05-03-11, 04:53 PM
  2. Automatic not shifting correctly
    By mikejpss in forum L81 Vette Registry Forum
    Replies: 21
    Last Post: 02-01-04, 04:26 PM
  3. degree in your cam correctly???
    By grumpyvette in forum General Automotive Discussion
    Replies: 0
    Last Post: 02-06-03, 09:40 AM
  4. Tachometer not reading correctly
    By macz28cam in forum C4 Technical and Performance
    Replies: 1
    Last Post: 09-12-02, 02:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved