Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!

Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 4 of 4
  1. #1
    Member c5y2k's Avatar
    Join Date
    Oct 2005
    Location
    Gallatin, TN
    Posts
    483
    Corvette(s)
    2000 Nassau Blue Vert

    Default Instrument cluster issues

    Working on tracking this one down. So I had not drivin the vet in about 4-6 weeks and the battery was dead so I put the charger on it (lowest setting 2amp). About 2 weeks later I pulled the charger off and jumped in started it up and off I went. Well I noticed the instrument cluster lights are not working, just the lights, gaugages and DIC work just fine. All other "things" seem to be working fine also except for the cruise control and the driving lights. I cant find anything else electrical that is not working.

    I've checked the fuses on everything related to the IC and cruise and they are all good. The driving/fog light fuse was blown. I replaced that and they are working fine now.

    I have not pulled any codes yet so I'm thinking that's my next step. I cleaned/checked the grounds about 2 years ago and they were good then but that can not hurt again.

    Any other ideas?

  2. #2
    BigJimZ16's Avatar
    Join Date
    Oct 2008
    Location
    Portage, Indiana
    Posts
    805
    Corvette(s)
    2004 Z06 CE & 2010 Grand Sport Vert JS Blue

    Default

    I know this is going to sound simplistic, but have you made sure that the IC light dimmer control is turned up? Might have bumped it by mistake...
    The only thing that you accomplish when you make something idiotproof, is breed a better grade of idiot,
    Z06/Z16 #1689

  3. #3
    Member c5y2k's Avatar
    Join Date
    Oct 2005
    Location
    Gallatin, TN
    Posts
    483
    Corvette(s)
    2000 Nassau Blue Vert

    Default

    Yup checked that and it works for all the other lights on the dimmer. Still no IC lights.

  4. #4
    BigJimZ16's Avatar
    Join Date
    Oct 2008
    Location
    Portage, Indiana
    Posts
    805
    Corvette(s)
    2004 Z06 CE & 2010 Grand Sport Vert JS Blue

    Default

    Quote Originally Posted by c5y2k View Post
    Yup checked that and it works for all the other lights on the dimmer. Still no IC lights.
    Cool beans... I just had to ask the easiest question.
    The only thing that you accomplish when you make something idiotproof, is breed a better grade of idiot,
    Z06/Z16 #1689

Similar Threads

  1. Question: US to EU Cluster Instrument
    By mimi77230 in forum C5 Z06 Discussion
    Replies: 0
    Last Post: 01-19-10, 01:30 PM
  2. Instrument Cluster
    By gaC5 in forum C5 Technical and Performance
    Replies: 2
    Last Post: 05-18-07, 05:04 PM
  3. 85 Instrument Cluster
    By WLB in forum C4 Technical and Performance
    Replies: 2
    Last Post: 12-24-03, 04:06 PM
  4. 87 LCD Instrument Cluster
    By nickjgj in forum C4 Technical and Performance
    Replies: 12
    Last Post: 06-30-02, 10:25 PM
  5. The Ol' Instrument Cluster Gag
    By Uerik in forum C4 Technical and Performance
    Replies: 6
    Last Post: 04-02-02, 06:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved