Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!


Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Dec 2006
    Location
    Central Valley, CA
    Posts
    2
    Corvette(s)
    1991

    Default Service ABS light on 1991

    The car is a 1991.

    Here is what happens:

    1. Turn ignition key to on and ABS light comes on then goes off as it should
    2. Start car and I hear the ABS pump do its whirring noise thing and then the ABS activated light come on then goes off as it should.
    3. Start driving and then the Service ABS light comes on. This light only comes on once you start moving, but stays on.

    This car has aftermarket 12" cross-drilled rotors and 17x11 AFS wheels in the back and 17x9.5 in the front.

    Tire sizes are:
    Rear - P31535ZR17
    Front - P27540ZR17


    I came across this when I noticed no ABS light at all, did some digging (I know I should have caught this but I didn't -as I beat myself up) and found that one of the ABS harnesses was upplugged under the rear storage compartment near the ABS unit. Once I plugged in the harness is when this was discovered.

    Since it only comes on once I start moving I'm wondering if it could be a wheel speed sensor or is the ABS unit getting confused because of the tire size?

    I checked the fluid in the reservoirs, the one closest to the master cylinder is at max and the other one is about a 1/4" from max.

    Thanks,
    mark

  2. #2
    Member safety_match's Avatar
    Join Date
    Dec 2002
    Location
    Vancouver, BC, Canada
    Posts
    177
    Corvette(s)
    1990 Bright Red roadster

    Default

    Quote Originally Posted by cyclist7531 View Post
    The car is a 1991.

    Here is what happens:

    1. Turn ignition key to on and ABS light comes on then goes off as it should
    2. Start car and I hear the ABS pump do its whirring noise thing and then the ABS activated light come on then goes off as it should.
    3. Start driving and then the Service ABS light comes on. This light only comes on once you start moving, but stays on.


    I came across this when I noticed no ABS light at all, did some digging (I know I should have caught this but I didn't -as I beat myself up) and found that one of the ABS harnesses was upplugged under the rear storage compartment near the ABS unit. Once I plugged in the harness is when this was discovered.



    Thanks,
    mark
    Sounds like the previous owner was hiding an ABS problem. Check the ABS sensors first, but mine was acting the same and it was the ABS computer. I found a used replacement out of a ZR1 on e-bay for $40 and it cleared up the problem.

    Safety

  3. #3
    New Member
    Join Date
    Dec 2006
    Location
    Central Valley, CA
    Posts
    2
    Corvette(s)
    1991

    Default

    Well, I would agree someone was trying to hide something. Anyways, tried two separate EBCM and still getting the same code 21 rt. speed sensor fault. Checked waveform between rt and lf front speed sensors and the rt. speed sensor is producing a different waveform than the left. What is happening is that there is a signal from the speed sensor to the EBCM but when you plug in the EBCM connector the signal goes dead. Checked all wiring between the sensor and EBCM and all appear ok. Going to try and different hub and see what that produces. Will know more tomorrow.

    Mark

Similar Threads

  1. Service Engine Soon Light
    By ReggieD in forum C4 Technical and Performance
    Replies: 20
    Last Post: 06-22-10, 09:57 PM
  2. puff of smoke and service engine soon light appears
    By nrangerZR-1 in forum C4 Corvette ZR-1
    Replies: 10
    Last Post: 05-10-05, 05:11 PM
  3. Service Engine Soon Light
    By charlieD in forum C4 Technical and Performance
    Replies: 2
    Last Post: 08-03-04, 07:20 PM
  4. Service engine light will not stay off
    By Customcar in forum C4 General Discussion
    Replies: 7
    Last Post: 05-06-04, 10:30 PM
  5. Ride Control service light
    By searay270 in forum C4 Technical and Performance
    Replies: 6
    Last Post: 09-26-02, 01:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved