Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!

Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 7 of 7
  1. #1
    Member joesroad's Avatar
    Join Date
    Aug 2006
    Location
    Florida
    Posts
    99
    Corvette(s)
    1988 Bright red Coupe

    Default 1988 Horn problems

    I need some help to find out why my horn will not work. It works when I set off the alarm but not when I press the horn button. Checked fuse is good. Replaced the horn button, Any ideas?
    Joe

  2. #2
    Member Bobsvette's Avatar
    Join Date
    May 2006
    Location
    Enfield, ct
    Posts
    211
    Corvette(s)
    96 aqua blue metallic LT-4/99 Pewter Coupe, auto

    Default

    Relay under dash?

  3. #3
    Member joesroad's Avatar
    Join Date
    Aug 2006
    Location
    Florida
    Posts
    99
    Corvette(s)
    1988 Bright red Coupe

    Default 1988 Horn problems

    Since the alarm still works I thought maybe it couldnt be the relay. Your thoughts?

  4. #4
    Member warp8's Avatar
    Join Date
    Jun 2006
    Location
    Florida
    Posts
    96

    Default

    The horn relay is activated by two sources to ground. One is the alarm. Since that works, you know the realy is good. The other source to ground is the horn switch in the steering column. I would remove the horn button and begin there.

  5. #5
    Member joesroad's Avatar
    Join Date
    Aug 2006
    Location
    Florida
    Posts
    99
    Corvette(s)
    1988 Bright red Coupe

    Default

    I installed a new horn button and made sure the power wire was plugged all the way in. Is there a switch under the steering wheel?

    Joe

  6. #6
    Member joesroad's Avatar
    Join Date
    Aug 2006
    Location
    Florida
    Posts
    99
    Corvette(s)
    1988 Bright red Coupe

    Default

    Found and corrected problem today turns out that the only thing wrong was that the contact points inside the steering wheel were pushed back to the point they were not making contact with the horn button, pretty hard to see but easy to fix. Just stuck a small screwdriver between the wheel and contacts and poped back into place. Thanks for the suggestions.
    Joe

  7. #7
    Member
    Join Date
    Jan 2004
    Location
    Newburgh, NY
    Posts
    34
    Corvette(s)
    1977 Blue Coupe, 1990 Red Coupe

    Default

    Had the same problem, replaced the spring inside the steering column

Similar Threads

  1. Horn problems on 72 Ttop
    By L88 crazy in forum C3 Technical and Performance
    Replies: 6
    Last Post: 03-14-04, 08:07 PM
  2. Horn Problems
    By 82RL in forum C3 Technical and Performance
    Replies: 11
    Last Post: 10-26-03, 01:25 AM
  3. More Horn Problems! Help.
    By SMKN97GP in forum C3 Technical and Performance
    Replies: 2
    Last Post: 08-16-03, 10:54 PM
  4. HELP! Horn problem! urgent.
    By SMKN97GP in forum C3 Technical and Performance
    Replies: 10
    Last Post: 07-15-03, 05:44 PM
  5. Steering Wheel puller? / Horn problems
    By gooney0 in forum C3 Technical and Performance
    Replies: 7
    Last Post: 03-18-03, 03:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved