Corvette Action Center - The ultimate online hub of Corvette news and information! Click here to go to the Corvette Forums!


Supporting Vendors / Dealers - Supporting Membership - Advertising Information - Corvette Amazon Shop
Results 1 to 6 of 6
  1. #1
    New Member
    Join Date
    Jul 2008
    Location
    Atlantic City
    Posts
    3

    Default 81 Corvette electrical problems

    All - I just started working on my friends 81 Corvette. She has numerous electrical problems. The power locks , right side power window, horn, radio, dash lights, gauges and their lights all do not function. At the fuse box the Fan, Gauges, Radio, and Instrument lights have no power. I notice someone has placed a 30 amp fuse in the instrument lamps fuse plug; I believe that it calls for a 7.5A. I guess the same someone also crimpted the purple and brown ingntion wires together at the base of the column. After I start the car, the alt/bat lights up. If the battery is left conected, I car will drain the battery dry. The wires at the altenatory have also been splices together, and the turn single switch work stay down for the lefthand single. Where do I start with this one?

  2. #2
    New Member
    Join Date
    Jul 2008
    Location
    Atlantic City
    Posts
    3

    Default

    oh, I forgot to mention that the interior/courtesy lights and tachometer don't work eighter.

  3. #3
    Member 21Again's Avatar
    Join Date
    Jun 2008
    Location
    SE MN
    Posts
    17
    Corvette(s)
    1981 White w/Cinnabar ; 2011 GS Vert Crystal Red

    Default Bad dash harness

    Sounds like you've got the 81 dash harness flaw. See this link: http://www.lectriclimited.com/freque..._questions.htm Look at A10 and A11. You'll probably need to send them the harness.

  4. #4
    New Member
    Join Date
    Jul 2008
    Location
    Atlantic City
    Posts
    3

    Default Wirering Harness!

    Thanks for replying so fast. I was reading the link and A11 states " If you have the dash harness that has the design flaw, then there is absolutely nothing we can do to make it right; we can not re-engineer it and we will not refurbish it." Does that mean that I could possible have a electrical problem in my wirering harness that cannot be corrected? Or is there another wirering harness that I can use. I never knew that it took GM three trie to get it right. I guess I will have to remove the old wirering harness out completely and send it to them to evaluate it. What happens if they can't correct the problem?

  5. #5
    Member 21Again's Avatar
    Join Date
    Jun 2008
    Location
    SE MN
    Posts
    17
    Corvette(s)
    1981 White w/Cinnabar ; 2011 GS Vert Crystal Red

    Default

    I spoke with LectricLimited at Bloomington Gold just last month about this design flaw issue. They said GM never did a recall because of the extensive amount of work involved with replacing the harness, plus according to GM engineers it would take more than 10 years to be a problem and it got GM around the issue of the recall. (Suffice to say if your 81 vette went up to now at 27 years without the wiring harness burning up - you've got the NON-defective one.) The problem according to LetricLimited is GM put too many items onto one of the main circuits. Specifically, the rear window defroster, pwr door locks and pwr windows all used the same bus in the fuse panel on the bad designed one. If you operate all three at the same time this will melt down the wiring harness/fuse panel and cause all kinds of shorts. If your Corvette has all three of these options then someone and or some "kid" before you played with all three at the same time and probably burned up the harness. I've seen the main harness on e-bay many times, or call LectricLimited and talk to them for some more with your issue, they may have other ideas as well not to mention the many people on this site that will chime in.

  6. #6
    New Member markwrob's Avatar
    Join Date
    Jul 2008
    Location
    Los Angeles
    Posts
    12
    Corvette(s)
    1981 L81

    Default

    Quote Originally Posted by 21Again View Post
    ...Specifically, the rear window defroster, pwr door locks and pwr windows all used the same bus in the fuse panel on the bad designed one. If you operate all three at the same time this will melt down the wiring harness/fuse panel and cause all kinds of shorts. If your Corvette has all three of these options then someone and or some "kid" before you played with all three at the same time and probably burned up the harness. ...
    I have all 3 options, pwr locks, pwr windows & defroster. Windows and defroster work but no power locks. I replaced the harneses at the back of the switches on the doors cause they looked a bit crusty, but they still don't work. Any advice would be greatly appreciated.

    Mark

Similar Threads

  1. April 2002: C5 Owners Speak Out!
    By Rob in forum Wheelspin
    Replies: 11
    Last Post: 11-23-06, 03:07 PM
  2. Electrical Question
    By Baldie88 in forum C4 Technical and Performance
    Replies: 11
    Last Post: 09-02-06, 07:33 AM
  3. 2000 Roadster Electrical Problems
    By rharule in forum C5 Technical and Performance
    Replies: 7
    Last Post: 04-25-02, 01:41 AM
  4. electrical problems
    By BubbleHead in forum C4 Technical and Performance
    Replies: 4
    Last Post: 07-25-01, 11:27 AM
  5. Brake Problems on my 81
    By JHL in forum C3 Technical and Performance
    Replies: 1
    Last Post: 11-27-00, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© CORVETTE is a registered trademark of the General Motors Corporation & Chevrolet Motor Division.  Neither Chevrolet Motor Division nor any subsidiaries of GM© shall bear any responsibility for CorvetteActionCenter.com content, comments, or advertising. CorvetteActionCenter.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved